Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Массив в 1С 8.3

Массив в 1С 8.3
Я
   dagermore
 
03.09.21 - 10:31
Вопрос такой, как в массиве 1С удалить человека т.е. стандартная фишка с Массив.Удалить() не подходит так как она удаляет значение с типом число. Мне нужно либо сделать так чтобы оно удаляло тип-"строку" или как вообще удалить строку в массиве?
   Мультук
 
1 - 03.09.21 - 10:38
(0)

массив.Найти
Массив.Удалить

Еще будет нужен оператор ЕСЛИ
   ДенисЧ
 
2 - 03.09.21 - 10:40
" она удаляет значение с типом число"

Мы тут посовещались и решили попросить телефон вашего дилера...
   dagermore
 
3 - 03.09.21 - 10:43
(2) Дилера нет база используется в личных целях я новичок
   RomaH
 
4 - 03.09.21 - 10:43
"как в массиве 1С удалить человека"
для начала надо этого человека в этот массив засунуть, но он туда не влезет - ответ никак
   ДенисЧ
 
5 - 03.09.21 - 10:45
(3) Дилера нет - что, сами выращиваете? Неплохо получается.. В Афганистане учились?
   dagermore
 
6 - 03.09.21 - 10:46
(4) Ну у меня уже создан массив где засунуты все сотрудники. Просто я хотел бы узнать возможно ли сделать выборку или что-то в этом роде чтобы удалить определенного сотрудника который выводится там.
   dagermore
 
7 - 03.09.21 - 10:47
(5) Я вас понял по вашему теперь самостоятельное изучение 1с является преступлением?
   ДенисЧ
 
8 - 03.09.21 - 10:51
(7) Нет. Но употребление веществ, после которых рождаются перлы "она удаляет значение с типом число" - законом точно не поощряется...
   Ненавижу 1С
 
9 - 03.09.21 - 10:54
(0) метод Удалить требует индекс
индекс можно получить через метод Найти

Пока Истина Цикл
        Индекс = Массив.Найти(Значение);
        Если Индекс=Неопределено Тогда
            Прервать;        
        КонецЕсли; 
        Массив.Удалить(Индекс);    
    КонецЦикла;
   dagermore
 
10 - 03.09.21 - 10:56
(8) Я вас понял. Сейчас бы считать неверное изложение мысли незаконным преступлением! Если не помогаете могли бы и не делать замечаний как мне кажется, так как от них не будет никакого толка в дальнейшем, но если вас это ставит выше других и вы как-то пытаетесь этим кого-то задеть, то очень уж зря.
   VladZ
 
11 - 03.09.21 - 11:01
(0) Давай начнем сначала: зачем удалять из массива? Кто положил в массив то, чего там быть не должно?
   VladZ
 
12 - 03.09.21 - 11:02
+11 Опиши задачу целиком. Есть основания полагать, что ты делаешь что-то не то.
   dagermore
 
13 - 03.09.21 - 11:07
(12) Так крч у меня есть документ в котором реквизит ссылается на справочник сотрудники. Я создал массив в котором все эти сотрудники отбираются по должностям. Т.е. теперь выводятся только те сотрудники у которых определенная должность. Теперь я поставил себе задачу сделать так чтобы одного из сотрудников программа не видела (тип скрыть или как-то так), но не удаляя его из самого справочника и не меняя ему должность.
   VladZ
 
14 - 03.09.21 - 11:10
(13) Основная задача массива в 1С - передать параметры в запрос. Во всех остальных случаях - есть другие механизмы. Переделывай.
   Гипервизор
 
15 - 03.09.21 - 11:11
(13) Выводятся где? Одного из сотрудников чтобы не видела где? При выборе сотрудника в форме документа?
   dagermore
 
16 - 03.09.21 - 11:13
(15) Ну да в реквизите где я выбираю сотрудников там выводится список где я хочу одного скрыть т.е. чтобы его невозможно было выбрать или чтобы он вообще не светился в списке
   dagermore
 
17 - 03.09.21 - 11:13
(14) С запросом эту фишку проделать у меня проблем нет. С запроса перешел на массив.
   VladZ
 
18 - 03.09.21 - 11:14
(17) Таблицу значений еще посмотри.
   VladZ
 
19 - 03.09.21 - 11:15
(18) Обрати внимание на НайтиСтроки.
   unbred
 
20 - 03.09.21 - 11:16
(14) улыбнуло. надеешься устроить тут холивар?)
   acht
 
21 - 03.09.21 - 11:17
(17) > С запроса перешел на массив.
ДенисЧ, это, кажись, не Aфганистан а Колумбия...
   acht
 
22 - 03.09.21 - 11:17
(16) Ты какие-нибудь курсы проходил?
   dagermore
 
23 - 03.09.21 - 11:18
(22) Нет самообучение.
   unbred
 
24 - 03.09.21 - 11:19
   dagermore
 
25 - 03.09.21 - 11:19
(22) Если с изучением будут проблемы то думаю пойду на курсы для их решения, но думаю критиковать новичка это не то что требовалось бы в данной ситуации!
   Ненавижу 1С
 
26 - 03.09.21 - 11:20
(25) я тебе на твой вопрос в (9) написал ответ
   dagermore
 
27 - 03.09.21 - 11:20
(24) Это я изучил!
   acht
 
28 - 03.09.21 - 11:20
(23) > будут проблемы
Уже есть.
   unbred
 
29 - 03.09.21 - 11:20
(26) +
   unbred
 
30 - 03.09.21 - 11:21
(27) нет
 
 
   dagermore
 
31 - 03.09.21 - 11:21
(26)Все норм, но думал еще решений подкинут.
   vladoe69
 
32 - 03.09.21 - 11:22
"Я создал массив в котором все эти сотрудники отбираются по должностям"... Зачем включил в массив этого сотрудника?
   dagermore
 
33 - 03.09.21 - 11:23
(28) Где проблемы? Их нет! Я не считаю что массивы это проблема. Форумы как по мне созданы для ответа на такие вопросы, но я почему-то смотрю тут есть особо умные люди которые критикуют новичков. А смысл от этого? Не понятно.
   dagermore
 
34 - 03.09.21 - 11:24
(32) Я в массив включил справочник где выводятся сотрудники, а не отдельно каждого в этом вся проблема
   unbred
 
35 - 03.09.21 - 11:25
(34) верной дорогой идёте, товарищ)
   Иванович Михаил
 
36 - 03.09.21 - 11:25
(34) Поработайте над формулировкой мыслей.
   acht
 
37 - 03.09.21 - 11:26
(33) > как по мне
Почему все тупые такие борзые?
   Ненавижу 1С
 
38 - 03.09.21 - 11:27
(37) соответственно не надо им уподобляться
   dagermore
 
39 - 03.09.21 - 11:27
(37) Честно говоря тут уже не ко мне вопрос. Я вроде спокойно отвечаю, а вы тут раздуваете из мухи слона. Зачем? До сих пор непонятно.
   Иванович Михаил
 
40 - 03.09.21 - 11:28
(39) ответь на (32)
   acht
 
41 - 03.09.21 - 11:28
(38) Точно.
Ну, собственно вот это отлично удерживает от оказания помощи.
   dagermore
 
42 - 03.09.21 - 11:29
(41) Собственно от вас я помощи как раз и не видел, чтобы удерживать ее!)))
   dagermore
 
43 - 03.09.21 - 11:30
(36) Да спасибо учту!
   dagermore
 
44 - 03.09.21 - 11:30
(40) Я же ответил
   Иванович Михаил
 
45 - 03.09.21 - 11:31
(44) Нет.
   Иванович Михаил
 
46 - 03.09.21 - 11:32
(44) И второй вопрос - зачем массив если всё равно все элементы справочника показываешь?
   Ненавижу 1С
 
47 - 03.09.21 - 11:32
(44) Вам как бы намекают, что крайне желательно получать сразу запросом нужные данные и только их, а не удалять их потом дополнительно
   Иванович Михаил
 
48 - 03.09.21 - 11:34
(47) Есть подозрение, что товарищ не понял код из (9), вот и ищет другое решение.
   dagermore
 
49 - 03.09.21 - 11:36
(47) Так объясню. Я сделал запрос чтобы сотрудники просто выводились и через массив решил сделать что-то вроде отбора (отбор вроде, но уже из-за людей которые критикуют часто я начинаю быть неуверенным в том что говорю).
   dagermore
 
50 - 03.09.21 - 11:37
(48) Нет же. Я говорю что просто изучаю и увидеть альтернативные решения для меня только +
   dagermore
 
51 - 03.09.21 - 11:39
Ладно я понял. Всем спасибо. Удачного дня!!!
   Иванович Михаил
 
52 - 03.09.21 - 11:40
(49) Зачем массив? Почему сразу не получить то, что нужно?
   dagermore
 
53 - 03.09.21 - 11:42
(52) Изучение нового. Вдруг при трудоустройстве в какую-либо компанию там будет код с массивами.
   VladZ
 
54 - 03.09.21 - 11:42
(49) Зачем тебе "что-то вроде отбора"?
   unbred
 
55 - 03.09.21 - 11:43
как делаешь ты:
выбрать * из сотрудники
для каждого сотрудник из ТЗСотрудники цикл
 массивСотрудников.Добавить(Сотрудник)
КонецЦикла
для каждого Сотрудник из МассивСотрудников Цикл
Если Сотрудник не не нужен Тогда
  читай код в (9) 
КонецЕсли

как надо:
выбрать НУЖНЫЕСотрудники из Сотрудники
   dagermore
 
56 - 03.09.21 - 11:47
(55) Вот у меня можно сказать угадали с кодом. Только массив идет за запросом, а так идентично
   eTmy
 
57 - 03.09.21 - 11:50
(10) С вылуплением! Добро пожаловать в мир мисты)
   Иванович Михаил
 
58 - 03.09.21 - 11:53
(56) В смылсе, "идет за запросом"?
   dagermore
 
59 - 03.09.21 - 11:55
(58) Я сам не понял че написал. Не увидел тут Цикл.
   dagermore
 
60 - 03.09.21 - 11:57
(58) Запутался одним словом
 
 
   dagermore
 
61 - 03.09.21 - 11:58
Ладно не надо других решений спасибо кто помог! Сам как-нибудь подумаю и попробую
   unbred
 
62 - 03.09.21 - 11:59
(61) учи запросы, а не массивы.
массивы сами придут.


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.