Вход | Регистрация
 

Как передать в процедуру печати БСП доп. параметры?

Как передать в процедуру печати БСП доп. параметры?
Я
   toypaul
 
03.09.21 - 10:25
И не просто статичные параметры, которые можно объявить при добавлении команды, а параметры, которые определяются (выбором в форме) перед печатью.
   toypaul
 
1 - 03.09.21 - 10:36
Ничего лучше не придумалось ...

Процедура ПередатьВПараметрыКоманды(ИмяКоманды, ДополнительныеПараметры)

    АдресКомандПечатиВоВременномХранилище = ЭтотОбъект.Команды.Найти("АдресКомандПечатиВоВременномХранилище").Действие;
    КомандыПечати = ПолучитьИзВременногоХранилища(АдресКомандПечатиВоВременномХранилище);
    НайденныеСтроки = КомандыПечати.НайтиСтроки(Новый Структура("ИмяКомандыНаФорме", ИмяКоманды));
    
    Для каждого КомандаПечати Из НайденныеСтроки Цикл
    
        Для каждого Элемент Из ДополнительныеПараметры Цикл
        
            КомандаПечати.ДополнительныеПараметры.Вставить(Элемент.Ключ, Элемент.Значение);
        
        КонецЦикла; 
    
    КонецЦикла; 
    
    ПоместитьВоВременноеХранилище(КомандыПечати, АдресКомандПечатиВоВременномХранилище);

КонецПроцедуры

вызывается из команды обработки печати


ДополнительныеПараметры = Новый Структура;
ДополнительныеПараметры.Вставить("МойПараметр", МойПараметр);
ПередатьВПараметрыКоманды(КомандаДопПараметр.Имя, ДополнительныеПараметры);

УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(КомандаДопПараметр, ЭтотОбъект, Объект);
   runoff_runoff
 
2 - 03.09.21 - 13:44
может пойти другим путем.. создать печатную форму БСП с выполнением на клиенте (клиентский метод).. а потом получать параметры из ВладелецФормы?..
   toypaul
 
3 - 03.09.21 - 13:55
(2) слишком муторно. кроме того у меня не внешняя ПФ
   runoff_runoff
 
4 - 03.09.21 - 15:11
годится для внешних или из расширения..

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.