Вход | Регистрация
    1  2  3   

Написал хотелку по передаче формы с клиента в серверный общий модуль.

Написал хотелку по передаче формы с клиента в серверный общий модуль.
Я
   Гений 1С
 
02.09.21 - 18:08
Сюда написал (не спортлото, чай)? https://github.com/SeiOkami/OneS/issues/86
А вы что скажете, вот текст иссью:

В 1С на УФ можно из серверного кода формы передать форму как параметр в серверный общий модуль. И далее из серверного общего модуля в другой серверный общий модуль.
Но из клиенского кода формы и из клиентского модуля невозможно передать форму в серверный общий модуль.
Можно передать форму только из клиентского кода формы в серверный код формы.

Для решения проблемы из клиентского кода формы или клиентского общего модуля вызывают серверный метод формы, который уже передает форму в серверный общий модуль.

Это крайне ужасное решение, которое провоцирует весь код писать в форме, не разнося ее по модулям. Нужно как можно скорее убрать это противоречивое ограничение.
   Maniac
 
101 - 03.09.21 - 12:37
На самом деле я не понял что Геня изобрел. в типовой полно глобальников где передается форма.
У меня даже есть такие процедуры некоторые - потому что например условные оформления для формы можно только на сервере программно управлять.
А в типовой вообще это на раз два.
Что Геня придумал - вообще не понял. очередной припадок видимо гениальности.
   Maniac
 
102 - 03.09.21 - 12:39
О придумал параметр передаваемый в процедуре? Типа???

&НаСервере
Процедура УстановитьУсловноеОформлениеСтрок(Объект,ФормаОбъекта,ЭлементОбъекта,ЭлементФормы) Экспорт
   Вафель
 
103 - 03.09.21 - 12:41
(93) не нужно передавать ссылку на форму на сервер.
форма живет и на сервере и на клиенте.
те при передаче формы с клиента на сервер, должна придти ссылка на серверную часть
   Вафель
 
104 - 03.09.21 - 12:42
сейчас конечно это невозможно ибо пытается на сервер попасть именно клиентская часть.
   Maniac
 
105 - 03.09.21 - 12:45
Из клиенской процедуры - создается серверная процедура.
После того как форма синхронизировалась с серверной частью там уже можно любые глобальники юзать.
   Maniac
 
106 - 03.09.21 - 12:49
в том числе в которых передавать параметр формы, для того чтобы обращаться к реквизитам и данным в этих реквизитах как вздумается.
Иногда можно делать просто глобальные серверные процедуры, в которые передавать структурой любые реквизиты формы и работать с ними.

С некоторыми можно даже без контекста работать. если в параметре был указан конкретный перечень реквизитов.

Пример.
Есть реквизит формы табличный документ.

Есть глобальная процедура которая формирует отчет выводимый в этот табличный документ (поле формы).

Без контекста можно из клиента создать серверную процедуру без контектса, в которой будет в своюб очередь глобальная процедура. в параметр которой впихнут реквизит формы.
   Maniac
 
107 - 03.09.21 - 12:51
&НаСервереБезКонтекста
Процедура СформироватьОтчетПоЦенамСервер(ТаблицаОтчета,ПараметрыЗапроса) 
    
    МегаПомощникПродажСервер.СформироватьОтчетПоЦенам(ТаблицаОтчета,ПараметрыЗапроса);
    
КонецПроцедуры

&НаКлиенте
Процедура СформироватьОтчетПоЦенам()
    
    ПараметрыЗапроса = Новый Структура;
    ПараметрыЗапроса = ПолучитьПараметрыДетальногоЗапроса(ПараметрыЗапроса);
    СформироватьОтчетПоЦенамСервер(ТаблицаЦеныНоменклатуры,ПараметрыЗапроса);  
    
КонецПроцедуры

ТаблицаЦеныНоменклатуры - реквизит формы с типом ТабличныйДокумент.
   Ыцшесрук
 
108 - 03.09.21 - 12:51
Геню, похоже, нужно вводить в анналы истории как эталонный пример синдрома Даннинга-Крюгера.
   acht
 
109 - 03.09.21 - 12:57
(108) > вводить в анналы
Да его уже давно и по самые помидоры. Сейчас народ просто прикидывает, как его в мирных целях использовать можно, например (73). Может и сгодится на что...
   Ненавижу 1С
 
110 - 03.09.21 - 15:20
опять ждать Free RAD?
https://geniy1s.ru/developments-soft/free-rad/
   Гений 1С
 
111 - 03.09.21 - 15:24
(101) это говорит о твоем уровне, как программиста
   Гений 1С
 
112 - 03.09.21 - 15:25
(110) Базуху жи
   Maniac
 
113 - 03.09.21 - 15:34
FREE RAD
Миссия проекта: дать программистам-разработчикам инструмент для быстрой разработки приложений (RAD — Rapid Application Development), связанных с базами данных.


Человек пишет инструмент для разработки приложений, тот кто ни одного приложения в жизни не создал)) Тем более коммерческого))
   Maniac
 
114 - 03.09.21 - 15:38
https://geniy1s.ru/developments-1s/1s-data-exchanges/csv-xml-translation/

"Для считывания CSV использовался не очень быстрый метод считывания файла в строку с последующим разбором отсюда. Метод реально медленный на 72 Мб файле работал 10 минут. Но работает правильно, т.к. обрабатывает переносы строк."
Геня научился CSV читать!!))) Открыл АМЕРИКУ.

но 10 минут!

Геня у меня обработка чтения CSV есть которая файл в 1 гиг с 15 000 000 строк - за 8 секунд читает.
   Maniac
 
115 - 03.09.21 - 15:39
А за минуту может создать новый файл в новыми ценами из этого первого файла.
   lodger
 
116 - 03.09.21 - 15:44
(114) ты просто не понимаешь всего гения.
   Гений 1С
 
117 - 04.09.21 - 17:29
(114) я надеюсь перенос строки в кавычках она отрабатывала?
   acht
 
118 - 04.09.21 - 17:30
(117) Подожди. Маня воюет с иностранцами в интернете, ему не до кода =)
   Гений 1С
 
119 - 04.09.21 - 22:02
(118) с украинцами штоли? У него ж оттедова конкуренты
   dmitryds
 
120 - 04.09.21 - 22:05
(94) Ты ведь вроде сайтами занимался, должен понимать, что на клиенте не может быть ссылки на форму (как при работе на сервере)
   МнеТолькоСпросить
 
121 - 05.09.21 - 05:07
(72) >ТС наркоман и расписывается в этом тут 
Тоже мне новость

(77)Ты лучше расскажи ты от цепей ограничения использования ОРМ 1с уже отказался? Ты вот вот(прям уже почти готово было) хотел выпустить набор обработок которые не будут использовать базу 1С а будут использовать, любые другие БД и за 12 копеек можно было получить полный функционал работы с 1С и даже какой-то способ перевести свои конфигурации с БД которую юзает 1С на ту какая тебе нравится.  Как там  дела? Готово?


(91)Видел на ИС публикацию когда гений в 1с не смог в цикле сложить две строки и решил использовать для этого эксель
   Гений 1С
 
122 - 05.09.21 - 09:49
(120) шта? форма живет на сервере и клиенте и синхронизируется. Конечно же, ссылка на форму может быть (или гуид формы, или как не назови). Что за бред вы пишите? при чем сайты к УФ?
   Гений 1С
 
123 - 05.09.21 - 09:50
(121) что такое ОРМ? Базуха - хорошая тема, но я пока увлечен ЕБОША, т.е. вкалыванием
   Юрий Лазаренко
 
124 - 05.09.21 - 10:15
(0) Крайне ужасные решения появятся, если в платформе будет возможность передавать все данные формы при каждом вызове серверного общего модуля. Подробности вот тут посмотри: https://youtu.be/PvQX0H28S_M?t=851
Если кратко: каждый такой вызов будет серверным контекстным. То есть, все данные формы превращаются в структуру (условно "структуру"), передаются на сервер, там актуализируются; далее выполняется какое-то действие и все конвертация и передача происходит в обратном порядке. Пример с лагерем и спичками тут подходит прекрасно. Сейчас для того, чтобы выполнить какие-то действия на сервере, не все заморачиваются выбором типа вызова: серверный контекстный или серверный бесконтекстный. Нагрузка на сервер при этом различается на порядки, то есть в сотни раз. Для передачи контекста формы на сервер сейчас надо вызвать серверную процедуру формы. Это "лишнее" телодвижение, которое хоть как-то отбивает желание 1Сника сделать несколько контекстных серверных вызовов там, где можно обойтись одним. Если же общие серверные модули можно будет вызывать из любого места формы, то скоро от быстродействия этой формы не останется ничего.
   Гений 1С
 
125 - 05.09.21 - 11:25
(124) при каждом не надо. форма и так уже существует на сервере
   Гений 1С
 
126 - 05.09.21 - 11:25
Если это сложно определить платформе, можно указать директиву препроцессора
   Ненавижу 1С
 
127 - 05.09.21 - 11:30
(125) а толку? Она на клиенте возможно изменилась и её надо синхронизовать и потом в обратную сторону
   Гений 1С
 
128 - 05.09.21 - 11:32
(127) послушай, я делаю все то же самое через заплатку в форме, почему это не может сделать платформа. Ну можно изменить и в обратную сторону, в чем проблема?
   lucbak
 
129 - 05.09.21 - 11:36
(124) Цитата "Сервер не может вызвать клиента даже если очень этого захочет" (возможно не дословно, но смысл именно такой был). Ставим СВ и о чудо - оказывается сервер может вызвать клиента :) Я конечно не программист, но складывается ощущение, что что-то не то в консерватории...
   Гений 1С
 
130 - 05.09.21 - 11:45
(129) мне не нужно вызывать клиента с сервера, мне нужно вызывать сервера с клиента.
А что такое СВ?
 
 
   Ненавижу 1С
 
131 - 05.09.21 - 11:49
(128) твоя заплатка не сработает если нужно передать две формы
   lucbak
 
132 - 05.09.21 - 11:56
(130) Сервер Взаимодействия
   Ненавижу 1С
 
133 - 05.09.21 - 12:08
(129) ну это может быть постоянный опрос клиентом сервера в отдельном потоке
   lucbak
 
134 - 05.09.21 - 12:19
(133) Все может быть, но факт остается фактом - если нельзя, но очень хочется то можно все. Есть много вещей которые я не понимаю (относительно платформы) - почему можно гонять с клиента на сервер (и наоборот) массивы,списки,структуры,соответствия, но по какой-то странной логике нельзя - таблицы (разумеется я могу разложить ее в массив структур и т.д.), но ...
   Гений 1С
 
135 - 05.09.21 - 12:51
(131) две не нужно.
   Гений 1С
 
136 - 05.09.21 - 12:52
(134) ну вот о том и речь, что нужно убирать странности и приводить в норму
   Юрий Лазаренко
 
137 - 05.09.21 - 12:55
(129) Слайд 33, мелким шрифтом внизу: https://youtu.be/PvQX0H28S_M?t=1034
   Ненавижу 1С
 
138 - 05.09.21 - 12:58
(134) кажется я уже писал в (67) - потому что объекты не передаются так с клиента на сервер как ссылки, а происходит полная сериализация/десериализация объекта, фактически создается копия
они решили пойти компромисс и сделать возможной передачу относительно легких по структуре объектов
я не говорю, что решение идеальное
вообще все выглядит довольно странным - просто запомните, как неправильные глаголы, но что есть, то есть
   Юрий Лазаренко
 
139 - 05.09.21 - 13:01
+(137) Необязательно даже СВ ставить, можно и ВК + сокеты.
https://www.youtube.com/watch?v=5le3A2f3QjM
   lucbak
 
140 - 05.09.21 - 13:01
(137) Не прочитал сразу (сори). Другими словами, сделать можно все, но 1С это просто не нужно.
(138) Да я "запомнил" и смирился уже, но осадочек как говорится остался :)
   Юрий Лазаренко
 
141 - 05.09.21 - 13:04
(140) Платформа и так не сильно быстрая, нагружать ее дополнительными фишками - это утяжелить еще. К тому же, зачем весь дополнительный функционал включать в платформу и отдавать просто так, если можно продавать за дополнительные деньги, как СВ. Маркетинг и разные версии за разные деньги никто не отменял.
   Ненавижу 1С
 
142 - 05.09.21 - 13:04
(140) а с формой так нельзя, нельзя просто взять и развернуть копию, а надо найти этот объект и синхронизовать
вообще форма на клиенте и на сервере в каком-то смысле объекты разных типов, просто синхронизированные друг с другом
   Юрий Лазаренко
 
143 - 05.09.21 - 13:08
(142) И тут важно помнить, что они не постоянно синхронизированные. Если форму открыть и в элемент ввода типа "Число" ввести цифру 2, то на клиенте цифра появится, а на сервере нет. Для синхронизации необходимо сделать контекстный серверный вызов (чаще всего). А серверный вызов - это суть разобрать/собрать весь лагерь, чтобы сходить за спичками. И чтобы таких вызовов было поменьше и платформа хоть как-то ворочалась и не погибла вместе с сервером, 1С сознательно не выполняет пожелалку ТС из (0). И правильно делает.
   Юрий Лазаренко
 
144 - 05.09.21 - 13:13
(134) Кстати, в первых версиях управляемых форм, в 2008 году, таблица значений была доступна на клиенте. То есть, в управляемой форме в процедуре &НаКлиенте можно было написать
МояТЗ = Новый ТаблицаЗначений
и это не было ошибкой. В следующих релизах это стало невозможным.
   Гений 1С
 
145 - 05.09.21 - 13:15
(140) вот потому я и оставил хотелку, чтобы показать 1с, что нам, простым программистам нужно
   lucbak
 
146 - 05.09.21 - 13:17
(141) >>Платформа и так не сильно быстрая
Это одна из проблем 1С (вместо того, что бы делать очередные мало кому нужные бантики) могли бы заняться ее ускорением, но нет...
(144) Забавно.
   Юрий Лазаренко
 
147 - 05.09.21 - 13:23
(146) 8.3 ускорить практически невозможно (ИМХО, конечно)
   acht
 
148 - 05.09.21 - 13:40
(145) > что нам, простым программистам
Геня, ты с собой определись уже - ты простой программист или не простой?
   Ненавижу 1С
 
149 - 05.09.21 - 13:44
(148) альтернативно одаренный
   Вафель
 
150 - 05.09.21 - 14:22
А какая задача решается?
Скорее всего тут плохой дизай формы. Но сама 1с мало думает о доработках. Но уже больше чем в обычных формах
   MyNick
 
151 - 05.09.21 - 14:43
(0)Гений, что-то я не понял, а накуа тащить контекст всей формы в общий модуль?
Для манипуляции со всей формой используется модуль формы.
Для манипуляции с данными формы - передавай их в структуре параметра фунции общего модуля.

Для чего эти костыли, "кулибин" ты наш?
Чтобы было проще говнокодить?

Обрисуй конкретную задачу, где это тебе надо и мы скажем почему тебе это не надо.
   Ненавижу 1С
 
152 - 05.09.21 - 14:52
(151) ну какой-то смысл есть
вот например мне понадобилось и  форме заказа клиента и заказа на перемещение добавить колонки остатки/резервы по складу, объем и вес
они общие для обеих форм, так не копировать же код два раза?
   acht
 
153 - 05.09.21 - 14:59
(152) Там из "скопированного два раза кода" будет ровно одна серверная контекстная процедура из ровно одной строки, вызывающей общий серверный модуль.
   MyNick
 
154 - 05.09.21 - 15:06
(152) Так чтоли?


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    //ОбщийДляФорм.ДобавитьЭлементы(Элементы);

КонецПроцедуры

// ИЛИ С КЛИЕНТА

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ДобавитьЭлементы();
КонецПроцедуры

&НаСервере
Процедура ДобавитьЭлементы()
    ОбщийДляФорм.ДобавитьЭлементы(Элементы);
КонецПроцедуры


/////////////////// ОБЩИЙ МОДУЛЬ ///////////////

Функция ДобавитьЭлементы(Элементы) Экспорт
    
    Декорация = Элементы.Добавить("Декорация1", Тип("ДекорацияФормы"));
    Декорация.Заголовок = "Текст..";

КонецФункции
   Ненавижу 1С
 
155 - 05.09.21 - 15:07
(154) что-то в этом духе
Ну там еще расчет данных при добавлении/изменении товаров
   MyNick
 
156 - 05.09.21 - 15:11
(155) ...вооот... Т.е. Гении в одной функции хотят делать фарш из мух и котлет.
Это и есть говнокод.
В одной функции получаем условия для отображения элементов и прочей манипуляции с ними.
В другой - формируем интерфейс.
И это правильно. Получение и обработка данных и их отображение должны располагаться в разных местах.
Но гениям это мешает жить.
Они целые статьи пишут и изобретают велосипеды с квадратными колесами.
Лишь бы у последователей, читающих их божественный код, кровь из глаз шла.
   Гений 1С
 
157 - 05.09.21 - 18:21
(152) вызовешь отдельно для каждой формы
   Гений 1С
 
158 - 05.09.21 - 18:22
(156) почитай про вынесение кода формы в модули, потом пиши с умным видом.
   Гений 1С
 
159 - 05.09.21 - 18:22
(150) например, вынесение кода формы в модули
   Гений 1С
 
160 - 05.09.21 - 18:22
(151) почитай статью не по диагонали, думаю, поймешь.
 
 
   Гений 1С
 
161 - 05.09.21 - 18:23
(146) в данном случае скорость не важна, важнее наличие функционала, чтобы не писать заплатки (функции-посредники)
   Гений 1С
 
162 - 05.09.21 - 18:23
ок. пусть 1с сделает встроенную функцию-посредник, если она не может в вызов серверного модуля с формой с клиента
   Ненавижу 1С
 
163 - 05.09.21 - 18:47
(161) если параметры передавать через запись в справочник, то да, скорость не важна
   acht
 
164 - 05.09.21 - 19:34
(162) > пусть 1с
Повелеваешь?
   Конструктор1С
 
165 - 05.09.21 - 19:48
(158) Геня, бизнес-логика и интерфейс должны быть разделены. Бизнес-логика не должна зависеть от интерфейса. Ты когда уже программировать научишься? То, чем ты сейчас занимаешься, сложно назвать программированием, это кодошлёпство
   Конструктор1С
 
166 - 05.09.21 - 19:52
Елитный говнокод. Смесь индусского с наркоманским

#Область ДляВызоваССервера

&НаСервере
Процедура ПроцедураНаСервере(ИмяМетода, П1 = "3b779cb1-3a77-4984-8e2b-8c7960a3863a", П2  = "3b779cb1-3a77-4984-8e2b-8c7960a3863a", П3  = "3b779cb1-3a77-4984-8e2b-8c7960a3863a", П4  = "3b779cb1-3a77-4984-8e2b-8c7960a3863a", П5  = "3b779cb1-3a77-4984-8e2b-8c7960a3863a") Экспорт
    П = "";
    Если П1 <> "3b779cb1-3a77-4984-8e2b-8c7960a3863a" Тогда
        П = ", П1";
        Если П2 <> "3b779cb1-3a77-4984-8e2b-8c7960a3863a" Тогда
            П = П + ", П2";
            Если П3 <> "3b779cb1-3a77-4984-8e2b-8c7960a3863a" Тогда
                П = П + ", П3";
                Если П4 <> "3b779cb1-3a77-4984-8e2b-8c7960a3863a" Тогда
                    П = П + ", П4";
                    Если П5 <> "3b779cb1-3a77-4984-8e2b-8c7960a3863a" Тогда
                        П = П + ", П5";
                    КонецЕсли;
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
        
    КонецЕсли;
    Выполнить(ИмяМетода + "(ЭтаФорма" + П + ")");
    
КонецПроцедуры

&НаСервере
Функция ФункцияНаСервере(ИмяМетода, П1 = "3b779cb1-3a77-4984-8e2b-8c7960a3863a", П2  = "3b779cb1-3a77-4984-8e2b-8c7960a3863a", П3  = "3b779cb1-3a77-4984-8e2b-8c7960a3863a", П4  = "3b779cb1-3a77-4984-8e2b-8c7960a3863a", П5  = "3b779cb1-3a77-4984-8e2b-8c7960a3863a") Экспорт
    Р = Неопределено;
    П = "";
    Если П1 <> "3b779cb1-3a77-4984-8e2b-8c7960a3863a" Тогда
        П = ", П1";
        Если П2 <> "3b779cb1-3a77-4984-8e2b-8c7960a3863a" Тогда
            П = П + ", П2";
            Если П3 <> "3b779cb1-3a77-4984-8e2b-8c7960a3863a" Тогда
                П = П + ", П3";
                Если П4 <> "3b779cb1-3a77-4984-8e2b-8c7960a3863a" Тогда
                    П = П + ", П4";
                    Если П5 <> "3b779cb1-3a77-4984-8e2b-8c7960a3863a" Тогда
                        П = П + ", П5";
                    КонецЕсли;
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
        
    КонецЕсли;
    Выполнить("Р = " + ИмяМетода + "(ЭтаФорма" + П + ")");
    Возврат Р;
КонецФункции
#КонецОбласти
   Конструктор1С
 
167 - 05.09.21 - 19:55
Пойду глаза прополощу
   Гений 1С
 
168 - 05.09.21 - 22:28
(165) 0 бит, прости. Есть задачи по дизайну формы, они связаны с интерфейсом, а не логикой, их хочется и нужно выносить в общие модули
   DropDead
 
169 - 06.09.21 - 03:24
Я все ещё не понимаю, зачем вы за гения работу делаете?
Он вам башляет?
   Конструктор1С
 
170 - 06.09.21 - 06:40
(168) в UI/UX ты тоже полное дно, поэтому у тебя и рождаются перлы типа (0)
   Юрий Лазаренко
 
171 - 06.09.21 - 09:50
(161) Конечно, "скорость не важна". Подумаешь - сервак положили.
   Ненавижу 1С
 
172 - 06.09.21 - 10:02
(171) в ларьках клиентов фиксина нет серваков
   acht
 
173 - 06.09.21 - 10:10
(172) > нет серваков
гггг, 0 бит, в айтикризис, фирма 1С не может, вот вам статья как я с ней борюсь.

=)
   sikuda
 
174 - 06.09.21 - 11:29
(171) Гений 1С как осел в Шреке - повод лучше разобраться...
   Конструктор1С
 
175 - 06.09.21 - 12:04
(174) если бы Г1С писал для себя, то фиг бы с ним. А так придёт ведь после него прогер, который будет вынужден иметь дело со всей той наркоманией, которую Г1С нагородил
   acanta
 
176 - 06.09.21 - 12:07
В последних версиях типовых было уже не модно с такими параметрами как в (166), рекомендовалось структуру одну в качестве параметра или максимум три параметра - структура, форсмажорный отказ и что то на ответ по аналогии с функцией.
   acanta
 
177 - 06.09.21 - 12:09
То есть вся лирика с гуидами в одной переменной, и еще мухи с котлетами как необязательные.
   BeerHelpsMeWin
 
178 - 06.09.21 - 13:00
(175) Это будет отличный повод запросить больше денег. Но есть одна проблема - у Гениных клиентов-нищебродов таких денег нет.
   MyNick
 
179 - 06.09.21 - 13:54
(158), (159), (160).
Твои гениальные мысли я читал. И не по диагонали.
Понятно, что ты хочешь. Даже понятно, зачем.
Даже сталкивался с такой потребностью сам, когда начинал осваивать УФ.
На первых порах плевался как и ты (вот же гады, не дают по быстренькому нафигачить "чтобы работало").
Но осознание позже, с опытом пришло - что так делать кака.
И почему - написано в (165) например.

(166) согласен... вот это жесть так жесть.
   Maniac
 
180 - 06.09.21 - 15:42
зачем Геня дарит миру) то что никому не нужно?
У него даже нет ни одного массового решения которое кому либо было нужно, я уже молчу про коммерческие.

Получается он на ком то из клиентов эксперементы ставит! коверкает до ужаса. Потом уходит. Вместо него приходят люди и окуевают!
Так получается?
   acht
 
181 - 06.09.21 - 17:10
(180) Потому что у него ничего больше нет. И вот этим последним он делится с нами, которые окуевают даже не приходя у его клиенту. Получается так.
   Гений 1С
 
182 - 06.09.21 - 17:50
(179) Гуру, преклоняю перед вами колени, если конечно не пи...., ой, не врете... а в 165 у тебя общие слова.
   H A D G E H O G s
 
183 - 06.09.21 - 23:12
Вот чего действительно не хватает в УФ - так это прямого вызова методов модулей менеджеров с клиента.
   H A D G E H O G s
 
184 - 06.09.21 - 23:13
Ты не сможешь вызвать код вот так с клиента
КодыВидовЛицензируемойДеятельности=Справочники.АСФЛицензии.ПолучитьКодыВидовЛицензируемойДеятельности();
   RomanYS
 
185 - 06.09.21 - 23:23
(183) так если самих менеджеров не на клиенте, то и их модулей логично нет. Чем общий клиентский модуль не устраивает?
   acanta
 
186 - 06.09.21 - 23:24
(184) как бы да, это был первый пункт рекламной кампании новой 8ки для семерочников.
   acanta
 
187 - 06.09.21 - 23:26
Поэтому семерочникам (у которых не было) проще переходить на УФ (где тоже уже нет), чем на ОФ (где все есть, но как то не очень получается).
   H A D G E H O G s
 
188 - 06.09.21 - 23:52
(185)
ПредопределенноеЗначение("Перечисление.АСФВидыЛицензируемойДеятельности.ЗакупкаЭСПофармакопейнымСтатьямБолее200дклВГод")
   Ненавижу 1С
 
189 - 06.09.21 - 23:54
(185) а чем общий серверный модуль в этом случае отличается от модуля менеджера?
   RomanYS
 
190 - 07.09.21 - 00:09
(188) ну да, сами перечисления недоступны, а значения доступны. Может и можно было красивее сделать. Раньше от этого тоже подташнивало, а теперь привык)
(189) ну должна же где-то быть граница. Все метаданные тащить на клиент, тоже так себе идея
   H A D G E H O G s
 
191 - 07.09.21 - 00:18
(190) В начальных 8.2 этой функции не было, приходилось в ПриСозданииНаСервере на клиент тащить ссылки. Потом впилили костыльчик.
   Конструктор1С
 
192 - 07.09.21 - 05:02
(191) так не нужно писать бизнес-логику на клиенте, и не будет такой уродливой надобности. Форма впринципе не должна заведовать бизнес-логикой, только отвечать за интерфейс
   Ыцшесрук
 
193 - 07.09.21 - 05:27
Геня старательно вызывает на себя ковшики с какахами и методично ими обмазывается :)
   Гений 1С
 
194 - 07.09.21 - 08:12
(193) я за истену.
   luter-89
 
195 - 07.09.21 - 09:04
(33) Есть такая штука как БСП, может почерпнешь что-то новое
   Гений 1С
 
196 - 07.09.21 - 12:44
(165) а мы где говорили про бизнес-логику? Клиент как раз и обращается на сервер, чтобы что-то однотипно отрисовать, т.е. сделать настройки интерфейса.
   acht
 
197 - 07.09.21 - 12:57
(196) А пользователь входит в программу чтобы поработать.
   H A D G E H O G s
 
198 - 07.09.21 - 13:01
Ловите любителя подергать за сервер в (192)!
   acht
 
199 - 07.09.21 - 13:13
(198) А он прав.

Вот, например раньше была дырка, все серверные методы были экспортные и видимые с клиента...
И пишет один такой геня, которому думать неохота, в форме на клиенте:

    Если ЕстьВозможностьУвольнятьСотрудникаНаСервере() Тогда
        УволитьСотрудникаНаСервере();
    КонецЕсли;

А второй геня пишет:
    Форма = ПолучитьФорму(...);
    Форма.Объект.Сотрудник = НенавистныйДиректор;
    Форма.УволитьСотрудникаНаСервере();

И все, бизнес логика пошла лесом, потому что геням так удобно.
   acht
 
200 - 07.09.21 - 13:15
А потом статью пишет и на форумах ссылки раскидывает - посмотрите, мол, какой я молодец, обошел дурацкое ограничение фирмы 1С, гггг, в айти кризис.
  1  2  3   

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.