Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Свертка базы и перенос даты ввода документов остатков

Свертка базы и перенос даты ввода документов остатков
Я
   fellix
 
02.09.21 - 12:23
При сворачивании в УПП типовой обработкой в конце выполняется активизация документов ввода остатков вот такой процедурой:

Процедура сбАктивизироватьВводОстатков(ДокументыВводаОстатков) Экспорт
    
    Для Каждого ТекДок Из ДокументыВводаОстатков Цикл
        
        ДокОбъект = ТекДок.Документ.ПолучитьОбъект();
        
        СтараяДата = ДокОбъект.Дата;
        ДокОбъект.Дата = НачалоДня(ДокОбъект.Дата)-1;//Документы были следующим днем после даты свертки, передвинем назад
        ПроверитьНомерДокумента(ДокОбъект,СтараяДата);
        
        ДокОбъект.Записать();
        
        Для Каждого ТекРегистрДвижений Из ДокОбъект.Метаданные().Движения Цикл
            ДокОбъект.Движения[ТекРегистрДвижений.Имя].Прочитать();
            Если ДокОбъект.Движения[ТекРегистрДвижений.Имя].Количество() > 0 Тогда
                Для Каждого ТекДвижение Из ДокОбъект.Движения[ТекРегистрДвижений.Имя] Цикл
                    ТекДвижение.Период = ДокОбъект.Дата;
                    
                КонецЦикла;
                
                ДокОбъект.Движения[ТекРегистрДвижений.Имя].УстановитьАктивность(Истина);
                ДокОбъект.Движения[ТекРегистрДвижений.Имя].Записать(Истина);
                
            КонецЕсли;    
            
        КонецЦикла;
        
        сбСообщениеСвертки("Обработан " + ДокОбъект.Ссылка + " " + ДокОбъект.Комментарий);
        
    КонецЦикла;    
    
КонецПроцедуры

Вопрос - зачем? Если я сворачиваю на 31.12.2015 23.59.59, документы ввода создаются на 01.01.2016 00:00:00, а затем в конце переносятся на секунду назад. Какой в этом смысл?
Помимо прочего захватывает документы созданные до свертки вручную на 1е число, их тоже перекидывает на конец предыдущего года.
   shuhard
 
1 - 02.09.21 - 14:37
(1) смысл в образовании начальных остатков
   fellix
 
2 - 02.09.21 - 15:32
Да, это я затроил.
Но перекидывание моих ручных корректировок на конец сворачиваемого периода - это косяк. У меня на начало года уже получается есть например остатки, которые должны появиться там через 12 часов.
Ладно, просто сделаю отбор в обработке, чтобы не трогал ручные корректировки и операции

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.