Вход | Регистрация
 

Как в управляемой форме сохранить некое значение?

Как в управляемой форме сохранить некое значение?
Я
   Гений 1С
 
01.09.21 - 17:34
Добавить реквизит не могу, т.к. расширяю событие общего клиентского модуля, куда передается форма.
А добавлять реквизиты можно только на сервере, на сервер переданную таким образом форму не передам.
Я создаю элемент невидимый временный, но это криво как-то.
Может есть нормальные способы?
   Гений 1С
 
1 - 01.09.21 - 17:39
блин, элементы тоже можно создавать только на сервере... жесть...
   НЕА123
 
2 - 01.09.21 - 17:43
(0)
попробовать использовать свойства полей, например, заголовок(невидимый).
   Новый1сник2
 
3 - 01.09.21 - 17:44
(0) конфа на поддержке ?
   BeerHelpsMeWin
 
4 - 01.09.21 - 17:44
У тебя же уже есть готовое решение, создать в расширении справочник с единственным реквизитом!
   Новый1сник2
 
5 - 01.09.21 - 17:51
можно справочник, можно регистр, я даже константой как то пользовался для передачи значения
   Ненавижу 1С
 
6 - 01.09.21 - 18:12
Разрешаю использовать параметры
   Гений 1С
 
7 - 01.09.21 - 18:13
(3) ну типа да, тем более что там входы могут быть из разных форм.
Но я уже типа выкрутился, передаю если что структуру, в которую обернута форма.
Если на входе метода форма - значит, вызвано стандартно, а если структура, то значит, мой метод вызывает.
Можно еще в глобальной клиентской процедуре хранить список УИД всех форм, которые так обработаны, но это уже лишнее.
   Гений 1С
 
8 - 01.09.21 - 18:44
   Ненавижу 1С
 
9 - 01.09.21 - 18:58
(8) ну что тут сказать? Это лютый пи*дец
   Гений 1С
 
10 - 01.09.21 - 19:02
(9) как бы ты решал сию задачу?
   Новый1сник2
 
11 - 01.09.21 - 19:04
(8) по ссылке "404 Не Найдено"
   Новый1сник2
 
12 - 01.09.21 - 19:06
я бы включил возможность изменения конфигурации, согласовав это с клиентом, а дальше в основной конфе правил
   Гений 1С
 
13 - 01.09.21 - 19:21
(12) Во всех формах, откуда идет вызов? Бог в помощь!
   Гений 1С
 
14 - 01.09.21 - 19:23
(11) Копируй ссылку, движок мисты коверкает в https://forum.mista.ru/%22https://geniy1s.ru/kak-v-upravlyaemoj-forme-otlozhit-dejstvie-do-pokaza-dialoga//%22
   Василий Алибабаевич
 
15 - 01.09.21 - 19:32
Непонятно. Но внушаить.

"реквизиты можно только на сервере, на сервер переданную таким образом форму не передам.
Я создаю элемент невидимый временный"

Полностью согласен с (9). Банально объявить переменную модуля на стороне клиента кто то запретил?
   Сергиус
 
16 - 01.09.21 - 19:58
(0)Мда..1с добавляя расширения, явно не учло, что у некоторых фантазия на их использование, будет зашкаливать.
   Гений 1С
 
17 - 01.09.21 - 20:16
(15) а что ты будешь в переменной модуля хранить? и кстати, у общих модулей клиентских разве можно добавлять переменные?
   Ненавижу 1С
 
18 - 01.09.21 - 20:17
(10) например вынес бы "кишки" так, раз уж ты "разбомбил" типовый вызов аннотацией &Вместо:

&Вместо("СтартоватьИЗакрыть")
Процедура дор_СтартоватьИЗакрыть(Форма)
  СтартоватьИЗакрытьПереопределено(Форма,Ложь);
КонецПроцедуры

и дальше бы работал с СтартоватьИЗакрытьПереопределено, меняя свой дополнительный параметр

вместо вот этого:

Если Условие Тогда
        Перейти ~Стандартно;
    КонецЕсли;
    
    //

    //Много кода

    //

    Возврат; 
    
    ~Стандартно:
    ПродолжитьВызов(Форма);
КонецПроцедуры

по мне читабельнее:

Если Условие Тогда
        ПродолжитьВызов(Форма);
        Возврат;
    КонецЕсли;
    
    //

    //Много кода

    //

    
КонецПроцедуры
   Гений 1С
 
19 - 01.09.21 - 20:18
(18) это вкусовщина. мне гото в конец нравится. это олдскул
   Ненавижу 1С
 
20 - 01.09.21 - 20:22
(19) надеюсь через год-другой тебе понадобиться его перечитать
   Guk
 
21 - 01.09.21 - 20:29
воистину гений!!!...
   Гений 1С
 
22 - 01.09.21 - 20:43
(20) зачем?
(21) а то, это тебе не анонимный гений Маня


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.