Вход | Регистрация
 

Как в 1С-обновляторе создать пользователей и включить в группы БСП?

Как в 1С-обновляторе создать пользователей и включить в группы БСП?
Я
   Гений 1С
 
01.09.21 - 13:10
Вот пример, как создавать пользователей в обычных базах:
https://helpme1c.ru/sozdaem-i-udalyaem-polzovatelej-pri-pomoshhi-obnovlyatora-1s
Для БСП тоже есть пример: https://github.com/milkin-vl/ONESCRIPT-user-scripts-for-Updater-1C/blob/master/Бухгалтерия%20предприятия/Создание%20нового%20пользователя.os
Но там только для полных прав. А нужно создать пользователя и включить его в нужные группы (БП3, ЗУП3).
Кто-нибудь делал? Не охота сидеть в конфигураторе и замерять по монитору, что там 1С делает при добавлении пользователя в группу.
   Злопчинский
 
1 - 01.09.21 - 14:18
(0) "Обратите внимание. В новых версиях конфигураций, основанных на БСП уже недостаточно создать пользователя информационной базы. В добавок нужно создать элемент справочника "Пользователи" и установить связь между ними. Если это ваш случай - разберите как работает вот этот пример(здесь ссылка)."
   ДенисЧ
 
2 - 01.09.21 - 14:23
(0) Мдя... геня в репертуаре...
УправлениеДоступом.ВключитьПрофильПользователю()
   acht
 
3 - 01.09.21 - 14:25
(2) За две тыщи в час читать документацию недостойно. Всегда есть бесплатные помощники на формуме. Вот ты, например.
   ДенисЧ
 
4 - 01.09.21 - 14:26
(3) Унизить геню - бесценно!
   VladZ
 
5 - 01.09.21 - 14:35
(0) Это типовые механизмы БСП.

Ты, как специалист с опытом, должен владеть типовыми механизмами БСП в совершенстве.
   Вафель
 
6 - 01.09.21 - 15:04
(5) зачем вообще знать этот код, который никогда не нужен ибо работает сам по себе
   Злопчинский
 
7 - 01.09.21 - 16:43
(5) ага, "врач по левому уху", по правому уху - другой спец...
   acht
 
8 - 01.09.21 - 17:20
(7) Ну, терапевт, например, должен знать, что уши-то у человека есть. Около 2 штук, в районе головы.
   Гений 1С
 
9 - 05.09.21 - 19:18
(6) именно. и все же?
   Гений 1С
 
10 - 05.09.21 - 21:34
Пользователя еще не создавал, но в группы включать/исключать вроде научился:

&НаСервере
Процедура ИзменитьПраваГБ2НаСервере()
    ТекПользователь = Справочники.Пользователи.НайтиПоНаименованию("ГБ2");
    ТекПрофиль = Справочники.ПрофилиГруппДоступа.НайтиПоНаименованию("Главный бухгалтер");
    ТекГруппаДоступа = ДатьПерсональнуюГруппуДоступа(ТекПользователь, ТекПрофиль);
    ТекГруппаДоступаОбъект = ТекГруппаДоступа.ПолучитьОбъект();
    Если ТекГруппаДоступаОбъект.Пользователи.Количество() = 0 Тогда
        НСтр = ТекГруппаДоступаОбъект.Пользователи.Добавить();
        НСтр.Пользователь = ТекПользователь;
        Сообщить("Добавлен профиль:" + ТекПрофиль);
    Иначе
        ТекГруппаДоступаОбъект.Пользователи.Очистить();
        Сообщить("Удален профиль:" + ТекПрофиль);
    КонецЕсли;
    ТекГруппаДоступаОбъект.Записать();
    
    
КонецПроцедуры

&НаСервере
Функция ДатьПерсональнуюГруппуДоступа(Пользователь, Профиль)
    З = Новый Запрос(
    "ВЫБРАТЬ
    |    ГруппыДоступа.Ссылка
    |ИЗ
    |    Справочник.ГруппыДоступа КАК ГруппыДоступа
    |ГДЕ
    |    ГруппыДоступа.Профиль = &Профиль
    |    И ГруппыДоступа.Пользователь = &Пользователь
    |    ");
    З.УстановитьПараметр("Пользователь", Пользователь);
    З.УстановитьПараметр("Профиль", Профиль);
    Выборка = З.Выполнить().Выбрать();
    Если Выборка.Следующий() Тогда
        Возврат Выборка.Ссылка;
    КонецЕсли;
КонецФункции

&НаКлиенте
Процедура ИзменитьПраваГБ2(Команда)
    ИзменитьПраваГБ2НаСервере();
КонецПроцедуры
   Гений 1С
 
11 - 05.09.21 - 21:37
(2) а что такое УправлениеДоступомСлужебный.УпрощенныйИнтерфейсНастройкиПравДоступа() ?
профиль - это замечательно, но нужно, чтобы пользователь был включен в нужную группу, как будто это было сделано руками, а не просто дать ему нужные роли, имхо. Иначе криво
   Гений 1С
 
12 - 05.09.21 - 21:39
(2) а хотя там есть код по профилю доступа, ок. Потестируем.
   МимохожийОднако
 
13 - 05.09.21 - 22:12
(0) К автору обновлятора пробовал обращаться?
   Гений 1С
 
14 - 05.09.21 - 22:26
(13) нет, я с ним не знаком
   Гений 1С
 
15 - 06.09.21 - 14:37
(2) а как при не упрощенном режиме групп доступа добавлять пользователя в группу?
   Гений 1С
 
16 - 06.09.21 - 15:18
Разобрался, нужно просто в группу в табличную часть добавить пользователя, остальное сделает 1С.
   Гений 1С
 
17 - 06.09.21 - 18:29
Написал статью по теме, если кому интересно: http://geniy1s.ru/programmnoe-dobavlenie-polzovatelej-v-bazy-na-bsp/

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.