Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Вопрос как правильно записать данные в РС

Вопрос как правильно записать данные в РС
Я
   den54
 
30.08.21 - 13:19
Добрый день.
Есть документ в который помещается информация кто какую операцию делал в месяц и количество по дням.  
Например: ИвановИ.И. делал операцию под номером 123, 1янв =2, 2янв = 4, 3янв.= 6, итд до конца месяца.
Посоветуйте, необходиом в РС записать даные из документа с ТЧ.В шапке документа ФИО,а в ТЧ есть стороки:

НомерОперации Дата1 Дата2 Дата3.... Дата31
123        2    4        6           9

Как правильно в цикле пребрать колонки текущей строки и записать в РС запись вида:
Дата1 ФИО  НомерОперации Значение(Дата1)
Дата2 ФИО  НомерОперации Значение(Дата2)
.......
Дата31 ФИО  НомерОперации Значение(Дата31)
   ДенисЧ
 
1 - 30.08.21 - 13:21
Для сч = 1 по КонецМесяца цикл
  запись = НаборЗаписейРегистра.Добавить();
  запись.Дата = НачалоМесяца(Дата) + сч*3600;
  запись.Фио = ФИО;
  запись.НомерОперации = сч;
  запись.Значение = Объект["Дата" + сч];
КонецЦикла;

Где-то так.
   den54
 
2 - 30.08.21 - 13:28
(1) запись.Значение = Объект["Дата" + сч];  вот с этим не мог понять как реализвать , спасибо буду пробывать,
Еще ,  запись.Дата = НачалоМесяца(Дата) + сч*3600;   // а почему умножаем не на 60*60*24? вроде же надо количество секунд?
   ДенисЧ
 
3 - 30.08.21 - 13:29
(2) Ну да, 86400 )) постоянно путаю.
   Мультук
 
4 - 30.08.21 - 13:33
(2)

Для каждого строка из ТвояТабличнаяЧасть Цикл

  Для сч = 1 по КонецМесяца цикл
    запись = НаборЗаписейРегистра.Добавить();
    запись.Дата = НачалоМесяца(Дата) + сч*3600;
    запись.Фио = ФИО;
    запись.НомерОперации = сч;
    запись.Значение = строка["Дата" + сч];
  КонецЦикла;

КонецЦикла;
   den54
 
5 - 30.08.21 - 13:38
(2) Да , отлично тоже, так же хотел, поробую отпищу , только вот запись.НомерОперации = ТЧ.НомерОперации; просто там операция № 123 а вот коичество разное в зависимости от дня

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.