Вход | Регистрация
 

Перезапись реквизита документа

Перезапись реквизита документа
Я
   НоваяВолна
 
25.08.21 - 08:42
Имеется Объекты (ОбъектРемонта)... Программно обработкой создаю документ Событие, записываю ДокСобытие.Записать(РежимЗаписиДокумента.Проведение);  
Далее мне надо понять создавался ли документ Событие на этот ОбъектРемонта за сегодня (потому как эту обработку могут несколько раз в день запустить) и если да, то не создавать новое Событие, а в найденном дописать строку в текстовый реквизит СодержаниеСобытия, иначе создать новое Событие.
   Делаю так:

Процедура ДействияФормыЗаплонироватьОбзвон(Кнопка)
    Для Каждого Стр Из СписокНаПокраску Цикл
        Если Стр.Отметка Тогда
            Запрос = Новый Запрос;
            Запрос.Текст =
            "ВЫБРАТЬ
            |    Событие.Ссылка,
            |    Событие.СодержаниеСобытия
            |ИЗ
            |    Документ.Событие КАК Событие
            |ГДЕ
            |    Событие.Дата МЕЖДУ &НачДата И &КонДата
            |    И Событие.ОбъектРемонта = &ОбъектРемонта
            |    И Событие.ГруппаСобытия = &ГруппаСобытия
            |    И Событие.ПометкаУдаления = ЛОЖЬ";
            
            Запрос.УстановитьПараметр("ГруппаСобытия", Справочники.ГруппыСобытий.НайтиПоКоду("000000043"));
            Запрос.УстановитьПараметр("НачДата", НачалоДня(ТекущаяДата()));
            Запрос.УстановитьПараметр("КонДата", КонецДня(ТекущаяДата()));
            Запрос.УстановитьПараметр("ОбъектРемонта", Стр.Объект);
            
            РезультатЗапроса = Запрос.Выполнить();
            
            Выборка = РезультатЗапроса.Выбрать();
            Если Выборка.Количество() <> 0 Тогда
                                // всегда получаю пустую выборку не понимаю почему!!!!!!!

                Выборка.Следующий();
                    Док = Выборка.Ссылка;
                // тут меняю поле СодержаниеСобытия
                
            Иначе
                СозданиеСобытия(Стр);
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;    
КонецПроцедуры


В результате получаю два документа Событие, правильно заполненные. А мне нужен один (первый), в котором дописано СодержаниеСобытия, но всегда получаю пустую выборку не понимаю почему?
   ДенисЧ
 
1 - 25.08.21 - 08:48
Потому что объекты не попадают под условия, которые ты задал в запросе.
   НоваяВолна
 
2 - 25.08.21 - 08:53
(1) подскажи как сделать
   ДенисЧ
 
3 - 25.08.21 - 08:53
(2) Задать правильные параметры - не предлагать, как я понимаю?
   НоваяВолна
 
4 - 25.08.21 - 08:57
(3) предлагать, но пнуть в нужную сторону ... туплю )))
   НоваяВолна
 
5 - 25.08.21 - 09:00
(3) дошло... спс ))
   НоваяВолна
 
6 - 25.08.21 - 11:07
(3) Только Объекты это элементы справочника)))

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.