Вход | Регистрация
 

Сдвинуть нужные строки в конец табличного поля

Сдвинуть нужные строки в конец табличного поля
Я
   NIGHTHUNTER
 
16.08.21 - 07:30
У обработки есть реквизит, Найденныессылки - тип ТаблицаЗначений.

На форме у реквизита НайденныеСсылки, путь к данным Объект.НайденныеСсылки.

В коде пытаюсь переместить некоторые элементы этой таблицы значений в конец таблицы. http://joxi.ru/eAO854GC6k4ezr
Но идет ошибка, - Несоответствие типов (параметр номер '1')

Как правильно это сделать?

            ПараметрыОтбора = Новый Структура;
            ПараметрыОтбора.Вставить("ПредставлениеМетаданных", "Справочник.КлючиАналитикиУчетаПоПартнерам");
            НайденныеСтроки = Объект.НайденныеСсылки.НайтиСтроки(ПараметрыОтбора);            
            //
            Для каждого ЭлМасс Из НайденныеСтроки Цикл
                Объект.НайденныеСсылки.Сдвинуть(ЭлМасс, Объект.НайденныеСсылки.Количество());
            КонецЦикла;
   NIGHTHUNTER
 
1 - 16.08.21 - 07:32
Объект.НайденныеСсылки - тип- ДанныеФормыКоллекция

ЭлМасс - тип - ДанныеФормыЭлементКоллекции
   PuhUfa
 
2 - 16.08.21 - 07:36
(0) Тут есть один добрый человек, он СП продает... совсем не дорого
   ДенисЧ
 
3 - 16.08.21 - 07:37
(2) "совсем не дорого"
Не обманывай человека )))
   NIGHTHUNTER
 
4 - 16.08.21 - 07:39
Почему идет ошибка?
ТзНайденныеСсылки = РеквизитФормыВЗначение("Объект.НайденныеСсылки");

по причине:
Нельзя изменять поле, содержащее объект данных формы
   ДенисЧ
 
5 - 16.08.21 - 07:41
А так
ТзНайденныеСсылкиДругая = РеквизитФормыВЗначение("Объект.НайденныеСсылки");
   NIGHTHUNTER
 
6 - 16.08.21 - 07:42
(5) Ок, спасибо, попробую. Кажется у меня такая же валяется уже. По этому так !
   NIGHTHUNTER
 
7 - 16.08.21 - 07:45
по причине:
Неправильное смещение внутри коллекции
что не так я делаю ?

            ТзНайденныеСсылкиДругая  = РеквизитФормыВЗначение("Объект.НайденныеСсылки");
            ПараметрыОтбора          = Новый Структура;
            ПараметрыОтбора.Вставить("ПредставлениеМетаданных", "Справочник.КлючиАналитикиУчетаПоПартнерам");
            НайденныеСтроки    = Объект.НайденныеСсылки.НайтиСтроки(ПараметрыОтбора);            
            НайденныеСтрокиВТз = ТзНайденныеСсылкиДругая.НайтиСтроки(ПараметрыОтбора);            
            //

            Для каждого ЭлМасс Из НайденныеСтрокиВТз Цикл
                ТзНайденныеСсылкиДругая.Сдвинуть(ЭлМасс, ТзНайденныеСсылкиДругая.Количество());
            КонецЦикла;
   NIGHTHUNTER
 
8 - 16.08.21 - 07:46
и так не правильно

            Для каждого ЭлМасс Из НайденныеСтрокиВТз Цикл
                ТзНайденныеСсылкиДругая.Сдвинуть(ЭлМасс, ТзНайденныеСсылкиДругая.Количество()-1);
            КонецЦикла;
   NIGHTHUNTER
 
9 - 16.08.21 - 07:48
видимо так

ТзНайденныеСсылкиДругая.Сдвинуть(ЭлМасс, ТзНайденныеСсылкиДругая.Количество()-2);
   NIGHTHUNTER
 
10 - 16.08.21 - 07:54
в другом случае на это ошибка

ТзНайденныеСсылкиДругая.Сдвинуть(ЭлМасс, ТзНайденныеСсылкиДругая.Количество()-2);

как нужно правильно, я же правильный индекс задаю?
   NIGHTHUNTER
 
11 - 16.08.21 - 08:04
по причине:
Неправильное смещение внутри коллекции
ТзНайденныеСсылкиДругая.Сдвинуть(ЭлМасс, ТзНайденныеСсылкиДругая.Количество()-2);

ТзНайденныеСсылкиДругая.Сдвинуть(ЭлМасс, ТзНайденныеСсылкиДругая.Количество()-1);

на оба варианта ошибка, мне нужно сдвинуть в конец таблицы, подскажите пожалуйста как правильно?
   NIGHTHUNTER
 
12 - 16.08.21 - 08:17
ТзНайденныеСсылкиДругая.Количество() - ТзНайденныеСсылкиДругая.Индекс(ЭлМасс)

нужно рассчитывать

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.