Вход | Регистрация
 

Не очищается запись регистра сведений

Не очищается запись регистра сведений
Я
   NIGHTHUNTER
 
14.08.21 - 09:13
УТ 11.4.
Не получается программно очистить запись регистра сведений Аналитика учета по партнерам.
При повторном выполнении поиска запись находится снова. То есть она не очищается.

Почему она может не очищаться?  http://joxi.ru/LmGbQ18CgeKZgr

                    МенеджерЗаписи                            = РегистрыСведений.АналитикаУчетаПоПартнерам.СоздатьМенеджерЗаписи();
                    Если ЗначениеЗаполнено(Элем.КлючЗаписиРегистраСведений[2].Значение) Тогда
                        МенеджерЗаписи.Партнер                    = Элем.КлючЗаписиРегистраСведений[2].Значение;
                    КонецЕсли;
                    Если ЗначениеЗаполнено(Элем.КлючЗаписиРегистраСведений[3].Значение) Тогда
                        МенеджерЗаписи.Организация                = Элем.КлючЗаписиРегистраСведений[3].Значение;
                    КонецЕсли;
                    Если ЗначениеЗаполнено(Элем.КлючЗаписиРегистраСведений[4].Значение) Тогда
                        МенеджерЗаписи.Контрагент                 = Элем.КлючЗаписиРегистраСведений[4].Значение;
                    КонецЕсли;
                    Если ЗначениеЗаполнено(Элем.КлючЗаписиРегистраСведений[5].Значение) Тогда
                        МенеджерЗаписи.Договор                    = Элем.КлючЗаписиРегистраСведений[5].Значение;
                    КонецЕсли;
                    Если ЗначениеЗаполнено(Элем.КлючЗаписиРегистраСведений[6].Значение) Тогда
                        МенеджерЗаписи.НаправлениеДеятельности = Элем.КлючЗаписиРегистраСведений[6].Значение;
                    КонецЕсли;
                    МенеджерЗаписи.Прочитать();
                    Если МенеджерЗаписи.Выбран() Тогда
                        МенеджерЗаписи.Удалить();                    
                    КонецЕсли;
   DrShad
 
1 - 14.08.21 - 09:27
а ты уверен что по твоему менеджеру она нашлась?
   ДенисЧ
 
2 - 14.08.21 - 09:33
Если МенеджерЗаписи.Выбран() Тогда
  МенеджерЗаписи.Удалить();                    
  Сообщить("Удалили");
Иначе
  Сообщить("Облом-сЪ");
КонецЕсли;
   NIGHTHUNTER
 
3 - 14.08.21 - 09:55
Если МенеджерЗаписи.Выбран() - Ложь.

Не находится выходит  и не удаляется.

Я смотрю по записям, верно все передаю. почему не находится не понятно (
   NIGHTHUNTER
 
4 - 14.08.21 - 09:59
Сейчас вот, при таком изменении, выбран сработало.

                    МенеджерЗаписи                            = РегистрыСведений.АналитикаУчетаПоПартнерам.СоздатьМенеджерЗаписи();
                    //Если ЗначениеЗаполнено(Элем.КлючЗаписиРегистраСведений[2].Значение) Тогда

                        МенеджерЗаписи.Партнер                    = Элем.КлючЗаписиРегистраСведений[2].Значение;
                    //КонецЕсли;

                    //Если ЗначениеЗаполнено(Элем.КлючЗаписиРегистраСведений[3].Значение) Тогда

                        МенеджерЗаписи.Организация                = Элем.КлючЗаписиРегистраСведений[3].Значение;
                    //КонецЕсли;

                    //Если ЗначениеЗаполнено(Элем.КлючЗаписиРегистраСведений[4].Значение) Тогда

                        МенеджерЗаписи.Контрагент                 = Элем.КлючЗаписиРегистраСведений[4].Значение;
                    //КонецЕсли;

                    //Если ЗначениеЗаполнено(Элем.КлючЗаписиРегистраСведений[5].Значение) Тогда

                        МенеджерЗаписи.Договор                    = Элем.КлючЗаписиРегистраСведений[5].Значение;
                    //КонецЕсли;

                    //Если ЗначениеЗаполнено(Элем.КлючЗаписиРегистраСведений[6].Значение) Тогда

                        МенеджерЗаписи.НаправлениеДеятельности = Элем.КлючЗаписиРегистраСведений[6].Значение;
                    //КонецЕсли;

                    МенеджерЗаписи.Прочитать();
                    Если МенеджерЗаписи.Выбран() Тогда
                        МенеджерЗаписи.Удалить();                    
                    КонецЕсли;
   ДенисЧ
 
5 - 14.08.21 - 10:03
Надо заполнять ВСЕ измерения для нахождения записи
   NIGHTHUNTER
 
6 - 14.08.21 - 10:31
(5) в (4) период не заполнен, хотя его там и нет, это как то может влиять?

Я не заполнял, потому что они же пустые, чем заполнять? Если их нет.
   Жан Пердежон
 
7 - 14.08.21 - 10:51
(0) начиная с выбора имен и заканчивай выбором типов и способа обработки - говнокод
   NIGHTHUNTER
 
8 - 14.08.21 - 10:57
Сейчас смотрю, и при условии что 

Если МенеджерЗаписи.Выбран() - Истина и есть Удалить

запись в регистре сведений остается (((( по какой причине? Что исправить?
   NIGHTHUNTER
 
9 - 14.08.21 - 11:04
МенеджерЗаписи                                = РегистрыСведений.АналитикаУчетаПоПартнерам.СоздатьМенеджерЗаписи();
                        МенеджерЗаписи.Партнер                 = Элем.КлючЗаписиРегистраСведений[2].Значение;
                        МенеджерЗаписи.Организация             = Элем.КлючЗаписиРегистраСведений[3].Значение;
                        МенеджерЗаписи.Контрагент              = Элем.КлючЗаписиРегистраСведений[4].Значение;
                        МенеджерЗаписи.Договор                 = Элем.КлючЗаписиРегистраСведений[5].Значение;
                        МенеджерЗаписи.НаправлениеДеятельности = Элем.КлючЗаписиРегистраСведений[6].Значение;
                    МенеджерЗаписи.Прочитать();
                    Если МенеджерЗаписи.Выбран() Тогда
                        МенеджерЗаписи.Удалить();                    
                    КонецЕсли;


Все задано, и отрабатывает Удалить, почему запись остается ?
   NIGHTHUNTER
 
10 - 14.08.21 - 11:07
(9+)  Отработала второй раз, записи удалились!!!!!

То есть нужно по 2 раза что ли прогонять?????

                    МенеджерЗаписи.Прочитать();
                    Если МенеджерЗаписи.Выбран() Тогда
                        МенеджерЗаписи.Удалить();                    
                    КонецЕсли;
//

                    МенеджерЗаписи.Прочитать();
                    Если МенеджерЗаписи.Выбран() Тогда
                        МенеджерЗаписи.Удалить();                    
                    КонецЕсли;

Разве так делается?

Ну если первый раз записи остаются, и удаляются второй раз. я подумал что можно так сделать?!
   vicof
 
11 - 14.08.21 - 13:07
Ты балбес, тебе уже 50 раз говорили как и что удалять.
   NIGHTHUNTER
 
12 - 14.08.21 - 13:29
(11) в (9) правильный код, делаю через менеджер записи, но удаляет если запустить 2 раза
   NIGHTHUNTER
 
13 - 14.08.21 - 13:45
Кто подскажет? Я вот сделал в (9) как говорили, что у меня тогда такое? Почему с первого раза не удаляет? находится потом снова!
   NIGHTHUNTER
 
14 - 14.08.21 - 14:05
Этот код работает так же как и (9)

                    //

                    НаборЗаписей =                                         РегистрыСведений.АналитикаУчетаПоПартнерам.СоздатьНаборЗаписей();
                    //

                    НаборЗаписей.Отбор.Партнер.Установить(                 Элем.КлючЗаписиРегистраСведений[2].Значение );
                    НаборЗаписей.Отбор.Организация.Установить(             Элем.КлючЗаписиРегистраСведений[3].Значение );
                    НаборЗаписей.Отбор.Контрагент.Установить(              Элем.КлючЗаписиРегистраСведений[4].Значение );
                    НаборЗаписей.Отбор.Договор.Установить(                 Элем.КлючЗаписиРегистраСведений[5].Значение );
                    НаборЗаписей.Отбор.НаправлениеДеятельности.Установить( Элем.КлючЗаписиРегистраСведений[6].Значение );
                    //

                    НаборЗаписей.Записать();                    
                    //
   NIGHTHUNTER
 
15 - 14.08.21 - 14:05
запись появляется повторно!!!!!
   NIGHTHUNTER
 
16 - 14.08.21 - 14:36
Подскажите пожалуйста, почему (9) и (14) не удаляют записи????

Заметил что если запустить второй раз, тогда они пропадают.

Я не понимаю !!!!
   NIGHTHUNTER
 
17 - 14.08.21 - 14:39
При запуске второй раз, запись пропадает из регистра сведений (((( Но почему не на первом запуске?

ВЫБРАТЬ
    АналитикаУчетаПоПартнерам.Партнер КАК Партнер,
    АналитикаУчетаПоПартнерам.Организация КАК Организация,
    АналитикаУчетаПоПартнерам.Контрагент КАК Контрагент,
    АналитикаУчетаПоПартнерам.Договор КАК Договор,
    АналитикаУчетаПоПартнерам.НаправлениеДеятельности КАК НаправлениеДеятельности,
    АналитикаУчетаПоПартнерам.КлючАналитики КАК КлючАналитики
ИЗ
    РегистрСведений.АналитикаУчетаПоПартнерам КАК АналитикаУчетаПоПартнерам
ГДЕ
    АналитикаУчетаПоПартнерам.Партнер.Код = &ПартнерКод
   DrShad
 
18 - 14.08.21 - 14:44
Записать <> прочитать, очистить и записать
   NIGHTHUNTER
 
19 - 14.08.21 - 15:23
(18) Подскажите пожалуйста по коду, учитывая (9) и (14), что можно реально попробовать?
Если я чт от оне так делаю, я делаю по имеющимся примерам и по тому что советовали, но что не так?
Как именно должно быть7 Подскажите? Как нужно изменить (9) или (14) что бы это работало с первого раза?
На некоторых регистрах работает , а на одном вот нет. Потом смотрю. и ещё на одном тоже так же стало.
   NIGHTHUNTER
 
20 - 14.08.21 - 15:24
(18) Я не понимаю как нужно правильно, вроде как (9) и (14) и так должны работать!
   NIGHTHUNTER
 
21 - 14.08.21 - 15:25
(18) О чем это? Как \это можно применить, к изменению (9) или (14) ?
   МимохожийОднако
 
22 - 14.08.21 - 15:47
ОФФ: "Угадал все буквы, но не смог назвать слово".
   NIGHTHUNTER
 
23 - 14.08.21 - 16:00
Я пробую вот так вот. Все отрабатывает. И очистить и записать. Но запись все равно остается ((
Что это значит???
                    //

                    НаборДанных = РегистрыСведений.АналитикаУчетаПоПартнерам.СоздатьНаборЗаписей();
                    НаборДанных.Отбор.Партнер.Установить(Элем.КлючЗаписиРегистраСведений[2].Значение);
                    НаборДанных.Прочитать();
                    Если НаборДанных.Количество() Тогда
                       НаборДанных.Очистить();
                       НаборДанных.Записать();
                    Иначе
                       Сообщить("Не найдены записи по партнеру " + Элем.КлючЗаписиРегистраСведений[2].Значение + " в регистре сведения АналитикаУчетаПоПартнерам" );
                    КонецЕсли;                    
                    //
   NIGHTHUNTER
 
24 - 14.08.21 - 16:00
Как что бы очищалось с первого раза? Я же уже всяко попробовал!
   ДенисЧ
 
25 - 14.08.21 - 16:03
"я делаю по ... тому что советовали"

Если бы ты делал то, что тебе советуют, ты давно бы уже 1с бросил.
   Жан Пердежон
 
26 - 14.08.21 - 17:01
проверь типы данных - хз какие они у тебя в регистре и в списке значений
   NIGHTHUNTER
 
27 - 14.08.21 - 17:05
(26) Список значений, это перебор тз, найти по ссылкам

Заходит же в условия, и читается

что именно проверить?

http://joxi.ru/nAyO34BuaY415m
   NIGHTHUNTER
 
28 - 14.08.21 - 17:07
http://joxi.ru/J2bkE89HgXlZKA

это так в этом случае, в другом по другому
   NIGHTHUNTER
 
29 - 14.08.21 - 17:15
http://joxi.ru/ZrJbWlNCb9vE5r

Видите одинаковый тип, и заходит по условию.

Вот это уже второй запуск. Почему при первом так же отработав, не очистились, не удалились записи?
   NIGHTHUNTER
 
30 - 14.08.21 - 17:16
это тут не причем?

http://joxi.ru/V2VWkZai8xN63A
 
 
   NIGHTHUNTER
 
31 - 15.08.21 - 05:52
UP
   NIGHTHUNTER
 
32 - 15.08.21 - 06:07
Подскажите пожалуйста, какими методами мне сейчас действовать, что бы добиться очищение регистра с первого раза?

Сейчас я заметил, что после работа выше приведенного кода, записи не то что бы очищаются, а их стало 2.

Проверяю в консоле запросов.
   МимохожийОднако
 
33 - 15.08.21 - 06:31
(23) Какой смысл вкладываешь в условие
НаборДанных.Количество() ?
   Ёпрст
 
34 - 15.08.21 - 08:53
(23) И не благодари
  
   НаборДанных = РегистрыСведений.АналитикаУчетаПоПартнерам.СоздатьНаборЗаписей();
     НаборДанных.Отбор.Партнер.Установить(Элем.КлючЗаписиРегистраСведений[2].Значение);
     НаборДанных.Записать();

   NIGHTHUNTER
 
35 - 15.08.21 - 13:18
(34) Не работает это. У меня такой же код есть, я перепробовал то есть все что можно.

И думаю тут дело в том что я по задаче, -

1. Получаю, НайтиПоСсылкам, ссылки на имеющегося партнера. И потом перебором, в момент когда включено проставляется в истина,
   обрабатываю сам некоторые строки, этой полученной таблицы со ссылками.

2. А именно, это регистры сведений, некоторые. Которые нужно исключить из обработки. То есть не ставя им, включено в истина. а оставив в ложь.
   Очистить их запись.
Первое с чем я борюсь, это регистр сведений АналитикаУчетаПопартнерам. Дело в том что перед ним идет обработка справочника КлючиАналитикиУчетаПоПартнерам

а этот справочник, тип ресурса ключ Аналитики, регистра сведений АналитикаУчетаПопартнерам. Он не удаляет существующую запись. Еще и задваивает имеющуюся с другим ключем аналитики.

Подозреваю что это от предварительной обработки справочника КлючиАналитикиУчетаПоПартнерам . Но вот как мне добиться все же очищения регистра АналитикаУчетаПоПартнерам,
я пока не понимаю. Используя вот этот же код (34) . Я проверял какие тольк оможно варианты кода. запись, исчезает только со второго раза. Так как после обработки, я проверяю.

Пока ничего мне не понятно. Подскажите если кто знает. но я вижу что тут разбираться только мне самому.
   NIGHTHUNTER
 
36 - 15.08.21 - 13:42
(35+) Я не понимаю, как мне отловить этот момент, и почему не очищается регистр сведений.
   Хосе
 
37 - 15.08.21 - 13:44
(36) Сложность УТ11 превысила возможности эникеев. ;-)
(35) Задача криво сформулирована, четко пропиши, тогда подскажу, я не понимаю, чего ты хочешь.
   NIGHTHUNTER
 
38 - 15.08.21 - 14:12
(37) Переделал обработку поиска и замены ссылок под эксель лист.

                ИначеЕсли Элем.ПредставлениеМетаДанных = "РегистрСведений.АналитикаУчетаПоПартнерам" Тогда

Вот этот регистр, мне нужно очистить, не передавая его на замену ссылок, что я и пытаюсь делать, но он очищается только если выполнить код 2 раза.

Для тестирования использую сейчас по одной строке. Код партнера для замены, и код партнера на замену.

Находятся все ссылки по партнеру для замены. И передаются на обработку, на замену на партнера на замену.

Некоторые регистры, из этой таблицы значений найденных ссылок, я исключаю из обработки. Мне их нужно просто очистить.

Вот один из них это РС.АналитикаУчетаПоПартнерам . Но он очищается если запустить весь код 2 раза. Почему не очищается с первого я не понимаю.

Если после первой обработки появляются 2 записи в этом регистре.

http://joxi.ru/eAObaQlC6xq1p2
   NIGHTHUNTER
 
39 - 15.08.21 - 14:16
(38) Исключил из обработки справочник "КлючиАналитикиУчетаПоПартнерам" .
Обработал.
Проверяю. Остались как записи справочника "КлючиАналитикиУчетаПоПартнерам" .
Так и запись регистра сведений АналитикаУчетаПоПартнерам .
   NIGHTHUNTER
 
40 - 15.08.21 - 14:38
(34) Записей в регистре становится 2 после первой обработки, я даже не могу представить почему.
   NIGHTHUNTER
 
41 - 15.08.21 - 14:40
   NIGHTHUNTER
 
42 - 15.08.21 - 14:42
После второй обработки, то есть запуска того же кода, записи пропадают. нужно что бы пропадали после первого.
Вопрос, от куда берется дубль. После первого раза. И почему не удаляется, после первого раза. А удаляется после второго ((.

Код очистки РС сейчас такой
                ИначеЕсли Элем.ПредставлениеМетаДанных = "РегистрСведений.АналитикаУчетаПоПартнерам" Тогда
                    НаборДанных = РегистрыСведений.АналитикаУчетаПоПартнерам.СоздатьНаборЗаписей();
                    НаборДанных.Отбор.Партнер.Установить(Элем.КлючЗаписиРегистраСведений[2].Значение);
                    НаборДанных.Записать();
   hhhh
 
43 - 15.08.21 - 15:10
(42) поаробуй НаборДанных.ОбменДанными.Загрузка = Истина;
   NIGHTHUNTER
 
44 - 15.08.21 - 16:40
(43) Ок, попробую. Там смотрю, по контрагентам так же пара регистров не очищается. Только со второго раза.

Но вот утром, ломая голову над вопросом, я  уже это пробовал. Ничего не дало ((((. Пробовал так же разные способы.

буду продолжать, но как то ощущаю что я потерялся уже в какой то не ведомом поведении платформы.
   vicof
 
45 - 16.08.21 - 00:16
(44) В который раз...
   NIGHTHUNTER
 
46 - 16.08.21 - 04:38
АналитикаУчетаПопартнерам пока не попадается, сейчас проблема вот с этим регистром СостоянияКонтрагентовБЭД

выше отрабатывается регистр СостоянияКонтрагентов, с подобным кодом, и вроде как очищается, вроде как, потому что я не знаю как будет потом, но вот этот
СостоянияКонтрагентовБЭД, не очищается с первого раза ((( Со второго очищается. Что это означает?
                ИначеЕсли Элем.ПредставлениеМетаДанных = "РегистрСведений.СостоянияКонтрагентовБЭД" Тогда
                    // РегистрСведений.СостоянияКонтрагентовБЭД (Не периодический, не зависимый)

                    //

                    МенеджерЗаписи            = РегистрыСведений.СостоянияКонтрагентовБЭД.СоздатьМенеджерЗаписи();
                    МенеджерЗаписи.Контрагент = Элем.КлючЗаписиРегистраСведений[2].Значение;
                    МенеджерЗаписи.Прочитать();
                    Если МенеджерЗаписи.Выбран() Тогда
                        МенеджерЗаписи.Удалить(); 
                    КонецЕсли;
                    //

                    //НаборДанных = РегистрыСведений.СостоянияКонтрагентовБЭД.СоздатьНаборЗаписей();

                    //НаборДанных.Отбор.Контрагент.Установить(Элем.КлючЗаписиРегистраСведений[2].Значение);

                    //НаборДанных.Записать();                    

                    //
   NIGHTHUNTER
 
47 - 16.08.21 - 04:45
Не очищает с первого раза

                    НаборДанных = РегистрыСведений.СостоянияКонтрагентовБЭД.СоздатьНаборЗаписей();
                    НаборДанных.Отбор.Контрагент.Установить(Элем.КлючЗаписиРегистраСведений[2].Значение);
                    НаборДанных.ОбменДанными = Истина;
                    НаборДанных.Записать();
   NIGHTHUNTER
 
48 - 16.08.21 - 05:07
С СостоянияКонтрагентовБЭД разобрался вроде .

Сейчас буду разбираться с АналитикаУчетаПоПартнерам .
   NIGHTHUNTER
 
49 - 16.08.21 - 09:05
Сейчас вот проверил. снова. Не очищается регистр сведений аналитика учета по партнерам.

Думал дело в справочнике КлючиАналитикиУчетаПоПартнерам, так как он является типом ресурса этого регистра. Но нет. не в этом.

Вот этот код отрабатывает, запись остается. Как мне ее очистить?
                ИначеЕсли Элем.ПредставлениеМетаДанных = "РегистрСведений.АналитикаУчетаПоПартнерам" Тогда
                НаборДанных = РегистрыСведений.АналитикаУчетаПоПартнерам.СоздатьНаборЗаписей();
                НаборДанных.Отбор.Партнер.Установить(Элем.КлючЗаписиРегистраСведений[2].Значение);
                НаборДанных.Записать();                    

При запуске обработки ещё раз, тоесть когда там остается запись по этому регистру сведений аналитика учета по партнерам, тонда запись удаляется.

В чем может быть причина, не удаления ее в первый раз?
   hhhh
 
50 - 16.08.21 - 11:11
(47) НаборДанных.ОбменДанными.ЗАГРУЗКА = Истина;

у вас какое-то рассеянное внимание.
   NIGHTHUNTER
 
51 - 16.08.21 - 11:36
(50) Я же говорю, делал. Не помогло!!!

Смотрите как сейчас. Идет на обработку таблица ссылок. Среди которых АналитикаУчетаПоПартнерам. Мне нужно очистить этот регистр.

Код такой, -

    НаборДанных = РегистрыСведений.АналитикаУчетаПоПартнерам.СоздатьНаборЗаписей();
    НаборДанных.Отбор.Партнер.Установить(Элем.КлючЗаписиРегистраСведений[2].Значение);
    НаборДанных.Записать();                    

Перед записать НаборДанных.ОбменДанными.ЗАГРУЗКА = Истина; ? Я делал не помогло.

Тут такой случай. Ставлю

ИначеЕсли Элем.ПредставлениеМетаДанных = "Справочник.КлючиАналитикиУчетаПоПартнерам" Тогда
    //Элем.Включено = Ложь;                    


то есть Ключи аналитики учета по партнерам, не обрабатываются. Включено = Ложь.

И вот в этом случае, регистр Аналитика учета по партнерам очищается.. После уже не находится. Но остаются ссылки на справочник КлючиАналитикиУчетаПоПартнерам .

Как тут с этим быть может кто знает?
   NIGHTHUNTER
 
52 - 16.08.21 - 11:37
(51) Мне справочник, КлючиАналитикиПоПартнерам тоже нужно удалить !!!
   ДенисЧ
 
53 - 16.08.21 - 11:39
(52) Удаляй!!!
   Обработка
 
54 - 16.08.21 - 11:44
53 сообщений из них 95 % сообщения автора. Я в шоке.
Да ну нафиг бегу из ветки.
   NIGHTHUNTER
 
55 - 16.08.21 - 11:44
(50) Это не помогает, остаются записи по РС.АналитикаУчетаПоПартнерам.

    НаборДанных = РегистрыСведений.АналитикаУчетаПоПартнерам.СоздатьНаборЗаписей();
    НаборДанных.Отбор.Партнер.Установить(Элем.КлючЗаписиРегистраСведений[2].Значение);
    НаборДанных.ОбменДанными.ЗАГРУЗКА = Истина;
    НаборДанных.Записать();                    

Записи пропадают только если 

Ставлю

ИначеЕсли Элем.ПредставлениеМетаДанных = "Справочник.КлючиАналитикиУчетаПоПартнерам" Тогда
    //Элем.Включено = Ложь;                    



то есть Ключи аналитики учета по партнерам, не обрабатываются. Включено = Ложь.

И вот в этом случае, регистр Аналитика учета по партнерам очищается.. После уже не находится. Но остаются ссылки на справочник КлючиАналитикиУчетаПоПартнерам .

(53) Опечатался!!!!! Мне этот справочник нужно передать на замену ссылок дальше по алгоритму.
Но если я это делаю, остаются записи регистра сведений Аналитикаучета Попартнерам, или вообще раздваиваются!!!!

Почему так?
   NIGHTHUNTER
 
56 - 16.08.21 - 11:47
(55+) Еще один цикл делать по этой таблице?????
   NIGHTHUNTER
 
57 - 16.08.21 - 11:48
(56+) Должно обрабатываться в одной итерации, же!
   hhhh
 
58 - 16.08.21 - 11:49
(55) но зачем вам всё это нужно? Первый раз вижу чела, который напропалую удаляет записи служебных регистров. База же может рухнуть.
   NIGHTHUNTER
 
59 - 16.08.21 - 11:51
(58) Производится замена элементов, удаляются не нужные записи регистров.
   DrShad
 
60 - 16.08.21 - 11:54
(55) они не задваиваются, тебе это кажется
 
 
   Ёпрст
 
61 - 16.08.21 - 11:55
(55) дарю, и не благодари


    НаборДанных = РегистрыСведений.АналитикаУчетаПоПартнерам.СоздатьНаборЗаписей();
//  НаборДанных.Отбор.Партнер.Установить(Элем.КлючЗаписиРегистраСведений[2].Значение);

    НаборДанных.ОбменДанными.ЗАГРУЗКА = Истина;
    НаборДанных.Записать();  


Потом прибегай сюда, будем рассказывать как восстанавливать утерянные данные.
   DrShad
 
62 - 16.08.21 - 11:58
(61) ну зачем же так радикально ? )))
   Ёпрст
 
63 - 16.08.21 - 11:59
(62) ты не поверишь, но после (61) записи у него затроятся.. :)
   hhhh
 
64 - 16.08.21 - 12:00
(59) вы же прекрасно знаете, что если у измерения регистра стоит галочка ведущее, то запись регистра удаляется автоматически сама по себе. У вас измерение Партнер - ведущее. Значит если вы удалите партнера, значит, и записи регистра сами удалятся. Зачем вы занимаетесь какой-то неведомой хренью?
   DrShad
 
65 - 16.08.21 - 12:02
(63) это я то не поверю!?
   DrShad
 
66 - 16.08.21 - 12:02
(64) он об этом не знает
   NIGHTHUNTER
 
67 - 16.08.21 - 12:48
Вот что я выявил!!!!!!
Записи появляются после, замены ссылок в элементах справочника КлючиАналитикиУчетаПоПартнерам .

Причем, я исключил его из обработки, решив обработать в другой итерации, вне общей обработке. И вот выясняется, что записи регистра АналитикаУчетаПоПартнерам,
не появятся после обработки, если не обрабатывать КлючиАналитикиУчетаПоПартнерам .

Если же обрабатывать КлючиАналитикиУчетаПоПартнерам, то есть производить замену ссылок, то записи АналитикаУчетаПоПартнерам, будут появляться как буд то бы их не удаляли.

И не появятся если не обрабатывать КлючиАналитикиУчетаПоПартнерам, не скажете почему так работает, и как это обойти?

Что бы заменить ссылки и у КлючиАналитикиУчетаПоПартнерам, и что бы записей не стало у АналитикаУчетаПоПартнерам .
   NIGHTHUNTER
 
68 - 16.08.21 - 12:49
(64) Про удаление партнера речи пока не шло, речь шла о замене ссылок в таких то объектах, и очистка таких то регистров.

Но вот я выявил, что при замере ссылок у Справочник.КлючиАналитикиУчетаПоПартнерам, записи РС.АналитикаУчетаПоПартнерам, так и будут в наличии, хоть заудаляйся !!!!
   DrShad
 
69 - 16.08.21 - 12:52
(68) потому что ты не понимая как все работает, начинаешь что-то делать
   DrShad
 
70 - 16.08.21 - 12:53
(67) у тебя запись удаляется, но при записи ключа снова создается
   NIGHTHUNTER
 
71 - 16.08.21 - 13:22
(69) Согласен, от куда мне это знать? Столкнулся вот и  думаю как решить.

(70) Но я не удаляю ключ КлючиАналитикиУчетаПоПартнерам , я делаю замену ссылок.
Получается что при замене ссылок, тоже записи создаются в регистре сведений АналитикаУчетаПоПартнерам ?

Как тут правильно будет? Не трогать Справочник.КлючиАналитикиУчетаПоПартнерам ? Не менять в нем ссылки?

Но а что он будет болтаться? Из за него партнера этого нельзя будет удалить?
   NIGHTHUNTER
 
72 - 16.08.21 - 13:23
(70) Подскажите пожалуйста. а как это определяется, что при замене ссылок у элемента справочника КлючиАналитикиУчетаПоПартнерам , появляются записи в регистре сведений АналитикаУчетаПоПартнерам  ?
   NIGHTHUNTER
 
73 - 16.08.21 - 13:31
(70) пока я менял ссылки с элементов справочника КлючиАналитикиУчетаПоПартнерам , получается если его удалять, то записи в РС.АналитикаУчетаПоПартнерам , создадутся снова????
   NIGHTHUNTER
 
74 - 16.08.21 - 13:34
как тогда избавляться от КлючиАналитикиУчетаПоПартнерам , что бы не создавались записи в РС.АналитикаУчетаПоПартнерам  ?
   DrShad
 
75 - 16.08.21 - 13:37
тебе уже неоднократно все объяснили, но ты упорно пытаешься изобрести велописед
   NIGHTHUNTER
 
76 - 16.08.21 - 14:24
(75) я всего лишь задал вопрос в (74)
   DrShad
 
77 - 16.08.21 - 14:26
(76) если ты не понял ответа, это не означает что тебе не дали
   DrShad
 
78 - 16.08.21 - 14:30
в (64) тебе уже подробно все рассказали
   hhhh
 
79 - 16.08.21 - 15:13
(71) да, нужно поменять в нем ссылки.
   NIGHTHUNTER
 
80 - 16.08.21 - 16:39
(79) Я же вам рассказываю, что я передаю Справочник.КлючиАналитикиУчетаПоПартнерам , что бы поменять в нем ссылки.

(78) Много шустрых!!!!! Только я по теме сижу!!!!

И все!!!! РС.АналитикаУчетаПоПартнерам, хоть заудаляйся там появляются и остаются записи, после обработки!!!!!
В чем проблема, понимаете????

Если исключить из замены ссылок Справочник.КлючиАналитикиУчетаПоПартнерам, вот тогда РС.АналитикаУчетаПоПартнерам пуст!!!!!
Почему я не знаю!

Я знаю что мне надо делать!!!!! Я вижу что Справочник.КлючиАналитикиУчетаПоПартнерам не нужно вообще трогать!
   hhhh
 
81 - 16.08.21 - 16:51
(80) вам уже написали, как только будете чистить справочник Партнеры, ненужные записи регистра сами удалятся. Что тут непонятного. Вообще забудьте про этот регистр, думайте про справочник Партнеры.
   NIGHTHUNTER
 
82 - 16.08.21 - 16:53
(81) Я не касался удаления партнеров, понимаете?
   Жан Пердежон
 
83 - 16.08.21 - 16:54
(82) у всех всё нормально удаляется, понимаешь?
   hhhh
 
84 - 16.08.21 - 16:57
(82) ваша единственная задача - это удаление лишних партнеров. Как это вы этого не касаетесь? Зачем тогда ссылки меняете в справочнике ключи аналитики?
   NIGHTHUNTER
 
85 - 16.08.21 - 17:09
(84) должно решиться все со временем
пока видно что, сказали так, аааа, ну как удалять партнеров?
Нужно оставить может!
Вот и справочник этот не трогать тогда!!!!! Может что и ещё.

Я в заглушке, без обратной связи, смотрел, как тут что работает, если так.
   Жан Пердежон
 
86 - 16.08.21 - 17:18
(85) открою тебе секрет, как ты должен был с такой херней разобраться:

1. ставишь точку останова в При/Перед записью набора записей твоего регистра;
2. запускаешь свою мегаполезную обработку;
3. когда срабатывает точка останова - смотришь Стек вызовов - откуда вызвалась запись и по какому условию;
4. делаешь выводы, правишь свою обработку, чтобы она стала еще полезнее.
   NIGHTHUNTER
 
87 - 17.08.21 - 09:22
(84) Я меняю ссылки по партнеру, что находит обработка.
Она нашла ссылки в справочнике КлючиАналитикиУчетаПоПартнерам  .

Пока я не понимаю как удалить этот элемент справочника КлючиАналитикиУчетаПоПартнерам  .

При удалении партнера, элемент справочника КлючиАналитикиУчетаПоПартнерам удалится сам?
   DrShad
 
88 - 17.08.21 - 09:26
обработка УдалениеНеиспользуемыхЭлементовСправочников
   NIGHTHUNTER
 
89 - 17.08.21 - 09:40
(88) Требуется, что бы в одной обработке все отрабатывало.

Пока не выяснил как с (87) .
   DrShad
 
90 - 17.08.21 - 09:44
(89) увольняйся
   DrShad
 
91 - 17.08.21 - 09:51
делаешь замену партнеров и контрагентов, регистры сведений сами перезапишутся, помечаешь на удаление всех партнеров, контрагентов и ключи, выполняешь удаление помеченных (при этом регистр сведений тоже почистится), все что не удалилось снимаешь пометку удаления

profit


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.