Вход | Регистрация
 

СтрНайти СтрРазделить на УТ10 но новой 1С

СтрНайти СтрРазделить на УТ10 но новой 1С
Я
   Maniac
 
13.08.21 - 15:11
Клиент прислал УТ10. туда встроил свои приблуды.

НО ругается на два стандартных метода СтрНайти СтрРазделить

Платформа стоит последняя. Самый прикол что у меня УТ10 для разработки даже новее совместимость стоит 8.2.13 , а него старее и Версия 8.2.16

Никаких у меня багов никогда не было с этими модулями, а у него орет что таких методов не найдено.

В описании 1С указано что для их работу 8.3.6 нужна, так стоит уже давно 8.3.19
   Maniac
 
1 - 13.08.21 - 15:11
В нете вообще ничего по этому багу не найти. Пишут тоже самое что в справке. Я ничерта понять не могу почему на одной вообще все отлично и никаких проблем, а на присланной не находит их.
   Dmitry1c
 
2 - 13.08.21 - 15:13
Дак если был в той или иной конфе глобальный модуль, который эмулирует эти функции, а его сейчас нет - оттуда и проблема
   ДенисЧ
 
3 - 13.08.21 - 15:13
Поток сознания.
Использовать новые функции на старых совместимостях - тут поможет только паталогоанатом.
   d4rkmesa
 
4 - 13.08.21 - 15:14
(0) В твоей конфе есть глобальный модуль с функциями-прокладками. )
   garantNo4x
 
5 - 13.08.21 - 15:15
и что .. даже в типовых есть функиии которые их заменяют
   garantNo4x
 
6 - 13.08.21 - 15:16
их не было в 8.2 ..
   Maniac
 
7 - 13.08.21 - 15:16
Блин. Сто процентов!
ИнтеграцияМОТПУТКлиентСервер
   garantNo4x
 
8 - 13.08.21 - 15:17
давай лучше про мерседесы ..
   Maniac
 
9 - 13.08.21 - 15:19
ИнтеграцияИСУТКлиентСерверГлобальный
   H A D G E H O G s
 
10 - 13.08.21 - 15:55
Подхвачена пальма Г1С, я смотрю.
   fisher
 
11 - 13.08.21 - 16:01
(0)
> у меня УТ10 для разработки даже новее совместимость стоит 8.2.13 , а него старее и Версия 8.2.16
> В описании 1С указано что для их работу 8.3.6 нужна, так стоит уже давно 8.3.19
Если бы новые функции работали на любых совместимостях, но нафига эти самые совместимости вообще нужны были?
Не знаю, кто врет, кто заблуждается, а кто пиздоглазит, но новые функции на старых совместимостях работать не могут.
   ДенисЧ
 
12 - 13.08.21 - 16:29
(11) Но асинхи на 18й платформе совместимости 14 работают )))
   Garykom
 
13 - 13.08.21 - 16:36
(12) "кто врет, кто заблуждается, а кто пиздоглазит"
   ДенисЧ
 
14 - 13.08.21 - 16:37
(13) Хочешь сказать, что асинхи не работают? О_о
   Быдло замкадное
 
15 - 13.08.21 - 16:39
(0) При чем тут релиз платформы? Режим совместимости в конфигурации сомтри
   Быдло замкадное
 
16 - 13.08.21 - 16:40
Функция СтрСравнить(Перем1, Перем2) Экспорт
    
    СравнениеЗначений = Новый СравнениеЗначений;
    
    Результат = СравнениеЗначений.Сравнить(Перем1, Перем2);
    
    Возврат Результат;
    
КонецФункции

Функция СтрРазделить(Текст, Разделитель, ВключатьПустые = Ложь) Экспорт

    Результат = РазложитьСтрокуВМассивПодстрокБСП(Текст, Разделитель);    
    
    Возврат Результат;
    
КонецФункции    

// Функция "расщепляет" строку на подстроки, используя заданный 

//        разделитель. Разделитель может иметь любую длину. 
//        Если в качестве разделителя задан пробел, рядом стоящие пробелы 

//        считаются одним разделителем, а ведущие и хвостовые пробелы параметра Стр
//        игнорируются.

//        Например, 
//        РазложитьСтрокуВМассивПодстрок(",ку,,,му", ",") возвратит массив значений из пяти элементов, 

//        три из которых - пустые строки, а 
//        РазложитьСтрокуВМассивПодстрок(" ку   му", " ") возвратит массив значений из двух элементов

//
//    Параметры: 

//        Стр -             строка, которую необходимо разложить на подстроки. 
//                        Параметр передается по значению.

//        Разделитель -     строка-разделитель, по умолчанию - запятая.
//

//
//    Возвращаемое значение:

//        массив значений, элементы которого - подстроки
//

Функция РазложитьСтрокуВМассивПодстрокБСП(Знач Стр, Разделитель = ",") Экспорт
    
    МассивСтрок = Новый Массив();
    Если Разделитель = " " Тогда
        Стр = СокрЛП(Стр);
        Пока 1=1 Цикл
            Поз = Найти(Стр,Разделитель);
            Если Поз=0 Тогда
                МассивСтрок.Добавить(Стр);
                Возврат МассивСтрок;
            КонецЕсли;
            МассивСтрок.Добавить(Лев(Стр,Поз-1));
            Стр = СокрЛ(Сред(Стр,Поз));
        КонецЦикла;
    Иначе
        ДлинаРазделителя = СтрДлина(Разделитель);
        Пока 1=1 Цикл
            Поз = Найти(Стр,Разделитель);
            Если Поз=0 Тогда
                МассивСтрок.Добавить(Стр);
                Возврат МассивСтрок;
            КонецЕсли;
            МассивСтрок.Добавить(Лев(Стр,Поз-1));
            Стр = Сред(Стр,Поз+ДлинаРазделителя);
        КонецЦикла;
    КонецЕсли;
    
КонецФункции// глРазложить


Функция СтрСоединить(МассивСтрок, Разделитель = "") Экспорт
    
    Результат = "";
    
    Для Каждого ЭлементМассива Из МассивСтрок Цикл
        
        Результат = Результат + ЭлементМассива + Разделитель;    
        
    КонецЦикла;
    
    ОтрезатьСимволов = СтрДлина(Разделитель);
    
    ОставитьСимволов = СтрДлина(Результат) - ОтрезатьСимволов;
    
    Результат = Лев(Результат, ОставитьСимволов);
    
    Возврат Результат;
    
КонецФункции

Функция СтрНачинаетсяС(НачалоСтроки, СтрокаПоиска) Экспорт
    
    КолВоСимволов = СтрДлина(СтрокаПоиска);    
    
    КолВоСимволовНачалоСтроки = СтрДлина(НачалоСтроки);
    
    Если КолВоСимволов = 0 ИЛИ КолВоСимволовНачалоСтроки = 0 Тогда
        
        Возврат Ложь;
        
    КонецЕсли;
    
    Если Лев(НачалоСтроки, КолВоСимволов) = СтрокаПоиска Тогда
        
        Результат = Истина;
        
    Иначе
        
        Результат = Ложь;
        
    КонецЕсли;
    
    Возврат Результат;
    
КонецФункции

Функция СтрНайти(Строка, ПодстрокаПоиска, НаправлениеПоиска = Неопределено, НачальнаяПозиция = Неопределено, НомерВхождения = 1) Экспорт
    // НаправлениеПоиска: СКонца,СНачала. По умолчанию: СНачала

    
    Если Строка = "" и ПодстрокаПоиска = "" Тогда
        // чтобы отрабатывало как в платформе

        Если НаправлениеПоиска = "СКонца" Тогда
            Если НомерВхождения = 1 Тогда
                Возврат 1;
            Иначе
                Возврат 0;
            КонецЕсли;
        Иначе
            Возврат мин(НомерВхождения, ?(НачальнаяПозиция=Неопределено, 1, НачальнаяПозиция));
        КонецЕсли;
    КонецЕсли;
    
    Если НачальнаяПозиция = Неопределено Тогда
        Если НаправлениеПоиска = "СКонца" Тогда
            лНачальнаяПозиция = СтрДлина(Строка);
        Иначе
            лНачальнаяПозиция = 1;
        КонецЕсли;
    Иначе
        лНачальнаяПозиция = НачальнаяПозиция;
    КонецЕсли;
    
    Если НаправлениеПоиска = "СКонца" Тогда
        лСтрока = "";
        Для сч = 1 По СтрДлина(Строка) Цикл
            лСтрока = Сред(Строка, сч, 1) + лСтрока;
        КонецЦикла;
        лПодстрокаПоиска = "";
        Для сч = 1 По СтрДлина(ПодстрокаПоиска) Цикл
            лПодстрокаПоиска = Сред(ПодстрокаПоиска, сч, 1) + лПодстрокаПоиска;
        КонецЦикла;
        лНачальнаяПозиция = макс(1, СтрДлина(Строка)-лНачальнаяПозиция-СтрДлина(ПодстрокаПоиска)+2);
    Иначе
        лСтрока = Строка;
        лПодстрокаПоиска = ПодстрокаПоиска;
        лНачальнаяПозиция = лНачальнаяПозиция;
    КонецЕсли;
    
    лНомерВхождения = 0;
    Результат = Найти(Сред(лСтрока, лНачальнаяПозиция), лПодстрокаПоиска);
    Пока Результат Цикл
        лНачальнаяПозиция = Результат + лНачальнаяПозиция + СтрДлина(ПодстрокаПоиска)-1;
        лНомерВхождения = лНомерВхождения + 1;
        Если лНомерВхождения = НомерВхождения Тогда
            Прервать;
        КонецЕсли;
        Результат = Найти(Сред(лСтрока, лНачальнаяПозиция), лПодстрокаПоиска);
    КонецЦикла;
    
    Если лНомерВхождения = НомерВхождения Тогда
        Результат = лНачальнаяПозиция - СтрДлина(ПодстрокаПоиска);
    Иначе
        Результат = 0;
    КонецЕсли;
        
    Если НаправлениеПоиска = "СКонца" И Результат<>0 Тогда
        Результат = СтрДлина(Строка) - Результат - СтрДлина(ПодстрокаПоиска) + 2;
    КонецЕсли;
    
    Возврат Результат;
    
КонецФункции
   Garykom
 
17 - 13.08.21 - 16:43
(14) хочу сказать что очень странно
   mikecool
 
18 - 13.08.21 - 16:50
   fisher
 
19 - 13.08.21 - 16:56
(12) Тогда пропиздоглазили разрабы платформы. Может и у ТС такой случай. Типа на каком-то релизе пропиздоглазили а потом пофиксили.
   ДенисЧ
 
20 - 13.08.21 - 17:13
(19) Фи, поручик, что за термины... (((
   Вафель
 
21 - 13.08.21 - 17:46
(19) а у 1с оно так. некоторые процедуры зависят от совместимости, а некоторые нет.
Как оно в 1с выбирается - хз
   МимохожийОднако
 
22 - 14.08.21 - 08:21
(21) По мере поступления информации о багах )
   МимохожийОднако
 
23 - 14.08.21 - 08:23
(16) + )


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.