Вход | Регистрация
 

Не находится контрагент

Не находится контрагент
Я
   NIGHTHUNTER
 
12.08.21 - 14:17
УТ 11.4.

Функцией поиска не находится контрагент, по партнеру.
Вызываю из другой функции, раз находится, потом снова не находится.
от чего может быть такое поведение базы?

В результате чего нельзя вести отладку.

//
&НаСервере
Функция КонтрагентПоПартнеру(ВыбПартнер)
    Если Не ЗначениеЗаполнено(ВыбПартнер) Тогда
        Возврат 0;    
    КонецЕсли;
    Запрос       = Новый Запрос;
    Запрос.Текст = "
        |ВЫБРАТЬ
        |    Контрагенты.Ссылка  КАК Ссылка,
        |    Контрагенты.Партнер КАК Партнер
        |ИЗ
        |    Справочник.Контрагенты КАК Контрагенты
        |ГДЕ
        |    Контрагенты.Партнер = &ВыбПартнер";
    Запрос.УстановитьПараметр("ВыбПартнер", ВыбПартнер);
    Рез = Запрос.Выполнить();
    Если Не Рез.Пустой() Тогда
        Выборка = Рез.Выбрать();
        Выборка.Следующий();
        Возврат Выборка.Ссылка;
    КонецЕсли;
Возврат 0;    
КонецФункции
//
   Kassern
 
1 - 12.08.21 - 14:19
(0) а если их 5 штук для одного партнера, зачем вы берете первого попавшегося?
   vvspb
 
2 - 12.08.21 - 14:20
(1) бизнес по-русски
   NIGHTHUNTER
 
3 - 12.08.21 - 14:21
(1) Вопрос в том, что. То находит, то не находит. Почему так?
   NIGHTHUNTER
 
4 - 12.08.21 - 14:22
(1) Скажут как нужно поправлю. Пока вот в поиске проблема.
   Kassern
 
5 - 12.08.21 - 14:23
(3) чудес не бывает, один и тот же запрос должен возвращать один и тот же результат. Либо запрос другой, либо партнер без контрагента.
   NIGHTHUNTER
 
6 - 12.08.21 - 14:24
(1) Как в вашем случае было бы нужно? Что ещё наложить какой отбор?
Там поиск первоначальный идет вообще по текстовому коду.

(5) В этом и вопрос, что нет. То работает то нет. Сам видел это 2 дня.

Что то с базой? Это глюки.
   runoff_runoff
 
7 - 12.08.21 - 14:33
задублированы партнеры.. одно наименование.. у одного есть контрагенты, у другого нет..
   Kassern
 
8 - 12.08.21 - 14:40
(6) потому что надо сопоставлять не по наименованию, а хотя бы по связке ИНН/КПП что в контрагенте а по нему уже получать партнера.
   NIGHTHUNTER
 
9 - 12.08.21 - 15:20
как правильно запустить ТиИ ? С какими галками?
   NIGHTHUNTER
 
10 - 12.08.21 - 15:20
Дело в том что работает все криво!!!!
   NIGHTHUNTER
 
11 - 12.08.21 - 15:21
(8) Там по ссылке. Ну будет видно можно так сделать. Пока хочу запустить ТиИ
   1Сергей
 
12 - 12.08.21 - 15:24
если один и тот же запрос возвращает разные данные, значит отличаются параметры
   NIGHTHUNTER
 
13 - 12.08.21 - 15:25
(12) Все тоже самое.
Нахожу по коду партнера, проверяю, и смотрю, как отработает поиск. Несколько раз, проверял.
Пока не пришел к этому выводу. ТиИ, нужно пробовать!
   NIGHTHUNTER
 
14 - 12.08.21 - 15:30
Как правильно запустить ТиИ ?

Подскажите пожалуйста.
   NIGHTHUNTER
 
15 - 12.08.21 - 15:32
так можно запустить?

http://joxi.ru/5mdKGW5uaegZXr
   NIGHTHUNTER
 
16 - 12.08.21 - 15:33
   garantNo4x
 
17 - 12.08.21 - 15:34
ну вообще не в кассу все это
   NIGHTHUNTER
 
18 - 12.08.21 - 15:34
(17) Что это значит?
   garantNo4x
 
19 - 12.08.21 - 15:35
(18) это значит что у тебе или на условии не входит или в контрагенте партнер не заполнен .. а тестирование это какая то фантастика
   NIGHTHUNTER
 
20 - 12.08.21 - 15:36
(19) Я же вам объяснял, что в одном случае отрабатывает, в другом нет
спецально делал проверку
   HawkEye
 
21 - 12.08.21 - 15:36
(0) перефразируя выражение: "Если не учить физику в школе, то вся жизнь наполнится чудесами и волшебством"...
получим: "если не учить программирование, то любое поведение системы будет восприниматься как глюки"
   серый КТУЛХУ
 
22 - 12.08.21 - 15:36
(5): поправка: один и тот же запрос с одим(и) и тем(и) же параметром(ами).
что и требуется проверить. причем не только на его представление (тупо выведя в табло или по шифт+ф9) но и по типу.
   NIGHTHUNTER
 
23 - 12.08.21 - 15:37
(20) Что это значит? Нарушение ссылочной целостности. Мне нужно запустить ТиИ, что бы посомтреть как это повлияет. Подскажите с какими галками.
   серый КТУЛХУ
 
24 - 12.08.21 - 15:37
(22)+: его - в смысле параметр (ну или их - в смысле параметры). между "находит" и "не находит".
   NIGHTHUNTER
 
25 - 12.08.21 - 15:38
(22) 100% один и тот же запрос с одним и тем же параметром отрабатывает по разному

Я хочу выполнить ТиИ, кто нибудь знает как его запускать в этом случае правильно?

(16) с какими настройками?
   серый КТУЛХУ
 
26 - 12.08.21 - 15:42
(25): нет. проверяйте представление и тип в работающем и неработающем.
выполняйте на здоровье. дело ваше.
   Мультук
 
27 - 12.08.21 - 15:45
(25) Скажи честно, это база УЖЕ после чудесного удаления дублей или еще нет?
   NIGHTHUNTER
 
28 - 12.08.21 - 16:14
О чем это говорит?

http://joxi.ru/12MyVQliw0YkO2
   hhhh
 
29 - 12.08.21 - 16:20
(28) партнеров поудалял, а карты оставил.
   NIGHTHUNTER
 
30 - 12.08.21 - 16:27
(29) Я ничего не удалял. Я делал их замену. но столкнулся с тем что не находит контрагентов.
Сделал макет с выводом, и увидел, что там раз, находит, раз нет. А потом в самой процедуре вообще не находит.
Вот и решил попробовать ТиИ, потому как работает глючно. Как сейчас выявить это, не знаю. Галки оставил все не изменять пока.
Так как не знаю что ставить.
Вот как это отработает, снова буду пробовать. Там в одной процедуре, раз работает, потом нет. Вот с чем я столкнулся. Что не могу продолжать отладку (.
 
 
   Мультук
 
31 - 12.08.21 - 16:35
(30) Нужно откатиться на резервную копию. И продолжить тесты по замене.
   hhhh
 
32 - 12.08.21 - 17:27
(30) это всё равно, что удалил.
   DJ Anthon
 
33 - 12.08.21 - 19:25
Это еще цветочки ) Базе уже пижда, верни копию, где нет Объект не найден
   NIGHTHUNTER
 
34 - 13.08.21 - 05:29
(33) Это первоначальное состояние базы.

Сейчас ТиИ ещё выполняется. Я работаю в копии, которая такая же. Смотрю сейчас как будет вести себя поиск. Но работает он очень криво.
так что нет смысла что то выполнять и отлаживать в такой базе. По этому запустил ТиИ, сначала для информации. Но получается работает она очень долго.

(33) Вопрос, как потом запускать ТиИ? Создавать ссылки или Удалять? И я так понимаю что в логе ТиИ, должна быть информация, о том что есть битые ссылки по контрагентам?
   NIGHTHUNTER
 
35 - 13.08.21 - 07:04
Ситуация продолжается.
Если я не ставил галки, удалять ссылки, создавать. То все получается так же осталось.
При выводе контрагентов для сравнения. что я делал, что бы выявить эту причину они есть.
Потом в другой процедуре они просто не находятся.
Что это, я не знаю.
Подскажите какие могут быть причины?
   NIGHTHUNTER
 
36 - 13.08.21 - 07:07
В логе ТиИ нет явного описания на контрагентов и партнеров, что что то с ними не так.
Есть описание только по ссылкам, на регистры сведений и другие справочники.

Что тут можно делать? В коде контрагенты продолжают не находиться (.
   NIGHTHUNTER
 
37 - 13.08.21 - 07:09
Если по ссылке не находится, можно найти по коду. Но как ещё можно попробовать поиск. что бы сработал он?

&НаСервере
Функция КонтрагентПоПартнеру(ВыбПартнер)
    Если Не ЗначениеЗаполнено(ВыбПартнер) Тогда
        Возврат 0;    
    КонецЕсли;
    Запрос       = Новый Запрос;
    Запрос.Текст = "
        |ВЫБРАТЬ
        |    Контрагенты.Ссылка  КАК Ссылка,
        |    Контрагенты.Партнер КАК Партнер
        |ИЗ
        |    Справочник.Контрагенты КАК Контрагенты
        |ГДЕ
        |    Контрагенты.Партнер = &ВыбПартнер";
    Запрос.УстановитьПараметр("ВыбПартнер", ВыбПартнер);
    Рез = Запрос.Выполнить();
    Если Не Рез.Пустой() Тогда
        Выборка = Рез.Выбрать();
        Выборка.Следующий();
        Возврат Выборка.Ссылка;
    КонецЕсли;
Возврат 0;    
КонецФункции
   NIGHTHUNTER
 
38 - 13.08.21 - 08:51
не находится так же, что с базой не понятно


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.