Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ТСД на мобильной платформе

ТСД на мобильной платформе
Я
   abbas
 
12.08.21 - 10:08
Доброе времени суток.
Написал маленькую конфигурацию под моб приложение и в будущем дорабатывать.
Приобрели ТДС Зебра TC26BK, пытаюсь получить событие при считывания сканером штрихкод.
В интернете есть пару статей на инфорстарте, но у меня нет стартами.
Подскажите пжста, кто сталкивался, куда копать?
   abbas
 
1 - 12.08.21 - 10:11
Мож есть у кого компонента...
   Smit1C
 
2 - 12.08.21 - 10:13
Изучай: Библиотека подключаемого оборудования для мобильных приложений
там всё есть
   Kassern
 
3 - 12.08.21 - 10:15
(2) +1 я на ее базе и делал свою конфу для мобилки, чтобы считывал ТСД корректно.
   abbas
 
4 - 12.08.21 - 10:40
Тип оборудования: Устройство ввода
Перепробовал все драйвера, но безрезультатно
   abbas
 
5 - 12.08.21 - 10:41
(3) может есть пример для продвижения моего затора
   Kassern
 
6 - 12.08.21 - 10:41
(4) просто разверните демку БПО мобильной и потестите на ТСД. Если все работает, то лезете в конфигурацию и выдергиваете нужные функции
   DGorgoN
 
7 - 12.08.21 - 10:43
Если совсем встанешь в позу то на ТСД есть утилита, которая эмулирует клавиатуру. В этом случае достаточно просто всегда держать фокус на текстовом поле с ШК.
Второй вариант БПО требует именно такой режим. Попробуй поиграться.
   Kassern
 
8 - 12.08.21 - 10:48
(7) ну это даж не интересно да и драйвер для этого не нужен, на тсд итак можно в данный режим перевести и еще чтоб энтер нажимал при сканировании.
   abbas
 
9 - 12.08.21 - 10:49
(6) Так и сделал, не работает
   Kassern
 
10 - 12.08.21 - 10:52
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ОписаниеОшибки = "";
    Если НЕ МенеджерОборудованияКлиент.ПодключитьОборудованиеПоИдентификатору(УникальныйИдентификатор, ОборудованиеУстройствоВвода, ОписаниеОшибки) Тогда
        Сообщить(ОписаниеОшибки);
    КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ПередЗакрытием(Отказ, ЗавершениеРаботы, ТекстПредупреждения, СтандартнаяОбработка)
    МенеджерОборудованияКлиент.ОтключитьВсеОборудование();
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
    Если ИмяСобытия = "Штрихкод" Или ИмяСобытия = "Barcode" Тогда
        ОбработатьШтрихкод(Параметр);
    Иначе
        Сообщить("Данные:" + Параметр);
    КонецЕсли;
КонецПроцедуры
   Kassern
 
11 - 12.08.21 - 10:53
(10) только надо получить ОборудованиеУстройствоВвода из Справочники.ПодключаемоеОборудование, может из константы какой нить.
   Kassern
 
12 - 12.08.21 - 10:53
(10) и да, надеюсь вы понимаете что данные процедуры должны быть привязаны к форме)
   DGorgoN
 
13 - 12.08.21 - 11:03
(9) Попробуй врубить режим эмуляции клавиатуры на ТСД и БПО одновременно?
   DGorgoN
 
14 - 12.08.21 - 11:03
(10) Вполне возможно что платформа сама требует эмуляции клавиатуры для этого!
   abbas
 
15 - 12.08.21 - 11:17
Может необходимо на самом ТСД проделать настройки?
   Kassern
 
16 - 12.08.21 - 11:19
(15) все может быть, может у вас вообще приложение для сканера не запущено на нем) Так же вам надо подключаемое оборудование заполнить в 1с, вы это сделали?
   Галахад
 
17 - 12.08.21 - 11:31
Интересная тема. Подпишусь.
   abbas
 
18 - 12.08.21 - 11:31
(16) создал все возможные оборудования, все выдали ошибку при установки драйвера, кроме одного "Устройство ввода"
   Kassern
 
19 - 12.08.21 - 11:37
(18) драйвер какой указали у устройства ввода?
   Kassern
 
20 - 12.08.21 - 11:38
(18) не надо все возможные, нужен Устройство ввода, с драйвером для сканера. А далее это устройство ввода получать для ОборудованиеУстройствоВвода  в фукнции ПодключитьОборудованиеПоИдентификатору
   RomakON
 
21 - 12.08.21 - 11:39
Когда делал мобильное приложение для ТСД Urovo запрашивал у производителя компоненты для сканера и ручной клавиатуры. Прислали демо-конфигурацию на 1С, из которой я выдернул нужные файлы. После этого файлы запихнул в общие макеты и прописал инициализацию при старте мобильного приложения
   abbas
 
22 - 12.08.21 - 11:40
(21) ТСД Urovo есть в списке подключаемого оборудования в БСП
   Kassern
 
23 - 12.08.21 - 11:51
(22) у меня на ТСД след настройка подключаемого оборудования:
тип Устройство ввода
Драйвер 1с Сканер штрихкода (NativeApi)
//
Настройка:
Устройство: Клавиатура
Тип выходных данных: Строка
Символ GS: NONE
версия драйвера 9.0.8.10
   RomakON
 
24 - 12.08.21 - 11:53
(22) При разработке мобильного приложения не использовал БСП, не знаю
   abbas
 
25 - 12.08.21 - 11:56
(23) У меня даже драйвер не установился
   Kassern
 
26 - 12.08.21 - 11:56
(25) значит что то вы делаете не так...
   abbas
 
27 - 12.08.21 - 11:58
Установил платформу, загрузил конф, опубликовал, закгрузил в ТСД, открыл и начал настраивать
   ejikbeznojek
 
28 - 12.08.21 - 12:00
У меня есть самописная конфа под Urovo могу скинуть, если скажешь куда.
   Галахад
 
29 - 12.08.21 - 12:16
(28) Если не трудно, мне тоже.
   ejikbeznojek
 
30 - 12.08.21 - 12:55
(29) Отправил. Конфа конечно - любительская. Но может пригодится.
 
 
   Галахад
 
31 - 12.08.21 - 13:45
(30) Получил. Спасибо!

Думаю что скоро придется осваивать подключение железячного сканера к мобильному устройству.
   abbas
 
32 - 12.08.21 - 14:14
(28) ugr_88@mail.ru
   abbas
 
33 - 12.08.21 - 14:16
Терминалы Zebra, нужно запустить приложение "DataWedge" (оно должно быть предустановлено на ТСД Zebra), затем "Profile0", затем поставить галку на "Intent output", в поле "Intent action" ввести com.dwexample.action, очистить поле "Intent category", а в "Intent delivery" выбрать "Broadcast intent". В параметрах Комбайна, выбрать способ сканирования "По событию", в поле "Имя события" ввести com.dwexample.action и в поле "Имя поля штрих-кода" ввести datawedge_intent_key_data
   abbas
 
34 - 12.08.21 - 14:21
(33) Это тоже не работает
   abbas
 
35 - 12.08.21 - 16:44
(28) Ругается на "установка внешней компоненты не выполнена"
   ejikbeznojek
 
36 - 12.08.21 - 17:38
(35)можешь ещё попробовать сканер подключать из другой компоненты.
Там где-то, где клавиатура подключается аппаратная, закомментированы строчки про сканер.
   abbas
 
37 - 12.08.21 - 18:17
(36) Да он вообще не хочет регистрировать компоненты
платформа 8_3_19_51
Загрузил на ТСД 1cem-arm.apk
   ejikbeznojek
 
38 - 12.08.21 - 18:44
Может быть каких-то разрешений не хватает?
И их выдать вручную?
   ejikbeznojek
 
39 - 12.08.21 - 18:45
Я эту конфигурацию разворачивал на  8.3.15.86


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.