Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Выбор формы в зависимости от версии клиента 1С

Выбор формы в зависимости от версии клиента 1С
Я
   Юзер123
 
11.08.21 - 16:42
Доброго времени.

Сделал форму списка документов.
Подскажите как ее открывать вместо основной если пользователь с Вэб клиента заходит.
   lubitelxml
 
1 - 11.08.21 - 16:45
#ЕСЛИ ВебКлиент ТОГДА
   Юзер123
 
2 - 11.08.21 - 16:57
(1) это я знаю)
Вопрос в том, где это вызывать надо?
   Юзер123
 
3 - 11.08.21 - 16:57
(2) в какой момент определяется какую форму открывать
   Вафель
 
4 - 11.08.21 - 16:58
если это бсп, то есть параметры клиента на сервере
   Юзер123
 
5 - 11.08.21 - 17:00
(4) ЭТо УНФ
   lubitelxml
 
6 - 11.08.21 - 17:36
В модуле менеджера документа есть процедура 
Процедура ОбработкаПолученияФормы(ВидФормы, Параметры, ВыбраннаяФорма, ДополнительнаяИнформация, СтандартнаяОбработка)
    Если ВидФормы = "ФормаСписка" Тогда
        ВыбраннаяФорма       = "ТвоеИмяНовойФормы";
        СтандартнаяОбработка = Ложь;
    КонецЕсли;
КонецПроцедуры
   Юзер123
 
7 - 12.08.21 - 16:06
(6)  да. вижу. Но почему то не реагирует на #ЕСЛИ ВебКлиент ТОГДА
   ДенисЧ
 
8 - 12.08.21 - 16:12
(7) Потому что эта процедура работает на сервере )))
   Юзер123
 
9 - 12.08.21 - 16:14
(8) какая эта?.
Процедура ОбработкаПолученияФормы( я в нее отладчиком захожу. все ок.
Отладка на сервере включена. Не проверяется 

#ЕСЛИ ВебКлиент ТОГДА
   Guk
 
10 - 12.08.21 - 16:16
(9) конечно ты в неё заходишь, только серверу до фонаря, кто такой ВебКлиент...
   Юзер123
 
11 - 12.08.21 - 16:18
(10) как сделать то?)
   Жан Пердежон
 
12 - 12.08.21 - 16:19
(11) покопайся в параметрах сеанса, авось найдешь что-нибудь для себя полезное
   Guk
 
13 - 12.08.21 - 16:20
(11) как вариант в ПриОткрытии основной формы проверять на ВебКлиент и если он, то открывать нужную форму, а основную не открывать...
   Гипервизор
 
14 - 12.08.21 - 16:30
А если попробовать выкрутиться через ПредставлениеПриложения().
   Гипервизор
 
15 - 12.08.21 - 16:31
   Guk
 
16 - 12.08.21 - 21:47
+(13) в основной форме
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    #Если ВебКлиент Тогда

                ПараметрыФормы = Новый Структура;
                //заполняешь параметры для открываемой формы, если надо

        ОткрытьФорму("Документ.МойДокумент.Форма.ФормаСпискаДляВебКлиента", ПараметрыФормы);
                Отказ = Истина;
    #КонецЕсли

КонецПроцедуры
   Вафель
 
17 - 12.08.21 - 22:17
А разве унф не на бсп?
   SilentMan
 
18 - 13.08.21 - 09:37
(11) я бы попробовал так: при старте клиента определять, что за клиент используется и клал эту инфу в параметр сеанса. В обработчике выбора формы смотрел в параметр сеанса и принимал решение, какую форму открывать

Список тем форума
 
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.