Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Установить цену произвольная при изменении цены ПодборТоваровВДокументПродажи

Установить цену произвольная при изменении цены ПодборТоваровВДокументПродажи
Я
   seregapplk
 
11.08.21 - 15:56
собственно в форме сделано
как сделать в подборе

код в форме
   Жан Пердежон
 
1 - 11.08.21 - 16:00
позвать программиста, он что-нибудь придумает
   seregapplk
 
2 - 11.08.21 - 16:00
ИначеЕсли Поле = Элементы.ТоварыЦена Тогда
        
        ТекущиеДанные = Элементы.Товары.ТекущиеДанные;
        //  +++++++++++

         Элементы.Товары.ТекущиеДанные.ВидЦены = Неопределено;  
        //----------- 

        Если ПравоНаЧтениеВидаЦены Тогда
            Если ЗначениеЗаполнено(ТекущиеДанные.ВидЦены) И НЕ Объект.Согласован Тогда
                ОчиститьСообщения();
                ОбщегоНазначенияКлиентСервер.СообщитьПользователю(
                    НСтр("ru='Для редактирования цены выберите вид цены ""<произвольная>""';uk='Для редагування ціни виберіть вид ціни ""<довільна>""'"),
                    Объект.Ссылка,
                    ОбщегоНазначенияКлиентСервер.ПутьКТабличнойЧасти("Объект.Товары", ТекущиеДанные.НомерСтроки, "ВидЦены"),);
                        
            КонецЕсли;
        КонецЕсли;
           
    ИначеЕсли НаборыКлиент.БлокируемыйЭлемент(Поле) Тогда
        
        ТекущаяСтрока = Объект.Товары.НайтиПоИдентификатору(ВыбраннаяСтрока);                                            
        Если ЗначениеЗаполнено(ТекущаяСтрока.НоменклатураНабора) И ТекущаяСтрока.КодСтроки = 0 Тогда
            
            ПараметрОповещения = Новый Структура;
            ПараметрОповещения.Вставить("НоменклатураНабора",   ТекущаяСтрока.НоменклатураНабора);
            ПараметрОповещения.Вставить("ХарактеристикаНабора", ТекущаяСтрока.ХарактеристикаНабора);
            ПараметрОповещения.Вставить("ФормаВладелец",        УникальныйИдентификатор);
            ПараметрОповещения.Вставить("СверхЗаказа",          Истина);
            
            Оповестить("РедактироватьНабор", ПараметрОповещения, ЭтаФорма);
            
        КонецЕсли;
        
    ИначеЕсли Поле = Элементы.ТоварыНоменклатураНабора Тогда
        
        ОткрытьЗначение(Элементы.Товары.ТекущиеДанные.НоменклатураНабора);
        
    КонецЕсли;
    
КонецПроцедуры
   seregapplk
 
3 - 11.08.21 - 16:00
(1) не оригинально)
   seregapplk
 
4 - 12.08.21 - 14:49
Нужно в конфигураторе, обработка подбор товаров в документ продажи,
В форме запрос количества 
В модуле формы, в процедуре при создании на сервере.
Закоментировать // перед строкой)              строки                                                                                                                                   //Элементы.Цена.ТолькоПросмотр = ЗначениеЗаполнено(ВидЦены);

  //Элементы.Цена.ПропускатьПриВводе = ЗначениеЗаполнено(ВидЦены);


И создать                                                                                                                                                                                                                                                         &НаКлиенте
Процедура ЦенаПриИзменении(Элемент)
  

  ВидЦены = Неопределено;
  
КонецПроцедуры
 В форме по поле ввода "цена"

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.