Вход | Регистрация
 

Варианты отчета на обычных формах

Варианты отчета на обычных формах
Я
   НоваяВолна
 
11.08.21 - 08:07
Управление производственным предприятием, редакция 1.2 + CRM ПРОФ, редакция 1.2 (1.2.11/1.2.1) (1.2.11.1)

Дорабатываю отчет на обычных формах. Создал свой вариант отчета, но не могу вспомнить как вывести выбор вариантов в пользовательском режиме. В отчете есть только СхемаКомпановкиДанных, Формы нет. При открытии форма выводится стандартная с кнопками "Действия", "Сформировать", "Конструктор настроек" и "Настройки" + кнопки "Восстановить/Сохранить значения". Нигде не вижу вариантов отчетов.
Подскажите как вывести выбор варианта отчета?
   ДенисЧ
 
1 - 11.08.21 - 08:09
Свою форму рисовать, насколько я помню. И в ней уже делать выбор.
   НоваяВолна
 
2 - 11.08.21 - 08:10
(1) Если свою форму ,то как обратится к Настройкам и Вариантам отчетов?
   ДенисЧ
 
3 - 11.08.21 - 08:12
(2) А что, ты в форме к схеме компоновки не можешь обратиться? Тебе запрещено под страхом расстрела?
Подсказываю - все настройки и варианты есть в схеме. И прекрасно читаются программно. И даже в встроенной справке описаны, как это странно не звучит...
   НоваяВолна
 
4 - 11.08.21 - 08:23
(3) при создании новой формы на нее по умолчанию вывелись те же кнопки, что и без создания
   ДенисЧ
 
5 - 11.08.21 - 08:24
(4) Могу подсказать, как их убрать. И добавить свои.
Но это будет дорого стоить...
   НоваяВолна
 
6 - 11.08.21 - 08:31
В ИТС сказано ,что выбор вариантов отчетов должен быть в меню Действия, но даже при создании формы вручную там такого нет
https://its.1c.ru/db/pubessence/content/64/hdoc/h60
   НоваяВолна
 
7 - 11.08.21 - 08:32
(6) + да и кнопки Все действия нет, есть кнопка Действия, с ограниченным набором функций
   ДенисЧ
 
8 - 11.08.21 - 08:35
(6) Картинка на скрине с выбором настроек
https://its.1c.ru/db/content/pubessence/src/141.png?_=1623788197
вообще ни о чём не говорит? Даже о том, что это управляемая форма, например?
   banco
 
9 - 11.08.21 - 08:44
(0) Видимо для обычных форм отчета не предусмотрели кнопки выбора варианта. А зачем вообще делать на обычных формах?
   ДенисЧ
 
10 - 11.08.21 - 08:45
(9) Ты не поверишь, но в РФ ещё очень много конфигураций на обычных формах.
Не всем нужны свистоплясалки в такси.
   НоваяВолна
 
11 - 11.08.21 - 09:01
(9) нашел решение, все работает:

Процедура _СменаВариантаНастройки (Элемент)
    
    Для каждого Настройка Из СхемаКомпоновкиДанных.ВариантыНастроек Цикл
        
        Если Элемент.Текст = Настройка.Представление тогда
            
            КомпоновщикНастроек.ЗагрузитьНастройки(Настройка.Настройки);
            
            Прервать;
            
        КонецЕсли;
        
    КонецЦикла;
    
КонецПроцедуры

Процедура УстановитьВариантыНастроек()
    
    КП = ЭлементыФормы.ДействияФормы; 
    
    НоваяКнопка = КП.Кнопки.Вставить(1,"_ВариантыОтчетов", ТипКнопкиКоманднойПанели.Подменю, "Варианты отчетов", ); НовоеДействие = Новый Действие("_СменаВариантаНастройки"); ч = 1;
    
    Для каждого Настройка Из СхемаКомпоновкиДанных.ВариантыНастроек Цикл
        
        НоваяКнопка = КП.Кнопки._ВариантыОтчетов.Кнопки.Добавить("Вариант"+Строка(ч), ТипКнопкиКоманднойПанели.Действие, Настройка.Представление, НовоеДействие); ч = ч + 1;
        
    КонецЦикла;
    
КонецПроцедуры

Процедура ПриОткрытии()
    УстановитьВариантыНастроек();
КонецПроцедуры
   ДенисЧ
 
12 - 11.08.21 - 09:03
Опять я без заработка остался (((
   banco
 
13 - 11.08.21 - 09:11
(10) Я не предлагал перейти на такси. На толстом клиенте нормально открываются управляемые формы.
   ДенисЧ
 
14 - 11.08.21 - 09:13
(13) Во внешних отчётах?
   banco
 
15 - 11.08.21 - 09:15
(14) А где в (0) написано про внешний отчет?
   НоваяВолна
 
16 - 11.08.21 - 09:26
(15) Отчет пока на самом деле внешний, но не суть, потом будет в конфигурации
   НоваяВолна
 
17 - 11.08.21 - 09:26
(12) Что такое не везет и как с этим бороться....

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.