Вход | Регистрация
 

Не работает ЦветаСтиля в УФ, на что заменить?

Не работает ЦветаСтиля в УФ, на что заменить?
Я
   Хосе
 
10.08.21 - 12:39
В ОФ например так: ЦветаСтиля.ЦветФонаПоля
   Хосе
 
1 - 10.08.21 - 12:41
Как-то надо подобрать цвета, пока сделал затычку:

Функция ЦветаСтиля(Цвет) Экспорт
    //!!! Временно

    Если Цвет = "ЦветФонаПоля" Тогда
        Возврат WebЦвета.Бирюзовый;
    ИначеЕсли Цвет = "ТекстИнформационнойНадписи" Тогда
        Возврат WebЦвета.Бирюзовый;
    ИначеЕсли Цвет = "ЦветФонаПоля" Тогда
        Возврат WebЦвета.Бирюзовый;
    ИначеЕсли Цвет = "ЦветФонаФормы" Тогда
        Возврат WebЦвета.Бирюзовый;
    Иначе
        Возврат WebЦвета.Бирюзовый;
    КонецЕсли;
КонецФункции
   Fragster
 
2 - 10.08.21 - 12:42
Насоздавай элементов стиля с твоими названиями
   Хосе
 
3 - 10.08.21 - 13:13
(2) а можно как-то получить цвета из ОФ? не охота вручную сопоставлять, хотя их и 4
   Хосе
 
4 - 10.08.21 - 13:53
Пардон, в УФ тоже доступно, но только на сервере.
&НаСервереБезКонтекста
Функция ЦветаСтиля(Цвет) Экспорт
    //!!! Временно

    Возврат ЦветаСтиля[Цвет]; 
    //Если Цвет = "ЦветФонаПоля" Тогда

    //    Возврат WebЦвета.Бирюзовый;

    //ИначеЕсли Цвет = "ТекстИнформационнойНадписи" Тогда

    //    Возврат WebЦвета.Бирюзовый;

    //ИначеЕсли Цвет = "ЦветФонаФормы" Тогда

    //    Возврат WebЦвета.Бирюзовый;

    //Иначе

    //    Возврат WebЦвета.Бирюзовый;

    //КонецЕсли;

КонецФункции

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.