Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Непонятно в запросе

Непонятно в запросе
Я
   Масянька
 
06.08.21 - 14:44
День добрый!
Из типовой УПП в нашу переношу.
Наша: 1С:Предприятие 8.2 (8.2.19.106), 8.1.0.17.
Запрос:
Функция ТекстЗапросаПрослеживаемыеТовары(НомераТаблиц, ПараметрыПроведения, Реквизиты) Экспорт
    
    Если (Не Реквизиты.ЕстьТовары ИЛИ Не Реквизиты.ВедетсяУчетПрослеживаемыхТоваров) Тогда
        ПараметрыПроведения.Вставить("ВТ_ПрослеживаемостьПредварительная", Неопределено);
        ПараметрыПроведения.Вставить("ВТ_Прослеживаемость",                Неопределено);
        ПараметрыПроведения.Вставить("ВТ_СуммыБезНДСПредварительная",      Неопределено);
        ПараметрыПроведения.Вставить("ВТ_СуммыБезНДС",                     Неопределено);
        ПараметрыПроведения.Вставить("ПрослеживаемыеОперации",             Неопределено);
        ПараметрыПроведения.Вставить("ПрослеживаемыеТовары",               Неопределено);
        ПараметрыПроведения.Вставить("РНПТ",                               Неопределено);
        Возврат "";
    КонецЕсли;
    
    НомераТаблиц.Вставить("ВТ_ПрослеживаемостьПредварительная", НомераТаблиц.Количество());
    НомераТаблиц.Вставить("ВТ_Прослеживаемость",                НомераТаблиц.Количество());
    НомераТаблиц.Вставить("ВТ_СуммыБезНДСПредварительная",      НомераТаблиц.Количество());
    НомераТаблиц.Вставить("ВТ_СуммыБезНДС",                     НомераТаблиц.Количество());
    НомераТаблиц.Вставить("ПрослеживаемыеОперации",             НомераТаблиц.Количество());
    НомераТаблиц.Вставить("ПрослеживаемыеТовары",               НомераТаблиц.Количество());
    НомераТаблиц.Вставить("РНПТ",                               НомераТаблиц.Количество());
    
    // Шаблон запроса для сбора временной таблицы ВТ_ПрослеживаемостьПредварительная
    ТекстЗапроса = "ВЫБРАТЬ
    |    НЕОПРЕДЕЛЕНО КАК Номенклатура,
    |    0 КАК Количество,
    |    НЕОПРЕДЕЛЕНО КАК СтранаПроисхождения,
    |    НЕОПРЕДЕЛЕНО КАК РНПТ,
    |    0 КАК КоличествоПрослеживаемости,
    |    НЕОПРЕДЕЛЕНО КАК ОтражениеВОтчетности,
    |    НЕОПРЕДЕЛЕНО КАК КодОперации,
    |    НЕОПРЕДЕЛЕНО КАК ДокументОперации,
    |    НЕОПРЕДЕЛЕНО КАК Контрагент,
    |    НЕОПРЕДЕЛЕНО КАК ПериодОперации,
    |    НЕОПРЕДЕЛЕНО КАК НомерДокумента,
    |    НЕОПРЕДЕЛЕНО КАК ДатаДокумента,
    |    НЕОПРЕДЕЛЕНО КАК ТипДокументаВПрослеживаемости,
    |    НЕОПРЕДЕЛЕНО КАК Комитент,
    |    НЕОПРЕДЕЛЕНО КАК ВидЗапасов,
    |    НЕОПРЕДЕЛЕНО КАК ЭтоЗакупкаДляКомитента
    |ПОМЕСТИТЬ ВТ_ПрослеживаемостьПредварительная";
    
    Если Реквизиты.ЕстьТовары Тогда
        ТекстЗапроса = ТекстЗапроса + Символы.ПС + Символы.ПС + "ОБЪЕДИНИТЬ ВСЕ" + Символы.ПС + Символы.ПС;
        ТекстЗапроса = ТекстЗапроса + "ВЫБРАТЬ
        |    ПоступлениеТоваровУслугТовары.Номенклатура КАК Номенклатура,
        |    ЕСТЬNULL(ПоступлениеТоваровУслугСведенияПрослеживаемости.Количество, ПоступлениеТоваровУслугТовары.Количество) КАК Количество,
        |    ПоступлениеТоваровУслугТовары.СтранаПроисхождения КАК СтранаПроисхождения,
        |    ПоступлениеТоваровУслугСведенияПрослеживаемости.РНПТ КАК РНПТ,
        |    ПоступлениеТоваровУслугСведенияПрослеживаемости.КоличествоПрослеживаемости КАК КоличествоПрослеживаемости,
        |    ВЫБОР
        |        КОГДА &ПрослеживаемыеОперацииОтображаютсяВДекларацииНДС
        |                И НЕ &БезвозмездноеПоступление
        |            ТОГДА ВЫБОР
        |                    КОГДА ПоступлениеТоваровУслугТовары.СчетУчетаБУ.Забалансовый
        |                        ТОГДА ЗНАЧЕНИЕ(Перечисление.ПорядокОтраженияВОтчетностиПоПрослеживаемости.ЖурналСФ)
        |                    ИНАЧЕ ЗНАЧЕНИЕ(Перечисление.ПорядокОтраженияВОтчетностиПоПрослеживаемости.КнигаПокупок)
        |                КОНЕЦ
        |        ИНАЧЕ ВЫБОР
        |                КОГДА &ЕстьНДС
        |                        И ПоступлениеТоваровУслугТовары.СчетУчетаБУ.Забалансовый
        |                    ТОГДА ЗНАЧЕНИЕ(Перечисление.ПорядокОтраженияВОтчетностиПоПрослеживаемости.ЖурналСФ)
        |                ИНАЧЕ ЗНАЧЕНИЕ(Перечисление.ПорядокОтраженияВОтчетностиПоПрослеживаемости.ОтчетОбОперациях)
        |            КОНЕЦ
        |    КОНЕЦ КАК ОтражениеВОтчетности,
        |    ВЫБОР
        |        КОГДА &БезвозмездноеПоступление
        |            ТОГДА ЗНАЧЕНИЕ(Справочник.КодыОперацийПрослеживаемости.БезвозмездноеПолучение)
        |        КОГДА &ПрослеживаемыеОперацииОтображаютсяВДекларацииНДС
        |                ИЛИ &ЕстьНДС
        |                    И ПоступлениеТоваровУслугТовары.СчетУчетаБУ.Забалансовый
        |            ТОГДА ЗНАЧЕНИЕ(Справочник.КодыОперацийПрослеживаемости.ПустаяСсылка)
        |        КОГДА ПоступлениеТоваровУслугТовары.СчетУчетаБУ.Забалансовый
        |            ТОГДА ЗНАЧЕНИЕ(Справочник.КодыОперацийПрослеживаемости.ПриобретениеТовараДляКомитента)
        |        КОГДА &ПлательщикНДС
        |            ТОГДА ЗНАЧЕНИЕ(Справочник.КодыОперацийПрослеживаемости.ПриобретениеПлательщикомНДС)
        |        ИНАЧЕ ЗНАЧЕНИЕ(Справочник.КодыОперацийПрослеживаемости.ПриобретениеНеплательщикомНДС)
        |    КОНЕЦ КАК КодОперации,
        |    ПоступлениеТоваровУслугТовары.Ссылка КАК ДокументОперации,
        |    ПоступлениеТоваровУслугТовары.Ссылка.Контрагент КАК Контрагент,
        |    НАЧАЛОПЕРИОДА(ПоступлениеТоваровУслугТовары.Ссылка.Дата, КВАРТАЛ) КАК ПериодОперации,
        |    ЕСТЬNULL(ПоступлениеТоваровУслугТовары.Ссылка.Номер, """") КАК НомерДокумента,
        |    ЕСТЬNULL(ПоступлениеТоваровУслугТовары.Ссылка.Дата, ДАТАВРЕМЯ(1, 1, 1)) КАК ДатаДокумента,
        |    ВЫБОР
        |        КОГДА НЕ &ПрослеживаемыеОперацииОтображаютсяВДекларацииНДС
        |                ИЛИ &БезвозмездноеПоступление
        |            ТОГДА ВЫБОР
        |                    КОГДА ПоступлениеТоваровУслугТовары.Ссылка.ЭтоУниверсальныйДокумент
        |                        ТОГДА ЗНАЧЕНИЕ(Справочник.ТипыДокументов.УПД)
        |                    ИНАЧЕ ЗНАЧЕНИЕ(Справочник.ТипыДокументов.Накладная)
        |                КОНЕЦ
        |        ИНАЧЕ НЕОПРЕДЕЛЕНО
        |    КОНЕЦ КАК ТипДокументаВПрослеживаемости,
        |    ВЫБОР
        |        КОГДА &ЭтоКомиссия
        |            ТОГДА ПоступлениеТоваровУслугТовары.Ссылка.Контрагент
        |        ИНАЧЕ ЗНАЧЕНИЕ(Справочник.Контрагенты.ПустаяСсылка)
        |    КОНЕЦ КАК Комитент,
        |    ВЫБОР
        |        КОГДА &ЭтоКомиссия
        |            ТОГДА ЗНАЧЕНИЕ(Перечисление.ВидыЗапасовПрослеживаемыхТоваров.ТоварыОтКомитентаНаРеализацию)
        |        ИНАЧЕ НЕОПРЕДЕЛЕНО
        |    КОНЕЦ КАК ВидЗапасов,
        |    ПоступлениеТоваровУслугТовары.СчетУчетаБУ.Забалансовый КАК ЭтоЗакупкаДляКомитента
        |ИЗ
        |    Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслугТовары
        |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПоступлениеТоваровУслуг.СведенияПрослеживаемости КАК ПоступлениеТоваровУслугСведенияПрослеживаемости
        |        ПО ПоступлениеТоваровУслугТовары.Ссылка = ПоступлениеТоваровУслугСведенияПрослеживаемости.Ссылка
        |            И ПоступлениеТоваровУслугТовары.ИдентификаторСтроки = ПоступлениеТоваровУслугСведенияПрослеживаемости.ИдентификаторСтроки
        |ГДЕ
        |    ПоступлениеТоваровУслугТовары.ПрослеживаемыйТовар
        |    И ПоступлениеТоваровУслугТовары.Ссылка = &Ссылка";
    КонецЕсли;

    ТекстЗапроса = ТекстЗапроса + ПрослеживаемостьБП.ТекстРазделителяЗапросовПакета();
    ТекстЗапроса = ТекстЗапроса + "ВЫБРАТЬ
    |    ВТ_ПрослеживаемостьПредварительная.Номенклатура КАК Номенклатура,
    |    СУММА(ВТ_ПрослеживаемостьПредварительная.Количество) КАК Количество,
    |    ВТ_ПрослеживаемостьПредварительная.СтранаПроисхождения КАК СтранаПроисхождения,
    |    ВТ_ПрослеживаемостьПредварительная.РНПТ КАК РНПТ,
    |    СУММА(ВТ_ПрослеживаемостьПредварительная.КоличествоПрослеживаемости) КАК КоличествоПрослеживаемости,
    |    ВТ_ПрослеживаемостьПредварительная.ОтражениеВОтчетности КАК ОтражениеВОтчетности,
    |    ВТ_ПрослеживаемостьПредварительная.КодОперации КАК КодОперации,
    |    ВТ_ПрослеживаемостьПредварительная.ДокументОперации КАК ДокументОперации,
    |    ВТ_ПрослеживаемостьПредварительная.Контрагент КАК Контрагент,
    |    ВТ_ПрослеживаемостьПредварительная.ПериодОперации КАК ПериодОперации,
    |    ВТ_ПрослеживаемостьПредварительная.НомерДокумента КАК НомерДокумента,
    |    ВТ_ПрослеживаемостьПредварительная.ДатаДокумента КАК ДатаДокумента,
    |    ВТ_ПрослеживаемостьПредварительная.ТипДокументаВПрослеживаемости КАК ТипДокументаВПрослеживаемости,
    |    ВТ_ПрослеживаемостьПредварительная.Комитент КАК Комитент,
    |    ВТ_ПрослеживаемостьПредварительная.ВидЗапасов КАК ВидЗапасов,
    |    ВТ_ПрослеживаемостьПредварительная.ЭтоЗакупкаДляКомитента КАК ЭтоЗакупкаДляКомитента
    |ПОМЕСТИТЬ ВТ_Прослеживаемость
    |ИЗ
    |    ВТ_ПрослеживаемостьПредварительная КАК ВТ_ПрослеживаемостьПредварительная
    |ГДЕ
    |    ВТ_ПрослеживаемостьПредварительная.Номенклатура <> НЕОПРЕДЕЛЕНО
    |
    |СГРУППИРОВАТЬ ПО
    |    ВТ_ПрослеживаемостьПредварительная.ДокументОперации,
    |    ВТ_ПрослеживаемостьПредварительная.КодОперации,
    |    ВТ_ПрослеживаемостьПредварительная.ТипДокументаВПрослеживаемости,
    |    ВТ_ПрослеживаемостьПредварительная.РНПТ,
    |    ВТ_ПрослеживаемостьПредварительная.СтранаПроисхождения,
    |    ВТ_ПрослеживаемостьПредварительная.Номенклатура,
    |    ВТ_ПрослеживаемостьПредварительная.НомерДокумента,
    |    ВТ_ПрослеживаемостьПредварительная.ДатаДокумента,
    |    ВТ_ПрослеживаемостьПредварительная.ОтражениеВОтчетности,
    |    ВТ_ПрослеживаемостьПредварительная.ПериодОперации,
    |    ВТ_ПрослеживаемостьПредварительная.Контрагент,
    |    ВТ_ПрослеживаемостьПредварительная.Комитент,
    |    ВТ_ПрослеживаемостьПредварительная.ВидЗапасов,
    |    ВТ_ПрослеживаемостьПредварительная.ЭтоЗакупкаДляКомитента";
    
    // Шаблон запроса для сбора временной таблицы ВТ_СуммыБезНДСПредварительная.
    // Суммы без НДС необходимы для отчета об операциях и для регистрации
    // прослеживаемого товара к получению РНПТ при импорте из ЕАЭС.
    ТекстЗапроса = ТекстЗапроса + ПрослеживаемостьБП.ТекстРазделителяЗапросовПакета();
    ТекстЗапроса = ТекстЗапроса + "ВЫБРАТЬ
    |    Неопределено КАК Номенклатура,
    |    0 КАК СуммаБезНДС,
    |    Неопределено КАК ЭтоЗакупкаДляКомитента
    |ПОМЕСТИТЬ ВТ_СуммыБезНДСПредварительная";
    
    Если Реквизиты.ЕстьТовары Тогда
        ТекстЗапроса = ТекстЗапроса + Символы.ПС + Символы.ПС + "ОБЪЕДИНИТЬ ВСЕ" + Символы.ПС + Символы.ПС;
        ТекстЗапроса = ТекстЗапроса + "ВЫБРАТЬ
        |    ПоступлениеТоваровУслугТовары.Номенклатура КАК Номенклатура,
        |    ВЫБОР
        |        КОГДА ПоступлениеТоваровУслугТовары.Ссылка.СуммаВключаетНДС
        |            ТОГДА ПоступлениеТоваровУслугТовары.Сумма - ПоступлениеТоваровУслугТовары.СуммаНДС
        |        ИНАЧЕ ПоступлениеТоваровУслугТовары.Сумма
        |    КОНЕЦ КАК СуммаБезНДС,
        |    ПоступлениеТоваровУслугТовары.СчетУчетаБУ.Забалансовый КАК ЭтоЗакупкаДляКомитента
        |ИЗ
        |    Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслугТовары
        |ГДЕ
        |    ПоступлениеТоваровУслугТовары.Ссылка = &Ссылка
        |    И ПоступлениеТоваровУслугТовары.ПрослеживаемыйТовар
        |    И (НЕ &ПрослеживаемыеОперацииОтображаютсяВДекларацииНДС
        |            ИЛИ &БезвозмездноеПоступление)";
        //|            ИЛИ &ЭтоПоступлениеИзЕАЭС)";
    КонецЕсли;

    ТекстЗапроса = ТекстЗапроса + ПрослеживаемостьБП.ТекстРазделителяЗапросовПакета();
    ТекстЗапроса = ТекстЗапроса + "ВЫБРАТЬ
    |    ВТ_СуммыБезНДСПредварительная.Номенклатура КАК Номенклатура,
    |    СУММА(ВТ_СуммыБезНДСПредварительная.СуммаБезНДС) КАК СуммаБезНДС,
    |    ВТ_СуммыБезНДСПредварительная.ЭтоЗакупкаДляКомитента КАК ЭтоЗакупкаДляКомитента
    |ПОМЕСТИТЬ ВТ_СуммыБезНДС
    |ИЗ
    |    ВТ_СуммыБезНДСПредварительная КАК ВТ_СуммыБезНДСПредварительная
    |ГДЕ
    |    ВТ_СуммыБезНДСПредварительная.Номенклатура <> НЕОПРЕДЕЛЕНО
    |
    |СГРУППИРОВАТЬ ПО
    |    ВТ_СуммыБезНДСПредварительная.Номенклатура,
    |    ВТ_СуммыБезНДСПредварительная.ЭтоЗакупкаДляКомитента
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |ВЫБРАТЬ
    |    ВТ_Прослеживаемость.Номенклатура КАК Номенклатура,
    |    ВТ_Прослеживаемость.Количество КАК Количество,
    |    ВТ_Прослеживаемость.РНПТ КАК РНПТ,
    |    ВТ_Прослеживаемость.КоличествоПрослеживаемости КАК КоличествоПрослеживаемости,
    |    ВТ_Прослеживаемость.ОтражениеВОтчетности КАК ОтражениеВОтчетности,
    |    ВТ_Прослеживаемость.КодОперации КАК КодОперации,
    |    ВТ_Прослеживаемость.ДокументОперации КАК ДокументОперации,
    |    ВТ_Прослеживаемость.Контрагент КАК Контрагент,
    |    ВТ_Прослеживаемость.ПериодОперации КАК ПериодОперации,
    |    ВТ_Прослеживаемость.НомерДокумента КАК НомерДокумента,
    |    ВТ_Прослеживаемость.ДатаДокумента КАК ДатаДокумента,
    |    ВТ_Прослеживаемость.ТипДокументаВПрослеживаемости КАК ТипДокументаВПрослеживаемости,
    |    ЕСТЬNULL(ВТ_СуммыБезНДС.СуммаБезНДС, 0) КАК СуммаБезНДС
    |ИЗ
    |    ВТ_Прослеживаемость КАК ВТ_Прослеживаемость
    |        ЛЕВОЕ СОЕДИНЕНИЕ ВТ_СуммыБезНДС КАК ВТ_СуммыБезНДС
    |        ПО ВТ_Прослеживаемость.Номенклатура = ВТ_СуммыБезНДС.Номенклатура
    |            И ВТ_Прослеживаемость.ЭтоЗакупкаДляКомитента = ВТ_СуммыБезНДС.ЭтоЗакупкаДляКомитента
    |ГДЕ
    |    ВТ_Прослеживаемость.РНПТ <> НЕОПРЕДЕЛЕНО
    |    И НЕ &ЭтоИмпорт
    |    И НЕ &ЭтоКомиссия
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |ВЫБРАТЬ
    |    ВТ_Прослеживаемость.Номенклатура КАК Номенклатура,
    |    СУММА(ВТ_Прослеживаемость.Количество) КАК Количество,
    |    ВТ_Прослеживаемость.СтранаПроисхождения КАК СтранаПроисхождения,
    |    ВТ_Прослеживаемость.Комитент КАК Комитент,
    |    ВТ_Прослеживаемость.ВидЗапасов КАК ВидЗапасов,
    |    ЗНАЧЕНИЕ(Справочник.Контрагенты.ПустаяСсылка) КАК Комиссионер,
    |    СУММА(ВТ_Прослеживаемость.КоличествоПрослеживаемости) КАК КоличествоПрослеживаемости,
    |    ВТ_Прослеживаемость.РНПТ КАК РНПТ,
    |    ДАТАВРЕМЯ(1, 1, 1) КАК ДатаРеализации,
    |    НЕОПРЕДЕЛЕНО КАК ОснованиеДляВозврата
    |ИЗ
    |    ВТ_Прослеживаемость КАК ВТ_Прослеживаемость
    |ГДЕ
    |    ВТ_Прослеживаемость.РНПТ <> НЕОПРЕДЕЛЕНО
    |
    |СГРУППИРОВАТЬ ПО
    |    ВТ_Прослеживаемость.Номенклатура,
    |    ВТ_Прослеживаемость.СтранаПроисхождения,
    |    ВТ_Прослеживаемость.Комитент,
    |    ВТ_Прослеживаемость.ВидЗапасов,
    |    ВТ_Прослеживаемость.РНПТ
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |ВЫБРАТЬ РАЗЛИЧНЫЕ
    |    ВТ_Прослеживаемость.РНПТ КАК РНПТ
    |ИЗ
    |    ВТ_Прослеживаемость КАК ВТ_Прослеживаемость
    |ГДЕ
    |    ВТ_Прослеживаемость.РНПТ <> НЕОПРЕДЕЛЕНО";
    
    Возврат ТекстЗапроса;
    
КонецФункции

Вызов запроса:
    НомераТаблиц         = Новый Структура;
    ПараметрыПроведения = Новый Структура;
    
    Запрос.Текст = Документы.ПоступлениеТоваровУслуг.ТекстЗапросаПрослеживаемыеТовары(НомераТаблиц, ПараметрыПроведения, УсловияПрослеживаемости);
    
    Если (Не ПустаяСтрока(Запрос.Текст)) Тогда
        Результат = Запрос.ВыполнитьПакет();
        Для Каждого НомерТаблицы Из НомераТаблиц Цикл
            ПараметрыПроведения.Вставить(НомерТаблицы.Ключ, Результат[НомерТаблицы.Значение].Выгрузить());
        КонецЦикла;
    КонецЕсли;
    
    СтруктураШапкиДокумента.Вставить("СтранаРегистрации", ?(ЗначениеЗаполнено(СтруктураШапкиДокумента.Контрагент.ОКСМ), СтруктураШапкиДокумента.Контрагент.ОКСМ,
                                     Справочники.КлассификаторСтранМира.Россия));
    
    ТаблицаРеквизиты = ПрослеживаемостьБП.СтруктуруВТаблицуЗначений(СтруктураШапкиДокумента);
    
    ПрослеживаемостьБП.СформироватьДвиженияПоступлениеТоваров(ПараметрыПроведения.ПрослеживаемыеТовары, ПараметрыПроведения.ПрослеживаемыеОперации, ПараметрыПроведения.РНПТ,
                                                              ТаблицаРеквизиты, Движения);

В запросе 5-ая таблица "ПрослеживаемыеОперации". В ней есть поле "ТипДокументаВПрослеживаемости".
Если данный запрос выполнить в консоли, то в 5-ой таблице поле "ТипДокументаВПрослеживаемости" заполнено.
В базе - это поле пустое.
Почему?
Спасибо.
   Ёпрст
 
1 - 06.08.21 - 14:46
(0) Потому, что по капусте ползал белый червячок
   ДенисЧ
 
2 - 06.08.21 - 14:46
Вот у тебя определяется это поле

        |    ВЫБОР
        |        КОГДА НЕ &ПрослеживаемыеОперацииОтображаютсяВДекларацииНДС
        |                ИЛИ &БезвозмездноеПоступление
        |            ТОГДА ВЫБОР
        |                    КОГДА ПоступлениеТоваровУслугТовары.Ссылка.ЭтоУниверсальныйДокумент
        |                        ТОГДА ЗНАЧЕНИЕ(Справочник.ТипыДокументов.УПД)
        |                    ИНАЧЕ ЗНАЧЕНИЕ(Справочник.ТипыДокументов.Накладная)
        |                КОНЕЦ
        |        ИНАЧЕ НЕОПРЕДЕЛЕНО
        |    КОНЕЦ КАК ТипДокументаВПрослеживаемости,

Оно вычисляется из параметров.
Какой отсюда вывод?
   ДенисЧ
 
3 - 06.08.21 - 14:46
(1) А капуста белокочанная или цветная?
   Beduin
 
4 - 06.08.21 - 14:46
(0) Ты параметры правильно транслировала в консоль?
   Ёпрст
 
5 - 06.08.21 - 14:46
А так, параметры разные в консоле и в коде.
   Масянька
 
6 - 06.08.21 - 14:48
(5) Какой именно?
    Запрос = Новый Запрос;
    Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
    Запрос.УстановитьПараметр("Ссылка",         Ссылка);
    Запрос.УстановитьПараметр("ЕстьНДС",         ЕстьНДС);
    Запрос.УстановитьПараметр("ПлательщикНДС",     ПлательщикНДС);
    Запрос.УстановитьПараметр("ПрослеживаемыеОперацииОтображаютсяВДекларацииНДС", (ПлательщикНДС И ЕстьНДС));
    Запрос.УстановитьПараметр("ЭтоКомиссия",     СтруктураШапкиДокумента.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СКомитентом);
    Запрос.УстановитьПараметр("ЭтоИмпорт",      ?(ЗначениеЗаполнено(СтруктураШапкиДокумента.Контрагент.ОКСМ) И 
                                                  СтруктураШапкиДокумента.Контрагент.ОКСМ = Справочники.КлассификаторСтранМира.Россия, Истина, Ложь));
    
    СчетБезвозмездногоПолучения = ПланыСчетов.Хозрасчетный.БезвозмездныеПоступления;//98.02

    
    Запрос.УстановитьПараметр("БезвозмездноеПоступление",  ?(СтруктураШапкиДокумента.СчетУчетаРасчетовСКонтрагентом = СчетБезвозмездногоПолучения, Истина, Ложь));
   Beduin
 
7 - 06.08.21 - 14:49
(6) Ты как параметры переносила в консоль? Не руками же.
   Ёпрст
 
8 - 06.08.21 - 14:49
(6) в отладчике точку останова перед выполнением запроса и сымотри сам текст и параметры. Тот же текст пихай в консоль и такие же параметры.
   vicof
 
9 - 06.08.21 - 14:49
(6) такие вопросы стыдно задавать должно быть.
   Ёпрст
 
10 - 06.08.21 - 14:49
можно и ИР задействовать, оно само там всё подставит
   fisher
 
11 - 06.08.21 - 14:51
(1) Ох нифига себе. А я это у Янки как-то пропустил.
   Масянька
 
12 - 06.08.21 - 14:52
(8) Нашла.
   Ёпрст
 
13 - 06.08.21 - 14:52
(11) ты кончай такие штуки , ты давай не подыхай, мы с тобой увидим скоро как рождается земля
   Масянька
 
14 - 06.08.21 - 14:52
Всем спасибо!
   Масянька
 
15 - 06.08.21 - 14:53
(13) А когда будет?
   fisher
 
16 - 06.08.21 - 14:54
(13) Уже слушаю :)

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.