Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

На основании Возврат товаров поставщику какая СФ?

На основании Возврат товаров поставщику какая СФ?
Я
   Mikhail Volkov
 
02.08.21 - 17:05
В КА1 (УПП) вводится Счет-фактура выданный - вроде правильно, Возврат товаров поставщику, если его дата больше даты поступления отчетного периода, то он проводится по алгоритму Реализации. А в КА2 (ERP) в Возврат товаров поставщику жму "Зарегистрировать счет-фактуру" - открывается Счет-фактура полученный (создание)!?
И при обмене из КА1 в КА2 помечается на удаление с ошибкой: Не удалось провести: Счет-фактура выданный ИП-000000007 от 08.07.2021 15:39:01 {(103)}: Ошибка при вызове метода контекста (Записать): Помеченный на удаление документ не может быть проведен! Где именно в КА2 помечается на удаление пока не нашел, хотелось бы знать где правда: в КА1 на основании Возврат товаров поставщику вводится СФ выданный, а в КА2 - СФ полученный?
   Mikhail Volkov
 
1 - 03.08.21 - 11:20
В модуле  Счет-фактура выданный ПередЗаписью() дописал Сообщить(), и получил:
ПометкаУдаления:  Нет, ОбменДанными.Загрузка: Да, РежимЗаписи: Запись, РежимПроведения: Неоперативный
ПометкаУдаления:  Да, ОбменДанными.Загрузка: Нет, РежимЗаписи: Отмена проведения, РежимПроведения: Неоперативный
Но где ставится пометка на удаление, как его найти?
   Mikhail Volkov
 
2 - 04.08.21 - 10:16
Снимаю пометку на удаление с Счет-фактура выданный, провожу, никаких сообщений, предупреждений... Где то место, в котором ставится пометка на удаление при обмене, как его найти?
   Mikhail Volkov
 
3 - 04.08.21 - 17:51
Вроде как поставщик, получив возращенный товар, должен оформить корректировочный счет-фактуру. И мы должны занести ее себе как полученную корректировочную счет-фактуру. Но как это правильно сделать в КА: УПП и ERP?
   Mikhail Volkov
 
4 - 05.08.21 - 09:47
Оказывается в КА1 (УПП) в документе Возврат товаров поставщику на вкладке НДС есть галочка: Поставщику выставляется счет-фактура на возврат: "При снятом флаге возврат отражается по счету-фактуре поступления. Если во всех или отдельных строках табличной части ценностей не указан документ поступления, на основании возврата может быть введен счет-фактура для указания реквизитов входящего документа.
При установленном флаге выписывается отдельный счет-фактура на возвращаемые ценности. Один экземпляр счета-фактуры передается поставщику". При снятии этой галочки надпись у Счет-фактуры "выданный" меняется на "полученный".
Может в КА2 (ERP) есть подобная галочка, не в документе Возврат товаров поставщику, а в общих настройках, где?
   Mikhail Volkov
 
5 - 05.08.21 - 14:58
Среди констант в КА2 (ERP) не нашел ничего подобного...
   Mikhail Volkov
 
6 - 05.08.21 - 16:12
Куда поставить точку останова, чтобы выяснить где ставится пометка на удаление? ПередЗаписью() бесполезно (1). В правилах обмена есть фрагмент Выполнить(Алгоритмы.ВыполнитьПроведениеДокументов):
ДокументыДляПовторногоПроведения = Новый Массив;
Для Каждого Документ Из Параметры.ДокументыДляПроведения Цикл
    Если Не Документ.ЭтоНовый() Тогда
        
        // Переполучаем объект, т.к. он мог быть изменен

        ДокументОбъект = Документ.Ссылка.ПолучитьОбъект();
        
        УстановитьОбменДаннымиЗагрузка(ДокументОбъект, Ложь);
        ДокументПроведен = Истина;
        Попытка
            
            Если ДокументОбъект.ПроверитьЗаполнение() Тогда
            
                ДокументОбъект.ДополнительныеСвойства.Вставить("ОтключитьМеханизмРегистрацииОбъектов", Истина);
                ДокументОбъект.ДополнительныеСвойства.Вставить("НеПроверятьДатыЗапретаИзмененияДанных");
                
                // выполняем попытку проведения документа

                ДокументОбъект.Записать(РежимЗаписиДокумента.Проведение);
                
                
            КонецЕсли;
        Исключение
            ДокументПроведен = Ложь;
        КонецПопытки;
        Если ДокументПроведен Тогда
            // Отражение в регл учете отдельной попыткой, т.к. не все документы его поддерживают.

            Попытка
                СсылкаДокумента = ДокументОбъект.Ссылка;
                
                СтруктураРеквизиты = Новый Структура(
                "Ссылка, Дата, Организация",
                СсылкаДокумента,
                СсылкаДокумента.Дата,
                СсылкаДокумента.Организация);
                
                РеглУчетПроведениеСервер.ОтразитьДокумент(СтруктураРеквизиты);
            Исключение
            КонецПопытки;
        ИначеЕсли ТипЗнч(ДокументОбъект.Ссылка) = Тип("ДокументСсылка.СчетФактураВыданный")
            Или ТипЗнч(ДокументОбъект.Ссылка) = Тип("ДокументСсылка.СчетФактураПолученный") Тогда
            ДокументыДляПовторногоПроведения.Добавить(ДокументОбъект);
        КонецЕсли;
    КонецЕсли;
КонецЦикла;

ДокументОбъект.ПроверитьЗаполнение() - это где в Счет-фактура выданный?
   Mikhail Volkov
 
7 - 06.08.21 - 09:37
Нашел УчетНДСРФ.АктуализироватьСчетаФактурыВыданныеПередЗаписью() где ставится пометка на удаление. В ней:
Функция СчетФактураВыданныйНеТребуется(ПараметрыРегистрации)
    
    СчетФактураНеТребуется = Ложь;
    
    Если НЕ ПараметрыРегистрации.РеализацияТоваров
         И НЕ ПараметрыРегистрации.РеализацияРаботУслуг
         И НЕ ПараметрыРегистрации.РеализацияПрочихАктивов
         И НЕ ПараметрыРегистрации.ВозвратТоваровПоставщику
         И НЕ ПараметрыРегистрации.ПрочееНачислениеНДС
         И НЕ ПараметрыРегистрации.ИсправлениеОшибок
         И НЕ ПараметрыРегистрации.КорректировкаПоСогласованиюСторон Тогда
        СчетФактураНеТребуется = Истина;
//    ИначеЕсли ПараметрыРегистрации.ВозвратТоваровПоставщику    //+МВ 06.07.2021

//        И (ПараметрыРегистрации.КорректировкаПоСогласованиюСторон
//                И ПараметрыРегистрации.Дата < ДатаОтраженияВозвратовКорректировочнымиСФ()

//            ИЛИ Не ПараметрыРегистрации.КорректировкаПоСогласованиюСторон
//                И ПараметрыРегистрации.Дата >= ДатаОтраженияВозвратовКорректировочнымиСФ()) Тогда

//        СчетФактураНеТребуется = Истина;
    КонецЕсли;
    
    Возврат СчетФактураНеТребуется;
    
КонецФункции

// Возвращает дату начала отражения возвратов корректировочными счетами-фактурами 

//
// Возвращаемое значение:

//   Дата   - по умолчанию 01 января 2019 года
//

Функция ДатаОтраженияВозвратовКорректировочнымиСФ() Экспорт

    Возврат '20190101';

КонецФункции

Т.е. в КА2 (ERP) жестко задано с 01 января 2019 года СФ выданные невозможны, только полученные корректировочные. Пришлось часть функции СчетФактураВыданныйНеТребуется() закомментировать.

Список тем форума
 
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.