Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Создание файла DBF

Создание файла DBF
Я
   Niel
 
30.07.21 - 17:15
Доброго времени суток. Подскажите, пожалуйста, почему не создается файл?
&НаКлиенте
Процедура Команда1(Команда)
    ВыполнитьКоманду("ВыгрузкаНомен");
КонецПроцедуры

&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды)
    ЭкспортНомен();    
КонецПроцедуры

&НаСервере
Процедура ЭкспортНомен()
    ф=Новый XBase;
    ф.Поля.Добавить("cod","S",40);
    ф.Кодировка=КодировкаXBase.OEM;
    ф.АвтоСохранение=Истина;
    ф.СоздатьФайл("c:\nom.dbf");
    //ф.ОчиститьФайл();    
    Запрос=Новый Запрос("ВЫБРАТЬ ПЕРВЫЕ 10
                        |    Номенклатура.Ссылка КАК Ссылка
                        |ИЗ
                        |    Справочник.Номенклатура КАК Номенклатура");
    Выборка = Запрос.Выполнить().Выбрать();
    
    Пока Выборка.Следующий() цикл
        ф.Добавить();
        ф.cod = Выборка.Ссылка;
    КонецЦикла;
    
    ф.ЗакрытьФайл();
КонецПроцедуры
   ДенисЧ
 
1 - 30.07.21 - 17:18
На сервере 
запрещена запись
ф.СоздатьФайл("c:\nom.dbf");
   bolder
 
2 - 30.07.21 - 18:06
(1) Внезапненько))Лайк!
Давно все говорят что порог в 1С вырос.
   Niel
 
3 - 30.07.21 - 20:11
(2) Подскажите, пожалуйста, а как надо?
   kubik_live
 
4 - 30.07.21 - 20:23
(3) Закусыва... ой Записывать НАДО! :)))))))))))
  Пока Выборка.Следующий() цикл
        ф.Добавить();
        ф.cod = Выборка.Ссылка;
        
        ф.Записать();

    КонецЦикла;
   kubik_live
 
5 - 30.07.21 - 20:31
+(4) А учитывая что:

ф.Поля.Добавить("cod","S",40);

Тогда
ф.cod = Лев(СокрЛП(Выборка.Ссылка),40);
   Niel
 
6 - 30.07.21 - 20:34
(4) после первой не закусыва..ой записываю ))

спасибо БООЛЬШОЕ!!! Всё получилось.
   kubik_live
 
7 - 30.07.21 - 20:37
(6) +++
Так много примеров записи в dBase в инете, неужели сразу не нашли?
   kubik_live
 
8 - 30.07.21 - 20:42
(6) Если будете писать в поля MEMO - обращайтесь
   Niel
 
9 - 30.07.21 - 20:42
(7) глаз замылился ((
   Niel
 
10 - 30.07.21 - 20:42
(8) спасибо большое

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.