Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Копия ОСВ в расширении не выводит дополнительные поля

Копия ОСВ в расширении не выводит дополнительные поля
Я
   pessok
 
30.07.21 - 12:54
Коллеги, всем привет!
Уже сломал голову и отладчик.
Суть проблемы - надо внести в ОСВ дополнительный источник данных и выводить из него данные для части счетов учета: данные сверки с контрагентами на счетах, где первое субконто - Контрагент
Типовую ОСВ надо оставить as is.
Скопировал отчет в расширение, дал новое имя, в модуле менеджера и модуле объекта тоже всё переименовал, дотащил нужные метаданные.
Формирую отчет - из настроек работает всё, кроме дополнительных полей, которые мне, собственно, и нужны.
Тупо не отрабатывает, притом любое доп. поле, не только добавленные в запросе.
Куда копать? Может кто-то сталкивался?
Заранее спасибо!
   RoRu
 
1 - 30.07.21 - 13:45
(0) базу не обновляли?
   pessok
 
2 - 30.07.21 - 13:46
эм, нет, а причем тут обновление?
   RoRu
 
3 - 30.07.21 - 13:47
(2) в последних релизах вроде изменилось что- то по работе с доп реквизитами
   pessok
 
4 - 30.07.21 - 13:59
3.0.96.35

Докопался до метода

// Функция добавляет выбранное поле и возвращает элемент выбранного поля. 

//
// Параметры:

//    ЭлементСтруктуры - КомпоновщикНастроекКомпоновкиДанных, НастройкиКомпоновкиДанных, 
//                       ВыбранныеПоляКомпоновкиДанных - Элемент структуры настройки отчета.

//    Поле - Строка - имя поля, которое нужно добавить в СКД.
//    Заголовок - Строка - Заголовок добавляемого поля.

// 
// Возвращаемое значение:

//    ВыбранноеПолеКомпоновкиДанных - Добавленное поле.
//

Функция ДобавитьВыбранноеПоле(ЭлементСтруктуры, Знач Поле, Заголовок = Неопределено) Экспорт
    
    Если ТипЗнч(ЭлементСтруктуры) = Тип("КомпоновщикНастроекКомпоновкиДанных") Тогда
        ВыбранныеПоля = ЭлементСтруктуры.Настройки.Выбор;
    ИначеЕсли ТипЗнч(ЭлементСтруктуры) = Тип("НастройкиКомпоновкиДанных") Тогда
        ВыбранныеПоля = ЭлементСтруктуры.Выбор;
    Иначе
        ВыбранныеПоля = ЭлементСтруктуры;
    КонецЕсли;
    
    Если ТипЗнч(Поле) = Тип("Строка") Тогда
        Поле = Новый ПолеКомпоновкиДанных(Поле);
    КонецЕсли;
    ВыбранноеПоле = ВыбранныеПоля.Элементы.Добавить(Тип("ВыбранноеПолеКомпоновкиДанных"));
    ВыбранноеПоле.Поле = Поле;
    Если Заголовок <> Неопределено Тогда
        ВыбранноеПоле.Заголовок = Заголовок;
    КонецЕсли;
    
    Возврат ВыбранноеПоле;
    
КонецФункции

ЭлементСтруктуры.Настройки.Выбор; - пустое значение.

Продолжаем изыскания
   pessok
 
5 - 30.07.21 - 14:03
Так, что-то именно с информацией по контрагенту, из организации доп. поля выводит.
Так что явно частный случай.
Всем спасибо за участие)

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.