Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Поле объекта не обнаружено (ДатаСобытия)

Поле объекта не обнаружено (ДатаСобытия)
Я
   Mehanik
 
27.07.21 - 12:30
Ошибка:
Ошибка при выполнении обработчика - 'ОбработкаПроведения'
по причине:
{ОбщийМодуль.ПроведениеДокументов.Модуль(101)}: Поле объекта не обнаружено (ДатаСобытия)
        КадровыеДвижения.Колонки.ДатаСобытия.Имя = "Период";

Код процедуры:
Процедура СформироватьКадровыеДвижения(РегистраторОбъект, Движения, КадровыеДвижения, ЗаполнятьНаборЗаписей = Истина) Экспорт
    
    Если КадровыеДвижения.Количество() > 0 Тогда
        Движения.КадроваяИсторияСотрудников.Записывать = Истина;
    КонецЕсли;
    
    Если ЗаполнятьНаборЗаписей Тогда
        КадровыеДвижения.Колонки.ДатаСобытия.Имя = "Период";
        Движения.КадроваяИсторияСотрудников.Загрузить(КадровыеДвижения);
        
    КонецЕсли;
    
    Если РегистраторОбъект.ДополнительныеСвойства.Свойство("ОтключитьПроверкуДатыЗапретаИзменения")
        И РегистраторОбъект.ДополнительныеСвойства.ОтключитьПроверкуДатыЗапретаИзменения Тогда
        
        Движения.КадроваяИсторияСотрудников.ДополнительныеСвойства.Вставить("ОтключитьПроверкуДатыЗапретаИзменения", Истина);
        
    КонецЕсли;
    
КонецПроцедуры
   ДенисЧ
 
1 - 27.07.21 - 12:36
Нет такой колонки...
   Mehanik
 
2 - 27.07.21 - 12:44
Где мне её добавить?
   Мультук
 
3 - 27.07.21 - 12:45
(0) Сейчас из тебя клещами будут вытягивать информацию:
1) Название и версия конфигурации
2) На поддержке ли конфа или туда уже лазали грязными руками
3) если обновлял, то удалил ли расширения-патчи или "как всегда"
4) не прыгал ли при обновлении через N-релизов
5) чистил ли кэш....
   Mehanik
 
4 - 27.07.21 - 12:48
1. Тестовая
2. Не поддерживается
3. Что за расширения-патчи?)
4. Нет
5. Где его чистить?
   Kassern
 
5 - 27.07.21 - 12:50
(4) крутая конфигурация "тестовая", уже такие релизы есть от 1с?)
   Kassern
 
6 - 27.07.21 - 12:50
(4) "Что за расширения-патчи?)" а вы кем являетесь, программистом?
   Mehanik
 
7 - 27.07.21 - 12:54
Нет, начинаю только 1с изучать
   Mehanik
 
8 - 27.07.21 - 12:57
Версия конфигурации: (3.0.25.9)
   Kassern
 
9 - 27.07.21 - 12:57
(8) 3.0.25.9 это версия чего? Бухгалтерия, зарплата, УТ, УПП, ЕРП и т.д.
   Mehanik
 
10 - 27.07.21 - 12:58
Кадры
   Mehanik
 
11 - 27.07.21 - 13:45
Бухгалтерия предприятия, редакция 3.0 (3.0.92.51)
Copyright (С) ООО "1C-Софт", 2009 - 2021. Все права защищены
   Mehanik
 
12 - 27.07.21 - 14:27
А где мне это поле проверить?
   Kondarat
 
13 - 27.07.21 - 14:38
(12) Вероятно в таблице значений "КадровыеДвижения"
   Mehanik
 
14 - 27.07.21 - 16:33
Ошибки на трёх именно процедурах, а именно в местах:

КадровыеДвижения.Колонки.ДатаСобытия.Имя = "Период";
СтруктураДанных.ДанныеОПлановыхНачислениях.Колонки.ДатаСобытия.Имя = "Период";
ДанныеСостоянийСотрудника.Колонки.ДатаСобытия.Имя = "Период";

Хотя данные загружаю:
Функция ПолучитьДанныеДляПроведения()    
    Запрос = Новый Запрос;
    
    Запрос.УстановитьПараметр("ДатаСобытия", ЭтотОбъект.ДатаУвольнения);
    Запрос.УстановитьПараметр("Ссылка", Ссылка);
    Запрос.УстановитьПараметр("Организация", Организация);
    Запрос.УстановитьПараметр("Подразделение", Подразделение);
    Запрос.УстановитьПараметр("Сотрудник", Сотрудник);
    
    Запрос.Текст =  
    "ВЫБРАТЬ
    |    ПриказОУвольненииСтавки.Ссылка.Сотрудник КАК Сотрудник,
    |    ПриказОУвольненииСтавки.Ссылка.Организация КАК ГоловнаяОрганизация,
    |    ПриказОУвольненииСтавки.ВидЗанятости КАК ВидЗанятости,
    |    ПриказОУвольненииСтавки.Ссылка.Подразделение КАК Подразделение,
    |    ПриказОУвольненииСтавки.Должность,
    |    ПриказОУвольненииСтавки.Ссылка.Организация КАК Организация,
    |    ЗНАЧЕНИЕ(Перечисление.ВидыКадровыхСобытий.Увольнение) КАК ВидСобытия,
    |    ПриказОУвольненииСтавки.Ссылка.ДатаУвольнения КАК ДатаУвольнения,
    |    ПриказОУвольненииСтавки.Ссылка.ДатаУвольнения КАК ДатаСобытия,
    |    ПриказОУвольненииСтавки.Ссылка КАК ПервичныйДокумент
    |ИЗ
    |    Документ.ПриказОУвольнении.Ставки КАК ПриказОУвольненииСтавки
    |ГДЕ
    |    ПриказОУвольненииСтавки.Ссылка = &Ссылка
    |;
    |
    ////////////////////////////////////////////////////////////////////////////////

    |ВЫБРАТЬ
    |    ПриказОУвольненииСтавки.Ссылка.Организация,
    |    ПриказОУвольненииСтавки.Ссылка.Сотрудник,
    |    ПриказОУвольненииСтавки.Ссылка.Подразделение,
    |    ПриказОУвольненииСтавки.Должность,
    |    ПриказОУвольненииСтавки.ВидЗанятости,
    |    ЗНАЧЕНИЕ(Перечисление.СостоянияСотрудника.Увольнение) КАК Состояние,
    |    ПриказОУвольненииСтавки.Ставка,
    |    ПриказОУвольненииСтавки.СчетУчетаЗатрат,
    |    ПриказОУвольненииСтавки.Субконто1,
    |    ПриказОУвольненииСтавки.Субконто2,
    |    ПриказОУвольненииСтавки.Субконто3,
    |    ПриказОУвольненииСтавки.Ссылка КАК Основание,
    |    ПриказОУвольненииСтавки.Ссылка.ДатаУвольнения КАК ДатаСобытия
    |ИЗ
    |    Документ.ПриказОУвольнении.Ставки КАК ПриказОУвольненииСтавки
    |ГДЕ
    |    ПриказОУвольненииСтавки.Ссылка = &Ссылка
    |;
    |
    ////////////////////////////////////////////////////////////////////////////////

    |ВЫБРАТЬ
    |    ПлановыеНачисленияИУдержанияСрезПоследних.Организация,
    |    ПлановыеНачисленияИУдержанияСрезПоследних.Сотрудник,
    |    ПлановыеНачисленияИУдержанияСрезПоследних.Подразделение,
    |    ПлановыеНачисленияИУдержанияСрезПоследних.Должность,
    |    ПлановыеНачисленияИУдержанияСрезПоследних.ВидНачисленияУдержания,
    |    ПлановыеНачисленияИУдержанияСрезПоследних.Валюта,
    |    ПлановыеНачисленияИУдержанияСрезПоследних.ВидЗанятости,
    |    ПлановыеНачисленияИУдержанияСрезПоследних.Сумма,
    |    ЛОЖЬ КАК Актуальность,
    |    &ДатаСобытия
    |ИЗ
    |    РегистрСведений.ПлановыеНачисленияИУдержания.СрезПоследних(
    |            &ДатаСобытия,
    |            Организация = &Организация
    |                И Подразделение = &Подразделение
    |                И Сотрудник = &Сотрудник) КАК ПлановыеНачисленияИУдержанияСрезПоследних
    |ГДЕ
    |    ПлановыеНачисленияИУдержанияСрезПоследних.Актуальность";
    
    РезультатЗапроса = Запрос.ВыполнитьПакет();
    
    ДанныеДляПроведения = Новый Структура; 
    
    ДанныеДляПроведения.Вставить("КадровыеДвижения", РезультатЗапроса[0].Выгрузить());
    ДанныеДляПроведения.Вставить("СтавкиСотрудников", РезультатЗапроса[1].Выгрузить());
    ДанныеДляПроведения.Вставить("ПлановыеНачисления", РезультатЗапроса[2].Выгрузить());
    
    Возврат ДанныеДляПроведения        
КонецФункции
   Mehanik
 
15 - 27.07.21 - 16:36
Ругается на колонки, но почему? Я же их указываю
   Mehanik
 
16 - 27.07.21 - 16:49
Может быть из-за того, что документы приёма на работу и кадровые перемещения защищены от редактирования? И оно просто не считывает от туда данные
   Kondarat
 
17 - 27.07.21 - 16:51
(16) Можно ведь в отладчике посмотреть что там за колонки и что с ними происходит.
   Kassern
 
18 - 27.07.21 - 16:59
(0) зайдите и в отладке гляньте коллекцию колонок для КадровыеДвижения.Колонки
   Mehanik
 
19 - 27.07.21 - 17:18
Дело в том, что при откладке меня не возвращает в конфигуратор.
   Mehanik
 
20 - 27.07.21 - 17:21
Я запускаю через откладку и мне просто выбивает эту ошибку, не возвращая в конфигуратор
   Kondarat
 
21 - 27.07.21 - 17:21
(19) Если база клиент-серверная, надо включить отладку на сервере. Если файловая. вероятно не там ставим точечку...
   Mehanik
 
22 - 27.07.21 - 17:24
А как сделать откладку на сервере?
   Kondarat
 
23 - 27.07.21 - 17:27
(22) Загугли - не ленись. Ответов тьма.
   Ёпрст
 
24 - 27.07.21 - 17:32
(0) вероятно, повторно колонку переименовываешь (нахрена только ?)  и имеешь сабж
   Ёпрст
 
25 - 27.07.21 - 17:34
Если че, алияс задай Как Период в тексте запроса и выкинь своё переименование колонки отовсюду.
   Mehanik
 
26 - 28.07.21 - 09:32
Если ЗаполнятьНаборЗаписей Тогда
        КадровыеДвижения.Колонки.ДатаСобытия.Имя = "Период";
        Движения.КадроваяИсторияСотрудников.Загрузить(КадровыеДвижения);
    КонецЕсли;

КадровыеДвижения.Колонки.ДатаСобытия.Имя = "Период"; когда останавливаюсь тут, оно видит колонку и проходит всё. Но после загрузки кадровых движений, она пропадает. Смотреть кадровые движения?
   hhhh
 
27 - 28.07.21 - 12:17
(26) наверно 2 раза запускаете эту строку. На втором проходе колонки ДатаСобытия уже нет.
   Менталист
 
28 - 28.07.21 - 14:07
(26)Ты же сам изменил имя колонки с "ДатаСобытия" на "Период", так откуда она там появится с таким именем?
   Kassern
 
29 - 28.07.21 - 14:12
а можно вопрос, а на кой это все надо? Я про подмену имени колонки
   Kassern
 
30 - 28.07.21 - 14:12
(29) какую задачу то в целом решаете?
 
 
   Mehanik
 
31 - 28.07.21 - 15:49
Собственно разобрался... Просто предыдущие документы нужно было перепровести... Код вообще не трогал


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.