Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не срабатывает блокировка начала сеансов в консоли сервера 1С

Не срабатывает блокировка начала сеансов в консоли сервера 1С
Я
   Антиквар
 
26.07.21 - 16:34
Всем привет!

Есть 2 базы 1С: одна стандартная ЗУП, вторая самописная.
Обе базы клиент-серверные (MS SQL).
При необходимости проведения регламентных работ я ставлю блокировку начала сеансов в консоли сервера 1С, для обеих баз. С выводом сообщения пользователю.
Делаю всё одинаково, но блокировка срабатывает только в стандартной базе ЗУП. В самописной базе ничего не происходит.
Получается, что данный функционал - это не платформенное решение, это зависит от конфигурации? Нужно в самописной конфе чего-то докрутить?
Или куда копать?
   nodrama
 
1 - 26.07.21 - 16:37
Не знаю от чего это зависит.
У меня в ЗУПЕ 2.5, при установки блокировки сеансов, то же 50% людей заходят.
Но тут надо понимать какие сеансы. Если человек будет коннектиться к базе через COM или API, аля какой нибудь КаллЦентр как их там, не помню.
То Блокировка не работает на сколько я помню
   nodrama
 
2 - 26.07.21 - 16:39
Ну а вообще в коде ЗУП и Коде УПП. есть такое
"БлокировкаСеансов"

Функция РазрешитьРаботуПользователей() Экспорт
    
    Если НЕ ПравоДоступа("Администрирование", Метаданные) Тогда
        Возврат Ложь;
    КонецЕсли;
    
    ТекущийРежим = ПолучитьБлокировкуСеансов();
    Если ТекущийРежим.Установлена Тогда
        НовыйРежим = Новый БлокировкаСеансов;
        НовыйРежим.Установлена = Ложь;
        УстановитьБлокировкуСеансов(НовыйРежим);
    КонецЕсли;
    Возврат Истина;
    
КонецФункции
   Антиквар
 
3 - 26.07.21 - 16:41
(1) не, у меня проблема с обычными пользователями. Всякие COM и прочие внешние соединения отрубаю.
В ЗУП 3.1 действует на всех без проблем. В самописной вообще ни на кого
   nodrama
 
4 - 26.07.21 - 16:41
То есть есть обработка типовая в УПП и тд. БлокировкаСеансов, ты там ставишь время С и ПО и он блокирует сеансы если только ты не Админ.
Возьми ее из типовой УПП и поставь в свою самописную ну и код посмотри по поиску, что я выше скидывал. Сделай так же и попробуй. И галочки на сервере можно будет не ставить, возможно)
   Антиквар
 
5 - 26.07.21 - 16:42
(2) дак значит получается в конфе всё-таки зашита обработка этой штуки. Понятно, спасибо
   Антиквар
 
6 - 26.07.21 - 16:43
(4) ага, понял, посмотрю. Но в ЗУП 3.1 кстати и админа блокирует. По коду разблокировки только можно войти
   nodrama
 
7 - 26.07.21 - 16:44
(5) Ну я не копался. одно это то же (блокировкаСеанса и галочка в базе сервера 1с или нет) Но в Конфе точно есть типовая обработка БлокировкиСеансов, да и в синтаксическом помощнике есть БлокировкаСеансов.
Думаю что даже если в конфе не зашито. То можно Написать самому, либо взять из УПП допустим. там 10 строк и все.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.