Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ЗУП 3.1.18.121 Ошибка при выборе сотрудников в документе Табель учета рабочего времени

ЗУП 3.1.18.121 Ошибка при выборе сотрудников в документе Табель учета рабочего времени
Я
   Romazan1988
 
22.07.21 - 15:11
При создании документа "Табель учета рабочего времени" пытаюсь подобрать сотрудников из формы списка. Результат: сотрудники не выбраны в Табели.

Причина ошибки - косяк 1С. Возникает, когда включена настройка
"Настройка -Реквизиты  Организации - Учетная Политика и Другие Настройки - Учетная Политика  -  Расчет  Зарплаты  -  установили  галку  на  "Использовать обособленные территории" ".
Если галка включена , то в менеджере документа

[quote]

Процедура ОбработкаПолученияФормы(ВидФормы, Параметры, ВыбраннаяФорма, ДополнительнаяИнформация, СтандартнаяОбработка)
    Если ВидФормы = "ФормаОбъекта"
        И (ПолучитьФункциональнуюОпцию("ИспользоватьОбособленныеТерритории")
        Или ПолучитьФункциональнуюОпцию("ИспользоватьОсобыеУсловияТрудаВОрганизации")
        Или ПолучитьФункциональнуюОпцию("ИспользоватьСменыРаботыСотрудников")) Тогда
            
        ВыбраннаяФорма = "ФормаДокументаАльтернативная";
        СтандартнаяОбработка = Ложь;
    КонецЕсли;            
КонецПроцедуры

[/quote]

Вызывается форма "ФормаДокументаАльтернативная" и для нее не работает подбор.
Решение, либо кажды раз снимать галку в "Использовать обособленные территории", либо изменить программно через расширение

[quote]

&Вместо("ОбработкаПолученияФормы")
Процедура Расш2_ОбработкаПолученияФормы(ВидФормы, Параметры, ВыбраннаяФорма, ДополнительнаяИнформация, СтандартнаяОбработка)
    Если ВидФормы = "ФормаОбъекта"
        И (ПолучитьФункциональнуюОпцию("ИспользоватьОбособленныеТерритории")
        Или ПолучитьФункциональнуюОпцию("ИспользоватьОсобыеУсловияТрудаВОрганизации")
        Или ПолучитьФункциональнуюОпцию("ИспользоватьСменыРаботыСотрудников")) Тогда
            
        ВыбраннаяФорма = "ФормаДокумента";
        СтандартнаяОбработка = Ложь;
    КонецЕсли;    
КонецПроцедуры

[/quote]

P.S. Написал в техподдержку на v8@1c.ru , Жду.
Если я не прав и не так поступил, напишите свои варианты.
   Romazan1988
 
1 - 22.07.21 - 15:28
Статус обращения в техподдержку, может кому поможет https://regevent.1c.ru/sbo/tp/8e553ef0-eae1-11eb-8154-0050569f2415/info/
   Said_We
 
2 - 22.07.21 - 16:39
(0) "Решение, либо кажды раз снимать галку в "Использовать обособленные территории", либо изменить программно через расширение" - или сделать так что бы подбор работал в "ФормаДокументаАльтернативная".
   Said_We
 
3 - 22.07.21 - 16:46
(0) Там из обоих форм вызывается одна и та же процедура подбора, но количество параметров для "ФормаДокументаАльтернативная" указывается три, а не два, как для обычной формы.
Третьим не обязательным параметром передается сам объект, а должна быть по всей видимости элемент представления данных на форме табличной части "ДанныеВремени".

Как-то так.
   Said_We
 
4 - 22.07.21 - 16:49
(3) "сам объект" - это форма целиком.
Проще совсем не указывать этот третий параметр.
   Said_We
 
5 - 22.07.21 - 16:58
(0) "Если я не прав и не так поступил, напишите свои варианты." - если есть две формы разные и выбор зависит от настройки. То пусть так и есть. В одной из этих форм не работает подбор, так как он не верно вызывается. Его необходимо вызвать так же как и у "рабочей" формы. Либо если подбор должен отличаться, то этот третий параметр передать правильным образом (правильное значение правильного типа и/или структуры).
   SleepyHead
 
6 - 22.07.21 - 16:58
(0) То же самое при подборе в ведомости на выплату. Что-то они там намудрили со стандартными настройками.

Пытался установить стандартные настройки формы подбора - та же ошибка.
   Said_We
 
7 - 22.07.21 - 17:02
А в 3.1.18.46 работало?
   SleepyHead
 
8 - 22.07.21 - 17:03
(7) Я тебе больше скажу - работало даже в более ранних версиях.
   sitex
 
9 - 22.07.21 - 17:05
(0) Жертвы ЕГЭ пришли на работу. Чего странного. Сами сегодня от этого прифигели.
   Romazan1988
 
10 - 26.07.21 - 16:40
Опубликовал расширение для исправленния ситуации, может кому пригодиться https://infostart.ru/public/1485505/
Техподдержка только сегодня взялась за эту ошибку
   kubik_live
 
11 - 26.07.21 - 17:12
(10) Спасибо!
   Romazan1988
 
12 - 27.07.21 - 09:25
1С хочет отбрить меня по поводу обращения в техподдержку по этой проблеме. Пишут

[1C]
В типовой конфигурации текущего релиза проблема не подтверждается.
Если на сотрудника в указанном месяце нет табеля и сотрудник принят в штат организации, то наличие флага учета по обособленным территориям не влияет на подбор сотрудника в табель.
[1C]
   Said_We
 
13 - 27.07.21 - 14:28
(12) Может они свежее релиз выпустили?
   Romazan1988
 
14 - 28.07.21 - 09:04
У меня последняя версия ЗУП 3.1.18.121    16.07.21
1С отказала в приеме заявки, на демо версии ЗУП не удалось повторить этот глюк.
Ребят, протестировал подбор сотрудников заново на своем ЗУП. Табель заполняется сотрудником, но не всегда. Я не знаю что влияет на подбор сотрудника в табель. Попробуйте убрать фильтр подразделения и остальные фильтры и, вроде как, получится увидеть сотрудника в табеле.
   Said_We
 
15 - 28.07.21 - 09:08
(14) Ищи точный вариант воспроизводства ошибки ищи от чего зависит и полностью им описывай, иначе не примут.
Для точности описания алгоритма действий моделирования ошибки надо взять демку с поставки последнего релиза и на ней. Они будут смотреть именно так.
   Romazan1988
 
16 - 28.07.21 - 09:14
(15) Нашел!!!
Если уже существует табель с июньской датой на сотрудника из подбора , то сотрудника нельзя выбрать в создаваемом табеле за июНь. Нужно выбрать другой месяц.
   Romazan1988
 
17 - 29.07.21 - 16:18
Ответ линии консультаций:

Правильно ли мы Вас понимаем, что Вы создаете табель за м ай 2021 года, выбираете в него Булатова и сохраняете.
Затем создаете новый табель за май 2021 года и снова пытаетесь выбрать в него Булатова? 
Если так, то поведение программы правильное. Нельзя ввести более 1 табеля на одного сотрудника за один и тот же период.


1С хорошо сделали, что ушли от табличной части на форме. Но блин, заведующим магазинов нужно редактировать табеля сотруджников. Поэтому остаемся на старой форме до поры до времени

Список тем форума
 
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.