Вход | Регистрация
 

Три разных отчета СКД в одном табличном документе - ширина колонок

Три разных отчета СКД в одном табличном документе - ширина колонок
Я
   Гений 1С
 
16.07.21 - 11:33
Вывожу три разных отчета на СКД.
Если выводить отдельно, ширина колонок ОК.
Если выводить вместе, то ширина подстраивается под общую.
Как это побороть?

Визуально посмотреть тут: https://fixogram.ru/neponyatki-s-shirinoj/


СКД вывожу функцией:


Функция ВывестиОтчетВСКД(ДокументРезультат, СхемаКомпоновкиДанных, КомпоновщикНастроек, ДанныеРасшифровки, СтруктураВнешнихДанных = Неопределено) Экспорт
    
    КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных();
    Настройки = КомпоновщикНастроек.ПолучитьНастройки();
    МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
    ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных();
    ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, СтруктураВнешнихДанных, ДанныеРасшифровки);
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент();
    ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
    ПроцессорВывода.НачатьВывод();
    
    Пока Истина Цикл
        ЭлементРезультата = ПроцессорКомпоновкиДанных.Следующий();
        Если ЭлементРезультата = Неопределено Тогда
            Прервать;
        Иначе
            ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
        КонецЕсли;
        
    КонецЦикла;
    
    ПроцессорВывода.ЗакончитьВывод();
    
КонецФункции
   Ненавижу 1С
 
1 - 16.07.21 - 12:02
рисуй свое, например выводи на три разных табличных документа, потом склеивай
   Вафель
 
2 - 16.07.21 - 12:04
выводи каждый в свой, а потом объединяй с разной шириной
   Ботаник Гарден Меран
 
3 - 16.07.21 - 12:06
СоздатьФорматСтрок()
   fisher
 
4 - 16.07.21 - 12:07
Я бы попробовал создать индивидуальные форматы строк для заголовков группировок через макеты СКД. Вдруг выгорит.
   Гений 1С
 
5 - 16.07.21 - 12:08
(1) Гм, надо попробовать.
(3) Не помогает, пробовал.
   SleepyHead
 
6 - 16.07.21 - 12:17
(0) А на что влияет не так ширина колонок? Какую проблему создает?
   Гений 1С
 
7 - 16.07.21 - 12:29
(6) суммы в итого сокращает, заменяются на #####
   Гений 1С
 
8 - 16.07.21 - 12:30
(3) В общем получилось, но нужно по-особому использовать:


    ТекДокументРезультат = Новый ТабличныйДокумент();
    ТекСхемаКомпоновкиДанных = ПолучитьМакет("МакетСклад");
    ТекКомпоновщикНастроек = Новый КомпоновщикНастроекКомпоновкиДанных();
    ТекКомпоновщикНастроек.ЗагрузитьНастройки(ТекСхемаКомпоновкиДанных.НастройкиПоУмолчанию);
    
    //Включаем подробный режим

    Попытка
        ТекКомпоновщикНастроек.Настройки.Структура[0].Структура[0].Использование = Подробно;
    Исключение
    КонецПопытки;

    ДокументРезультат.Область(ДокументРезультат.ВысотаТаблицы + 1, 1).Текст = "Сравнение запасов товара на даты: " + Формат(ДатаСклада1, "ДФ=dd.MM.yyyy") + " и: " + Формат(ДатаСклада2, "ДФ=dd.MM.yyyy") + ?(ЗначениеЗаполнено(ВыбПодразделение), " По подразделению: " + ВыбПодразделение, "") + " Сформировано: " + ТекущаяДата();
    СтруктураВнешнихДанных = Новый Структура("ТЗ", ТЗ);
    ВывестиОтчетВСКД(ТекДокументРезультат, ТекСхемаКомпоновкиДанных, ТекКомпоновщикНастроек, ДанныеРасшифровки, СтруктураВнешнихДанных);
    СоздатьФорматСтрок(ТекДокументРезультат);
    ДокументРезультат.Вывести(ТекДокументРезультат);


Функция СоздатьФорматСтрок(ДокументРезультат) Экспорт
    ТекОбласть = ДокументРезультат.Область(1, 1, ДокументРезультат.ВысотаТаблицы, ДокументРезультат.ШиринаТаблицы);
    //ДокументРезультат.Область(ДокументРезультат.ВысотаТаблицы, , ДокументРезультат.ВысотаТаблицы, )

    ТекОбласть.СоздатьФорматСтрок();
КонецФункции
   SleepyHead
 
9 - 16.07.21 - 12:35
(7) А если в условном оформлении поменять методику "забивать" на "переносить"?
   Гений 1С
 
10 - 16.07.21 - 12:40
(9) уже не актульно, проблема решена. Нет, это будет не красиво.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.