Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка протокола системы взаимодействия

Ошибка протокола системы взаимодействия
Я
   soopchik
 
15.07.21 - 12:40
Всем доброго времени суток.
Не могу понять что не так.
С ошибкой валится при нажатии на "ОК" при добавлении новой интеграции с телеграмм.
Вчера с этим же ботом всё было нормально.
Подробнее текст ошибки:

Ошибка протокола системы взаимодействия
{ВнешняяОбработка.StandardECSRegister.Форма.IntegrationForm.Форма(260)}: Int.Write();
{ВнешняяОбработка.StandardECSRegister.Форма.IntegrationForm.Форма(267)}: SaveOnServer();

по причине:
Ошибка протокола системы взаимодействия

Подробнее как всё было.
Вчера:
зарегистрировал бота.
Зарегистрировал конфигурацию в системе взаимодействия на 1С:Диалог.
(конфигурация полностью пустая, кроме одной роли со всеми флагами и одного пользователя с этой ролью)
Добавил интеграцию. (по нажатию на "ОК" - было всё ок)
Отправил в бота сообщение.
Сразу появилось новое обсуждение в 1с.
По игрался с сообщениями туда - сюда. Всё отлично.
Решил почистить все сообщения.
Интерактивно не нашёл как.
Вроде разобрался как программно через СистемаВзаимодействия.УдалитьСообщение(текСообщение.Идентификатор);
Но не вышло.
Ошибка была та же "Ошибка протокола системы взаимодействия", только вот не сохранил подробностей.
Попробовал не заморачиваться и нажал в 1с выйти из беседы.
Вышел и больше ни чего сделать не смог. Новые сообщения не приходят.
Сегодня:
Удалил в 1с регистрацию.
Создал новую конфигурацию.
Добавил роль и пользователя.
Зарегистрировал на 1С:Диалог
Начал добавлять интеграцию.
т.е. всё как и вчера, но при нажатии на "ОК", получил вот такую бяку.

Может кто чем помочь?
По ошибке текущей, да и не только. Может я раньше что-то накосячил. Может есть какой другой совет, чтоб не прийти к этой ошибке.
Спасибо.
   Галахад
 
1 - 15.07.21 - 12:43
Хм. А если глазами посмотреть. В телеграмм. Там с ботом все в порядке?
   soopchik
 
2 - 15.07.21 - 12:50
(1) Знать бы как это можно проверить. Я и в этом то не силён.
Но сообщения из телеграмма в него слать могу.
   soopchik
 
3 - 15.07.21 - 12:59
(1) Вроде всё работает.
По ходил по всяким менюшкам в ботфазер
Поменял аватар.
   soopchik
 
4 - 15.07.21 - 13:48
Помогло удаление бота и создание того же заново.
Но вопрос остаётся открытым.
Возможно уже в другом контексте.
У кого есть какая информация по этому поводу?
Похоже на то что нельзя два раза регистрацию делать на один ИД

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.