Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ЗУП 3.14->3.18, расчетный листок, порядок выплат.

ЗУП 3.14->3.18, расчетный листок, порядок выплат.
Я
   Target1025
 
14.07.21 - 16:04
При переходе с 3.14 на 3.18 расчетный листок сломался в том смысле, что теперь выплаты в правой части листка идут не в возрастании, а как бог на душу положит. Кто-то решал этот вопрос?
   El_Duke
 
1 - 14.07.21 - 16:11
(0) А где тут вопрос ?
Выплаты есть ? Выплаты все что были сделаны ? Если да - никаких вопросов нет
   Target1025
 
2 - 14.07.21 - 16:17
(1) Они все сделаны, но в списке идут вразнобой.
   El_Duke
 
3 - 14.07.21 - 16:32
(2) Ну и что ?
   Target1025
 
4 - 14.07.21 - 16:35
(3) =) Завидую вам!
   KnightAlone
 
5 - 14.07.21 - 17:49
(4) отвечай так : "Это не баг, это фича!"
   vis_tmp
 
6 - 14.07.21 - 18:16
(0) А 1С обещала такой порядок?
   Гость из Мариуполя
 
7 - 14.07.21 - 20:43
(6) а 1С что, плюет на основные понятия? Мало ли что она обещала или не обещала. Есть азы, так сказать, букварь...

Так на минутку, Учет -  это отражение фактов хозяйственной деятельности предприятий в ХРОНОЛОГИЧЕСКОМ порядке.

Ведомость к выплате - это как бы факт хозяйственной жизни (ну или перечисление в банк при безнале) и как бы этот факт неплохо было бы отражать, соблюдая основные понятия бух.учета.
Ладно там начисления, там порядок непонятен, то ли сначала одну надбавку, потом другую, все обе в конце месяца начисляются.
Но вот выплаты - это свершившиеся факты хозяйственной деятельности, зафиксированные определенными документами на определенные даты, и отражать такие ФАКТЫ было бы неплохо не просто так плюя на вся и всех, а именно как и требуют Азы - в хронологическом порядке.

Поэтому мало ли что она там обещала или не обещала...

ps:

- Милый, ты обещал на мне жениться.
- Мало ли что я НА ТЕБЕ обещал.
   hhhh
 
8 - 14.07.21 - 21:23
(7) основная конфа 3.1.14. Если они экстремалы и захотели острых ощущений, пожалуйста, на 3.1.18. В бетатестеры.
   El_Duke
 
9 - 15.07.21 - 08:44
(7) Не вижу чтобы кто то на это плевал

Откройте журнал ведомостей к выплате, журнал кассовых документов или перечислений в банк. Там все доки (связанные с выплатой зарплаты в нашем случае) будут в  ХРОНОЛОГИЧЕСКОМ порядке, как того и требует учет. ФАКТЫ отражены как положено

Для расчетного листка нет обязательного правила в каком порядке там должны идти записи. Его можно вообще сделать внешне каким угодно
Работодатель должен проинформировать работника о составных частях заработной платы, величине начислений и удержаний, налогов. Если в листке все это есть - никто не сможет придраться к его правильности. Вся необходимая инфа имеется, а способы ее размещения на печатной форме - дело вкуса и личного восприятия.
Не вижу в озвученном в (0) никаких нарушений или проблем
   Chai Nic
 
10 - 15.07.21 - 08:46
(0) Что-то там оптимизировали, и про порядок сортировки забыли. Пишите в техподдержку. Когда-нибудь поправят, как они любят выражаться, "в одном из будущих релизов".
   Target1025
 
11 - 15.07.21 - 17:22
(0) Решил таким методом.

В общем модуле ЗарплатаКадрыОтчеты ищем строки:

// Выплачено

СтрокаГруппы = СтрокаСотрудника.Строки.Найти(Перечисления.ГруппыНачисленияУдержанияВыплаты.Выплачено, "Группа");

И дописываем:
// Выплачено

СтрокаГруппы = СтрокаСотрудника.Строки.Найти(Перечисления.ГруппыНачисленияУдержанияВыплаты.Выплачено, "Группа");
Если СтрокаГруппы <> Неопределено Тогда 
    Если СтрокаГруппы.Строки.Количество() > 1 Тогда// сортировка пузырьком

        СдвигБыл = Истина;
        Пока СдвигБыл Цикл
            СдвигБыл = Ложь;
            Для Истр = 0 По СтрокаГруппы.Строки.Количество() - 2 Цикл 
                
                Строка1 = СтрокаГруппы.Строки[Истр];
                Дата1 = ?(Строка1.Регистратор = Неопределено, '00010101',
                        ?(Строка1.Регистратор.Пустая(),'00010101',Строка1.Регистратор.Дата));
                
                Строка2 = СтрокаГруппы.Строки[Истр+1];
                Дата2 = ?(Строка2.Регистратор = Неопределено, '00010101',
                        ?(Строка2.Регистратор.Пустая(),'00010101',Строка2.Регистратор.Дата));
                
                Если Дата1>Дата2 Тогда
                    СтрокаГруппы.Строки.Сдвинуть(Истр,1);
                    СдвигБыл = Истина;
                КонецЕсли;
            КонецЦикла;
        КонецЦикла;
    КонецЕсли;
   Said_We
 
12 - 15.07.21 - 19:10
(11) Ещё бы КвикСорт прикрутил...
А если выгрузить эти строки куда-то, сортирануть и засунуть обратно?
   Гость из Мариуполя
 
13 - 15.07.21 - 20:04
(9) Да понятно, что никаких нарушений формально нет. И что формального такого требования к расчетному листку нет.
Но.. вот как сказать - есть, понимаешь, профессиональное отношение к делу, а есть ну.. скажем "на от..сь". Профессионализм - он ведь и в таких мелочах тоже ощущается ощущается.

Сам говоришь - журнал ведомостей к выплате, журнал кассовых документов или перечислений - все красиво. А расчетный листок - нет.
Во, нашел нужное слово - некрасиво.
То есть формальных требований нет, но.. сделано некрасиво. Учитывая, что еще с 7.7 приучИли к этой красоте.  

А так то да, согласен - нарушений нет.
   El_Duke
 
14 - 16.07.21 - 08:26
(13) "сделано некрасиво"

Некрасиво для кого ?
Я думаю что 90% сотров даже не обратит внимание на изменение порядка записей о выплатах, если им не ткнуть в них. Человека интересует сколько начислили/выплатили, а не порядок следования в листке. Красота - вопрос индивидуального восприятия

Ну если у автора нет более важных вопросов чем этот - можно им заняться. Но зачем ?
В следующем релизе заметят и поправят. Тратить время на такие доделки нет никакого смысла
   Target1025
 
15 - 16.07.21 - 18:36
(12) QuickSort эффективен начиная с 10 элементов, до 10 эл. пузырек обгоняет. А тут выплат у людей в месят обычно две - Аванс и ЗП. И оооочень редко три - Аванс, ЗП, Отпускные.
   Target1025
 
16 - 17.07.21 - 08:42
(14) Тут вопрос у расчетчиков возник, не у сотрудников.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.