Вход | Регистрация
 

УПП Поле объекта не обнаружено (Комиссионер)

УПП Поле объекта не обнаружено (Комиссионер)
Я
   Kongo2019
 
14.07.21 - 10:17
При проведении дока, расчет себестоимости получаю такую ошибку.

{ОбщийМодуль.УправлениеЗапасамиРасширеннаяАналитика.Модуль(2017)}: Поле объекта не обнаружено (Комиссионер)
                    Если ЗначениеЗаполнено(СтрокаДокумента.Комиссионер) Тогда

Зарылся в код.
ИначеЕсли ВидСубконто.ВидСубконто = ВидСубконтоКонтрагенты Тогда
                
                Контрагент = Неопределено;
                
                // Для товаров принятых субконто Контрагент - это комитент
                Если УправлениеЗапасамиПартионныйУчетФормированиеПроводокРегл.СчетВИерархии(Проводка.СчетКт, СчетТоварыПринятые, СтруктураПараметров) Тогда
                    
                    Если ЗначениеЗаполнено(СтрокаДокумента.ДоговорКомитента) Тогда
                        Контрагент = СтрокаДокумента.ДоговорКомитента.Владелец;
                    Иначе
                        Контрагент = Справочники.Контрагенты.ПустаяСсылка();
                    КонецЕсли;                        
                    
                Иначе
                    
                    Если ЗначениеЗаполнено(СтрокаДокумента.Комиссионер) Тогда
                        Контрагент = СтрокаДокумента.Комиссионер;
                    Иначе
                        Контрагент = Справочники.Контрагенты.ПустаяСсылка();
                    КонецЕсли;                        

                КонецЕсли;


Конкретно вот на этом условии.
Если ЗначениеЗаполнено(СтрокаДокумента.Комиссионер) Тогда
Контрагент = СтрокаДокумента.Комиссионер;
Иначе
Контрагент = Справочники.Контрагенты.ПустаяСсылка();
КонецЕсли;                    

То бишь где-то в доке пустой реквизит Комиссионер. Но у нас в принципе нет комиссионной торговли. И вообще ничего комиссионного.
Так вот как этот док найти? И если он вообще? Может Это сам УПП уже глючит?

Уже два часа голову ловама.
   mikecool
 
1 - 14.07.21 - 10:24
"
То бишь где-то в доке пустой реквизит Комиссионер. " - неверно, в строке нет реквизита
   Kongo2019
 
2 - 14.07.21 - 10:27
(1) Ну тогда шо? кривое обновление?
   mikecool
 
3 - 14.07.21 - 10:29
(2) все может быть. поставь точку останова и посмотри, что за документ в это условие прилетает, может его там просто нет
   Kongo2019
 
4 - 14.07.21 - 10:44
(3) Я их там уже три поставил, не попадаю я на точку остановки.
То бишь только отваливаюсь по ошибке.
   piter3
 
5 - 14.07.21 - 10:45
(4) Отладка включена точно?
   mikecool
 
6 - 14.07.21 - 10:50
(4) ессно, это же либо сервер(подключен?) , либо фоновое(подключены)
   Kongo2019
 
7 - 14.07.21 - 11:06
Сейчас нафиг выгружу в файловую. И все нафиг придушу.
   Адинэснег
 
8 - 14.07.21 - 12:28
ммм,рауз...

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.