Вход | Регистрация
 

В релизе 8.3.17.2300 БП 3.0.96.35 нельзя вводить номер ГТД с пробелом спереди. Почему?

В релизе 8.3.17.2300 БП 3.0.96.35 нельзя вводить номер ГТД с пробелом спереди. Почему?
Я
   Гений 1С
 
12.07.21 - 17:51
Если ввести с пробелом, ругается на уникальность.
Кто это обрезает - платформа или БП?
База на фреше, отладить не могу.
У них вся логика была на том, что группы ГТД создавались без пробела, элементы - с пробелами.
Зачем, не знаю, велосипед не мой.
Но вот из-за этого перестало работать.
   Гений 1С
 
1 - 13.07.21 - 09:25
Гм. Обновил у себя. Такая фишка идет с 3.0.96.30 релиза. Пока еще не докопал, почему.
Платформа не влияет. У меня посвежее платформа 8.3.18.1483, но на более ранних релизах давала записать ГТД с пробелом.
   Гений 1С
 
2 - 13.07.21 - 09:45
Обнаружил "Закладку" от 1С:

Ну зачем???? Кто пояснит мне этот светлый поток мысли методистов?

Процедура ПередЗаписью(Отказ)
    
    Если ОбменДанными.Загрузка Тогда
        Возврат;
    КонецЕсли;
    
    Если НЕ ЭтоГруппа Тогда
        Реквизиты = Справочники.НомераГТД.РегистрационныйНомерИСтранаВвоза(Код);
        ЗаполнитьЗначенияСвойств(ЭтотОбъект, Реквизиты, "РегистрационныйНомер,СтранаВвозаНеРФ");
        Код = СокрЛП(Код);
    КонецЕсли;
    
КонецПроцедуры
   Garykom
 
3 - 13.07.21 - 09:46
(0) >вся логика была на том, что группы ГТД создавались без пробела, элементы - с пробелами

ну так исправь архитектурную ошибку
   Гений 1С
 
4 - 13.07.21 - 09:46
(3) исправить конечно можно. Я не понимаю этих шараханий и "улучшальцев"
   DrZombi
 
5 - 13.07.21 - 09:47
(0) Смешно... :)
   Гений 1С
 
6 - 13.07.21 - 09:50
(5) И не говори. Придется переписывать чужие костыли, клиент попал на деньги.
   Chai Nic
 
7 - 13.07.21 - 10:03
(2) Объяснить просто. Сделано так, чтобы минимизировать ошибки, когда ГТД заносят тетеньки предпенсионного возраста, которые при слове "пробел" спрашивают "а что это такое?".
   Сурьма
 
8 - 13.07.21 - 10:04
(6) 1С даёт тебе возможность заработать, а ты ещё и не доволен. Странный ты...
   vis_tmp
 
9 - 13.07.21 - 10:15
(8) Возможно, это не самая интересная задача?
   BeerHelpsMeWin
 
10 - 13.07.21 - 10:21
(9) и как давно фрилансеров мелкого пошиба спрашивают, интересная для них задача или нет?
   Сурьма
 
11 - 13.07.21 - 10:27
(9) Так у него 99% задач таких.
   ДенисЧ
 
12 - 13.07.21 - 10:34
(0) Потому что дурацкие решения нужно искоренять до их реализации. А реализаторов - до рождения.
   Гений 1С
 
13 - 16.07.21 - 12:45
Написал по этому поводу статью: http://geniy1s.ru/1s-chto-ty-delaesh-s-gtd-prekrati/
   Ненавижу 1С
 
14 - 16.07.21 - 15:32
(13) зачем тебе камменты в бложике, если ты их трешь?

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.