Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не открывается ТТН из документа реализации товаров и услуг

Не открывается ТТН из документа реализации товаров и услуг
Я
   mihalich979
 
07.07.21 - 10:57
Всем привет

вчера обновили 1с
конфа КА 2.4.13.203

так вот в документе реализация товаров и услуг
в самом низу есть ссылки документов на основании (ТекстДокументыНаОснованииПодвал)

выглядят как ссылки.
примерно таким текстом:
Счет-фактура №123 от 01.01.21     ТТН №123 от 01.01.21    Оформить ТТН

счет-фактура открывается, а ттн не открывается.

причем если сделать две ттн, то там будет другая ссылка типа ТТН(2) - и по нажатию открывает список с двумя ттн

Куда копать подскажите... не пойму как в поиске такое поискать.
   ДенисЧ
 
1 - 07.07.21 - 11:03
Смотри событие ссылки при клике, что там делает.
   mihalich979
 
2 - 07.07.21 - 11:13
так в конфигураторе ссылки нет

это при открытии документа заполняется форматированная строка

вот код

// тут добавляется текст и ссылка по ТТН если она одна

Если Форма.КоличествоТранспортныхНакладных = 1 Тогда
            ТекстТТН = НСтр("ru='ТТН %СокращенноеНаименованиеТранспортнойНакладной%'");
            ТекстТТН = СтрЗаменить(ТекстТТН,
                        "%СокращенноеНаименованиеТранспортнойНакладной%",
                        Параметры.СокращенноеНаименованиеТранспортнойНакладной);
            
            Если ПараметрыТТН.Просмотр Тогда
                ТекстТТН = Новый ФорматированнаяСтрока(ТекстТТН,
                                    ,
                                    ОбщегоНазначенияВызовСервера.ЦветСтиля("ЦветГиперссылки"),
                                    ,
                                    ПолучитьНавигационнуюСсылку(Параметры.ТранспортнаяНакладная));
            КонецЕсли;
        Иначе
// тут добавляется текст и ссылка если ТТН две и более

            
            ТекстТТН = НСтр("ru = 'ТТН (%КоличествоТранспортныхНакладных%)'");
            ТекстТТН = СтрЗаменить(ТекстТТН, "%КоличествоТранспортныхНакладных%", Форма.КоличествоТранспортныхНакладных);
            
            Если ПараметрыТТН.Просмотр Тогда
                ТекстТТН = Новый ФорматированнаяСтрока(ТекстТТН,
                                                        ,
                                                        ОбщегоНазначенияВызовСервера.ЦветСтиля("ЦветГиперссылки"),
                                                        ,
                                                        "ОткрытьСписокТранспортныхНакладных");
            КонецЕсли;
        КонецЕсли;
   ДенисЧ
 
3 - 07.07.21 - 11:14
Так есть ссылка или нет? Что в конфигураторе в этом месте на форме? ТекстТТН куда потом присваивается?
   mihalich979
 
4 - 07.07.21 - 11:34
(3) в конфигураторе в форме на этом месте
поле надписи
Имя: ТекстДокументыНаОснованииПодвал

и ссылки в это поле заполняются при открытии документа.
   ДенисЧ
 
5 - 07.07.21 - 11:47
(4) А теперь посмотри на свойство этой надписи. Наверняка, стоит галка "гиперссылка". И прописан обработчик приклике (как он там называется, он один для гиперссылки)
   mihalich979
 
6 - 07.07.21 - 11:53
(5) галка не стоит
обработчик есть в нем все также как в предыдущей конфе.

только в конце чуть добавлено.// Локализация



Процедура ТекстДокументыНаОснованииОбработкаНавигационнойСсылки(Элемент, НавигационнаяСсылка, СтандартнаяОбработка)
    
    ОчиститьСообщения();
    
    ПараметрыРегистрации = ПараметрыРегистрацииСчетовФактурВыданныхСервер(Объект);
    УчетНДСУПКлиент.ОбработкаНавигационнойСсылкиСчетаФактурыВыданные(ЭтаФорма, НавигационнаяСсылка,  СтандартнаяОбработка, ПараметрыРегистрации);
    
    ПродажиКлиент.ОбработкаНавигационнойСсылкиТранспортныеНакладные(ЭтаФорма, НавигационнаяСсылка, СтандартнаяОбработка);
    
    ФискальнаяОперацияОбработкаНавигационнойСсылки(Элемент, НавигационнаяСсылка, СтандартнаяОбработка);

    //++ Локализация    

    ПараметрыРегистрацииУведомленийОПеремещении = ПараметрыРегистрацииУведомленийОПеремещенииПрослеживаемыхТоваровСервер(Объект);
    ПрослеживаемостьФормыКлиентПереопределяемый.ОбработкаНавигационнойСсылкиУведомленияОПеремещенииПрослеживаемыхТоваров(
        ЭтаФорма,
        НавигационнаяСсылка,
        СтандартнаяОбработка,
        ПараметрыРегистрацииУведомленийОПеремещении);
    //-- Локализация

    
КонецПроцедуры

надо ее закомментить попробовать в копии базы...
   ДенисЧ
 
7 - 07.07.21 - 11:57
ПродажиКлиент.ОбработкаНавигационнойСсылкиТранспортныеНакладные(...)

Вот сюда и смотри.
   mihalich979
 
8 - 07.07.21 - 11:59
закомментил - не помогло
   ДенисЧ
 
9 - 07.07.21 - 12:00
А почему должно помочь? Там же идёт обработка поиска ТТН )))
   mihalich979
 
10 - 07.07.21 - 12:01
(7) был я там
не обрабатывает там ссылку
вот код процедуры
список из нее открывает и создает новую .



Процедура ОбработкаНавигационнойСсылкиТранспортныеНакладные(Форма, НавигационнаяСсылка, СтандартнаяОбработка) Экспорт
        
    Если НавигационнаяСсылка = "ОткрытьСписокТранспортныхНакладных" Тогда
        
        СтандартнаяОбработка = Ложь;
        
        ОткрытьСписокТранспортныхНакладных(Форма);
        
    ИначеЕсли НавигационнаяСсылка = "СоздатьТранспортнуюНакладную" Тогда
        
        СтандартнаяОбработка = Ложь;
        
        СоздатьТранспортнуюНакладную(Форма);
        
    КонецЕсли;
    
КонецПроцедуры
   PaulBC
 
11 - 08.07.21 - 04:21
(0) https://releases.1c.ru/patches/total?nick=ARAutomation20&ver=2.4.13.203
EF_00_00372182 На форме документа Реализация товаров и услуг не работает гиперссылка для перехода к форме сформированного документа ТТН.
   mihalich979
 
12 - 08.07.21 - 09:33
я в конце процедуры добавил условие
если это ссылка на ТТН то

ПерейтиПоНавигационнойСсылке(<НавигационнаяСсылка>)
   mihalich979
 
13 - 08.07.21 - 09:34
(11) спасибо!

сделал костыль сам см. (12)

Список тем форума
 
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.