Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Автоматическое открытие периода

v7: Автоматическое открытие периода
Я
   OnePrg
 
05.07.21 - 08:37
РИБ, дочек порядка 300. Каждый месяц открывать период вручную на всех долго. Как это можно автоматизировать?
   ДенисЧ
 
1 - 05.07.21 - 08:40
а) написать кликер, который жмёт кнопки.
б) разобраться, что происходит при открытии месяца и запрограммировать это.
в) нанять стаю макак.
   Garykom
 
2 - 05.07.21 - 08:42
г) не пора ли уже перейти на 8-ку?
   NorthWind
 
3 - 05.07.21 - 08:42
(0) перейти в снеговика, там это реализовано :)
   OnePrg
 
4 - 05.07.21 - 08:43
(1) пункт б) подходит
вот такой код нарыл

Если ЭтоПервыйЗапуск = 0 Тогда
// не первый запуск

//Автоматическое открытие периода
ДатаТА=ПолучитьДатуТА();
Если (РабочаяДата()>ДатаТА)И
((ДатаМесяц(ДатаТА)<>ДатаМесяц(РабочаяДата()))ИЛИ(ДатаГод(ДатаТА)<>ДатаГод(РабочаяДата()))) Тогда
Если МонопольныйРежим()=0 Тогда
Ответ=Вопрос("Не открыт период!"+РазделительСтрок+
"Для открытия периода запустите программу в монопольном режиме!"+РазделительСтрок+
"Завершить работу программы?","Да+Нет");
Если Ответ="Да" Тогда
СтатусВозврата(0);
Возврат;
КонецЕсли;
Иначе// монопольный режим

Если ИмяПользователя()="УстановкаТА" Тогда
УстановитьТАна(ТекущаяДата());
Иначе
Ответ=Вопрос("Не открыт период!"+РазделительСтрок+
"Выполнить открытие периода?","Да+Нет");
Если Ответ="Да" Тогда
УстановитьТАНа(РабочаяДата());
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
   Василий Алибабаевич
 
5 - 05.07.21 - 08:43
(0) Вариант из издания "1С на селе и в городе" для режима "оперучет":
Запускать 1С из-под специального пользователя. В этом сеансе проверять
Если начМесяца(ТекущаяДата())>начМесяца(ПолучитьДатуТА()) ТОгда
  Если МонопольныйРежим()=0 Тогда
    Предупреждение("Для открытия нового периода необходимо
    |запустьить программу в монопольном режиме!");
    СтатусВозврата(0);
    Возврат;
  Иначе
    //30.09.18

    Если Вопрос("Открыть новый период", "Да+Нет") = "Да" Тогда
      УстановитьТАНА(ТекущаяДата());
      Предупреждение("Новый период открыт.
      |для продолжения нужно запустить программу в немонопольном режиме.");
    КонецЕсли;
  КонецЕсли;
КонецЕсли;
   ДенисЧ
 
6 - 05.07.21 - 08:44
(4) Умничка.
Тогда в чём вопрос?
   Андрей_Андреич
 
7 - 05.07.21 - 08:46
Только таймауты в вопросах и предупреждениях устанавливайте а то робот на кнопки жать не будет
   OnePrg
 
8 - 05.07.21 - 08:46
Всем спасибо! Разобрался.
   Злопчинский
 
9 - 05.07.21 - 11:19
(5) в общем случае - неправильно. период итогов м.б. отличный от месяца.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.