Вход | Регистрация
 

БП 3.0 Вид субконто ... не доступен для данной записи

БП 3.0    Вид субконто ... не доступен для данной записи
Я
   bvb
 
02.07.21 - 13:18
Был у меня на 50 добавлен субконто "Кассы" . После обновления слетела появляется ошибка :

Ошибка при выполнении обработчика - 'ОбработкаПроведения'
по причине:
Запись не верна! Вид субконто "Кассы" не доступен для данной записи! (Регистр бухгалтерии: Журнал проводок (бухгалтерский и налоговый учет); Номер строки: 1)
{Документ.ПриходныйКассовыйОрдер.МодульОбъекта(11)}:    Движения.Хозрасчетный.Записать();

по причине:
Запись не верна! Вид субконто "Кассы" не доступен для данной записи! (Регистр бухгалтерии: Журнал проводок (бухгалтерский и налоговый учет); Номер строки: 1)

В ПВХ "ВидыСубконтоХозрасчетные"   справочник отражен и в типи и виде предопределенных.
Что не так ?
   2S
 
1 - 02.07.21 - 13:21
Очисти перед заполнением
   bvb
 
2 - 02.07.21 - 13:24
(1) Что очистить ?
   RomanYS
 
3 - 02.07.21 - 13:27
(0) >> Что не так ?
Вид субконто слетел в конкретном счёте, по которому ты проводки делпешь
   bvb
 
4 - 02.07.21 - 13:34
(1) Дык я смотрю план счетов он есть там
   2S
 
5 - 02.07.21 - 13:55
(2) ты же программно пишешь, свой код?
вот субконто и очисти перед заполнением
   bvb
 
6 - 02.07.21 - 14:13
(3) нет не слетел . Движение.СчетДт.ВидыСубконто - он есть


(5) Я его программно заполнял в обработке расширения

&После("ОбработкаПроведения")
Процедура Расш1_ОбработкаПроведения(Отказ, Режим)
    
    Для Каждого Движение ИЗ Движения.Хозрасчетный Цикл
        Если Движение.СчетДт.Код = "50.01" Тогда
            Движение.СубконтоДт.Кассы = Касса;
        КонецЕсли;
    КонецЦикла;    
    
    Движения.Хозрасчетный.Записать();
    
    
КонецПроцедуры
   2S
 
7 - 02.07.21 - 14:16
(6) млять, не тупи
Это 100-летний баян. 
Движение.СубконтоДт.Кассы.Очистить();
В синтаксисе могу ошибиться
   bvb
 
8 - 02.07.21 - 14:41
(7) Не работает.
Я думал дело в расширении - выключил поставил в конце модуля нативного модуля проведения.

Для Каждого Движение ИЗ Движения.Хозрасчетный Цикл
        Если Движение.СчетДт.Код = "50.01" Тогда
                                 Движение.СубконтоДт.Очистить();
            Движение.СубконтоДт.Кассы = Касса;
        КонецЕсли;
    КонецЦикла;    
    
    Движения.Хозрасчетный.Записать();
   Kesim
 
9 - 02.07.21 - 15:28
отладчиком посмотри что у тебя в Движение.СубконтоДт
   bvb
 
10 - 02.07.21 - 15:59
Дело было не в бобине....

Во время обновления я забыл создать предопределенный элемент "Кассы" ПВХ "Виды субконто хозрасчетые"
Потом создал
Но Старый элемент который ранее был предопределенным стал просто элементом и на него смотрела настройка плана счетов.
Далее думаю понятно...
Помогло  что снял запрет редактирования субконто с счета 50.01 полез редактировать и сразу увидел лишние элементы ПВХ

Думаю мое п#страдание будет кому то полезно
Не создавайте дублей элементов ПВХ !

Думаю во избежание подобной пидерсии нужно создавать элемент либо на уровне ПВХ в БД ,либо на уровне конфы но в расширении

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.