Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Неверное имя реквизита

v7: Неверное имя реквизита
Я
   Asia2016
 
30.06.21 - 12:19
Документ авансовый отчет. При открытии (и не только) выдает ошибку "Неверное имя реквизита"
Процедура ПриОткрытии()
    глПроверкаРазрешенияРедактирования(Контекст);

    ПриЗаписиПерепроводить(1);
    Форма.КоррСчет.ВыборГруппы(0);
    Форма.ИспользоватьЗакладки(1);
    Форма.Закладки.ДобавитьЗначение(1,"Лицевая сторона");
    Форма.Закладки.ДобавитьЗначение(2,"Оборотная сторона");
    Форма.ИспользоватьСлой("Основной, Шапка",2);
    ПриУстановкеТипаОтчета();  
    ОстатокНаНачалоДня = 0;
    ОстатокНаКонецДня = 0;
        Если Пластик1 = 1 Тогда
            Сч55 = СчетПоКоду("55.40.1");
        ИначеЕсли Пластик2 = 1 Тогда     
            Сч55 = СчетПоКоду("55.40.2");  
        ИначеЕсли Пластик3 = 1 Тогда     
            Сч55 = СчетПоКоду("55.40.3");     
        ИначеЕсли Пластик4 = 1 Тогда     
            Сч55 = СчетПоКоду("55.40.4");
        ИначеЕсли Пластик5 = 1 Тогда     
            Сч55 = СчетПоКоду("55.40.5");
        ИначеЕсли Пластик6 = 1 Тогда     
            Сч55 = СчетПоКоду("55.40.6");     
        ИначеЕсли Пластик7 = 1 Тогда     
            Сч55 = СчетПоКоду("55.40.7");
        ИначеЕсли Пластик8 = 1 Тогда     
            Сч55 = СчетПоКоду("55.40.8");     
        ИначеЕсли Пластик9 = 1 Тогда     
            Сч55 = СчетПоКоду("55.40.9");
        Иначе
            Сч55 = СчетПоКоду("55.40.10");
        КонецЕсли;        
    ПриВыбореЗаписать();    
КонецПроцедуры

// Формирование платежных реквизитов по расчетному счету
Процедура глПроверкаРазрешенияРедактирования(Конт) Экспорт
    Если Конт.Выбран() = 1 Тогда
        Если (Конт.ДатаДок <= Константа.ДатаЗапретаРедактирования) и (Конт.Форма.ТолькоПросмотр() = 0) Тогда
            Конт.Форма.ТолькоПросмотр(1);
            Предупреждение("Разрешен только просмотр документа!", 4);
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры
   ДенисЧ
 
1 - 30.06.21 - 12:20
И что, даже на строку не ссылается, где ошибка?
   1Сергей
 
2 - 30.06.21 - 12:20
"Неверное имя реквизита" - это полный текст ошибки?
   Масянька
 
3 - 30.06.21 - 12:21
(1) (2) Мысли читать не умеют...
   Asia2016
 
4 - 30.06.21 - 12:21
   Asia2016
 
5 - 30.06.21 - 12:23
да полный текст. документ работает. но при нажатии например кнопки рассчитать по счету тоже выдает это же сообщение
   ДенисЧ
 
6 - 30.06.21 - 12:25
Значит, где-то на форме есть что-то. Проверяй все элементы формы
   Asia2016
 
7 - 30.06.21 - 12:25
   Масянька
 
8 - 30.06.21 - 12:26
(5) По любому счету?
   Asia2016
 
9 - 30.06.21 - 12:30
(8) да. последние изменения : включила сумму ндс и сумму с ндс
Процедура Перерасчет()   
    Если (Форма.ТекущаяКолонка() = "СтавкаНДС") Тогда
        НДС = ОКР(СуммаБНДС * СтавкаНДС.Ставка / 100,2);
        СуммаСНДС = СуммаБНДС + НДС;
    ИначеЕсли Форма.ТекущаяКолонка() = "СуммаБНДС" Тогда
        НДС = ОКР(СуммаБНДС * СтавкаНДС.Ставка / 100,2);
        СуммаСНДС = СуммаБНДС + НДС;
    ИначеЕсли Форма.ТекущаяКолонка() = "НДС" Тогда
        СуммаСНДС = СуммаБНДС + НДС;
    ИначеЕсли Форма.ТекущаяКолонка() = "СуммаСНДС" Тогда
        Если СтавкаНДС.Ставка <> 0 тогда
            НДС = ОКР(СуммаСНДС * СтавкаНДС.Ставка / (СтавкаНДС.Ставка + 100),2);
        Иначе
            НДС = 0;
        КонецЕсли;
        СуммаБНДС = СуммаСНДС - НДС;
    КонецЕсли;
КонецПроцедуры
   Asia2016
 
10 - 30.06.21 - 12:32
и добавила ставкундс. тип справочник
   Масянька
 
11 - 30.06.21 - 12:36
(9) Колонка "СтавкаНДС" есть?
   Asia2016
 
12 - 30.06.21 - 15:07
(11) да
   Asia2016
 
13 - 30.06.21 - 15:10
   Arbuz
 
14 - 30.06.21 - 15:35
Говорят же - это где-то в свойствах элемента формы. см (6)
   Масянька
 
15 - 30.06.21 - 15:42
(13) Код в (9) - все реквизиты в коде совпадают по названию с колонками?
   Масянька
 
16 - 30.06.21 - 15:43
+ (15) А вообще да: правда (6). Надо перебирать форму.
   HawkEye
 
17 - 30.06.21 - 15:56
(0)  все не читал... "КоррСчет" - есть на форме?
   FN
 
18 - 30.06.21 - 16:34
(10)и добавила ставкундс. тип справочник
укажи вид справочника, а не просто "Справочник"
   Asia2016
 
19 - 01.07.21 - 13:02
Спасибо. (15) вы правы.
названия не все совпадали

Список тем форума
 
Глупец, лишенный способности посмеяться над собой вместе с другими, не сможет долго выносить программирование.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.