Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка в коде

Ошибка в коде
Я
   iiwanc
 
29.06.21 - 13:07
Здравствуйте!
Прошу сильно не пинать. Только начинаю изучать программирование.
1С Предприятие 8.3.18.1289 Зарплата и кадры государственного учреждения 3.1.18.82

Имеется:
&НаСервере
Функция НапечататьТабДок()
    Значение = РеквизитФормыВЗначение("Объект");
    Массив = Новый Массив;
    Массив.Добавить(Новый Структура("Подразделение", Новый Структура("ГоловнаяОрганизация", Организация)));
    ТабДок = Значение.ПечатьШР(Массив, Неопределено);
КонецФункции

&НаКлиенте
Процедура ПечатьШР(Команда)
    НапечататьТабДок();
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    Если ЗначениеЗаполнено(Организация) Тогда
        НапечататьТабДок();
    КонецЕсли;
КонецПроцедуры

При запуске выдает:
{(375, 45)}: Поле не найдено
"СведенияОбОтветственныхЛицахСрезПоследних.ДолжностьРуководителя"
СведенияОбОтветственныхЛицахСрезПоследних.<<?>>ДолжностьРуководителя КАК ДолжностьРуководителя,

Подробнее:
{(357, 45)}: Поле не найдено "СведенияОбОтветственныхЛицахСрезПоследних.ДолжностьРуководителя"
СведенияОбОтветственныхЛицахСрезПоследних.<<?>>ДолжностьРуководителя КАК ДолжностьРуководителя,
{ВнешняяОбработка.LINT_ШтатноеРасписание.МодульОбъекта(673)}:    Результат = Запрос.Выполнить();
{ВнешняяОбработка.LINT_ШтатноеРасписание.Форма.Форма.Форма(6)}:    ТабДок = Значение.ПечатьШР(Массив, Неопределено);
{ВнешняяОбработка.LINT_ШтатноеРасписание.Форма.Форма.Форма(11)}:    НапечататьТабДок();

по причине:
{(357, 45)}: Поле не найдено "СведенияОбОтветственныхЛицахСрезПоследних.ДолжностьРуководителя"
СведенияОбОтветственныхЛицахСрезПоследних.<<?>>ДолжностьРуководителя КАК ДолжностьРуководителя,

Как понял, изменились имена ресурсов в регистре. Но не пойму что и где прописать. Должность ведь не прописывал.
Подскажите, пожалуйста.
Буду благодарен советам!
   ДенисЧ
 
1 - 29.06.21 - 13:08
Искать нужно в ПечатьШР() модуля объекта
   apdate by
 
2 - 29.06.21 - 13:20
&НаСервере
Функция НапечататьТабДок()
    Значение = РеквизитФормыВЗначение("Объект");
    Массив = Новый Массив;
    Массив.Добавить(Новый Структура("Подразделение", Новый Структура("ГоловнаяОрганизация", Организация)));
    ТабДок = Значение.ПечатьШР(Массив, Неопределено);
КонецФункции

установите курсор на ПечатьШР и нажмите  F12

полученный код изучайте на предмет того куда делось ДолжностьРуководителя  в запросе
   Neo58
 
3 - 29.06.21 - 13:22
Может вместо СведенияОбОтветственныхЛицахСрезПоследних.ДолжностьРуководителя надо СведенияОбОтветственныхЛицахСрезПоследних.Должность
   iiwanc
 
4 - 29.06.21 - 13:44
ДолжностьРуководителя теперь называется УдалитьДолжностьРуководителя
Но проблема на этом не решена. Многие регистры видимо изменены

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.