Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Вызов кода из внешней обработки

Вызов кода из внешней обработки
Я
   LazyCamel
 
28.06.21 - 21:25
Ситуация: есть некий общий модуль, в нем есть фрагмент кода. И этот фрагмент может вызываться как из конфигурации, так и из внешнего отчёта. Причём, если код вызывается из конфигурации, то поведение должно быть одно, а если из ВО - другое. Как определить, что вызов пришёл из ВО. Попробовал написать так "Если ТипЗнч(ОбъектОтчета) = Тип("ВнешнийОтчетОбъект.<Имя>", не работает, идёт ругань, что тип "ВнешнийОтчет.<Имя>" не зарегистрирован. Как побороть?
   acht
 
1 - 28.06.21 - 21:29
МояПроцедура(КучаПараметров, ВызовИзВнешнегоОтчета = Ложь) Экспорт

    Если ВызовИзВнешнегоОтчета Тогда
        // Вызов из внешнего отчета

    КонецЕсли;

КонецПроцедуры;
   acht
 
2 - 28.06.21 - 21:30
Потому как откуда ты вытаскиваешь свой ОбъектОтчета ну совершенно неизвестно
   acht
 
3 - 28.06.21 - 21:32
Если тебе надо отличить отчет, встроенный в конфигурацию от внешнего, то типа того:

Если Метаданные.НайтиПоТипу(ТипЗнч(ОбъектОтчета)) = Неопределено Тогда
    // Это внешний отчет

КонецЕсли;
   LazyCamel
 
4 - 28.06.21 - 21:35
(1) Спасибо, попробую.
(3) Угу, именно надо отличить.
   LazyCamel
 
5 - 29.06.21 - 09:35
(3)Сделал так, получилось. Спасибо, проблема исчерпана.

Список тем форума
 
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.