Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Операция введенная вручную

v7: Операция введенная вручную
Я
   Asia2016
 
28.06.21 - 14:03
% по кредитам разносили в операциях в ручную. для налога на прибыль создаю отчет по расходам. С документами проще, а операция вручную вроде как и не документ. Каким методом
можно выбрать нужную информацию из Операций?
   Davalebor
 
1 - 28.06.21 - 14:04
(0) Выбрать операции, затем выбрать проводки, обратиться к реквизитам проводки.
   Amra
 
2 - 28.06.21 - 14:06
(1) За такое надо руки отрубать по локоть)
   Davalebor
 
3 - 28.06.21 - 14:11
(2) норм )
Все равно ж не понятно чего нужно автору.
Какая информация для него является "нужной", какой у нее "отчет по расходам".
Судя по тому что "с документами проще", инфу для отчета автор берет из документов. Тогда и с операциями можно так же.
   Asia2016
 
4 - 28.06.21 - 14:18
https://ibb.co/PZp2nxm вот такой отчет.
   Asia2016
 
5 - 28.06.21 - 14:19
и здесь должны быть отображены расходы по % и кредитам. но данные занесены через операции.
   Asia2016
 
6 - 28.06.21 - 14:21
отчет формировали через запрос.  а с операциями ступор
   2S
 
7 - 28.06.21 - 14:22
(0) БИ
   Asia2016
 
8 - 28.06.21 - 14:32
(7) спасибо попробую. других вариантов нет ?
типа Расходы = Документ.Операция.ТекущийДокумент, но это не документ
   Asia2016
 
9 - 28.06.21 - 14:51
Опер = создатьобъект("Операция");
        Опер.ВыбратьПроводки(ВыбНачПериода,ВыбКонПериода);
            Пока Опер.Получитьпроводку()=1 Цикл 
                
                    ТЗ.НоваяСтрока();  
                    ТЗ.ПроизСклад     = Опер.СубконтоДт;
                    ТЗ.Сумма         = Опер.Сумма;
                    ТЗ.СчетСписания    = Опер.Дт;
                    ТЗ.ТипЗатрат    = Опер.Субконто3;
                    ТЗ.Материал        = Опер.Субконто2;   
                    ТЗ.Расходы        = Опер.Субконто4;
                
            КонецЦикла;
 выдает 
Опер.Выбратьпроводки();   
{Отчет.новый2.Форма.Модуль(269)}: Операция не выбрана!
   Cthulhu
 
10 - 28.06.21 - 20:17
ВыбратьОперацииСПроводками
   HawkEye
 
11 - 28.06.21 - 20:24
(0) операция в ручную - самый обычный документ....

(9) что за чушь? ))))
   HawkEye
 
12 - 28.06.21 - 20:26
(9) если создатьОбъект("Операции")
то и выбратьОперации()/ПолучитьОперацию()
   Asia2016
 
13 - 29.06.21 - 09:49
(11) для самого обычного документа могу сделать так
Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)

    |Период с ВыбНачПериода по ВыбКонПериода;
    |ДвижениеМБП = Документ.ДвижениеМБП.ТекущийДокумент; и т.д.
с Операцией введенной вручную это не работает
   mikecool
 
14 - 29.06.21 - 09:54
в 2021 году не знать про БухИтоги? не верю!
   vladmenleo
 
15 - 29.06.21 - 10:08
(13) ну если бухитоги использовать религоя не позволяет то как-то так
Док = СоздатьОбъект("Документ.Операция");
    Опер = СоздатьОбъект("Операция");
    Док.ВыбратьДокументы(ВыбНачПериода, ВыбКонПериода); 
    Пока Док.ПолучитьДокумент() = 1 Цикл
        ФлПишем = 0;
        Опер.НайтиОперацию(Док.ТекущийДокумент());  
        Опер.ВыбратьПроводки();
        Пока Опер.ПолучитьПроводку() = 1 Цикл
// тутделай,что хочешь

        КонецЦикла;
        Если ФлПишем = 1 Тогда
            Сообщить(Опер.Документ);
            Опер.Записать();
        КонецЕсли;
        //

    КонецЦикла;
   vladmenleo
 
16 - 29.06.21 - 10:08
(15) религия
   Asia2016
 
17 - 29.06.21 - 11:31
спасибо всем

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.