Вход | Регистрация
 

Как записать в ТЧ объекта элементы подставляемые перед записью на сервере?

Как записать в ТЧ объекта элементы подставляемые перед записью на сервере?
Я
   RomaH
 
23.06.21 - 12:21
Суть
на форме пользователь устанавливает несколько флагов в строке табличной части

по варианту выбранных флагов ПередЗаписьюНаСервере ищу/создаю элемент справочника и этот элемент надо записать в эту строку ТЧ

т.е. элемент я выбираю при обработке каждой строки Из Объект.ТабличнаяЧасть

а вот записать надо в ТекущийОбъект -  а вот в которую строку?
   RomaH
 
1 - 23.06.21 - 12:21
код:

    Для Каждого СтрокаТЧ Из Объект.СеткаПриема Цикл
        
        МассивРазрешенныхГрупп = Новый Массив;
        
        Для Каждого ЭлементСоответствия Из СоответствиеЭлементовГруппамПользователей Цикл
            
            Если СтрокаТЧ[ЭлементСоответствия.Ключ] Тогда
                МассивРазрешенныхГрупп.Добавить(ЭлементСоответствия.Значение);
            КонецЕсли;
            
        КонецЦикла;
        
        РазрешенныеГруппыПользователей = Справочники.НаборыГруппПользователей.ПолучитьНабор(МассивРазрешенныхГрупп);
        
        //СтрокаТекущегоОбъекта = ТекущийОбъект.СеткаПриема.НайтиПоИдентификатору(СтрокаТЧ.ПолучитьИдентификатор());

        
        СтрокаТЧ.РазрешенныеГруппыПользователей = РазрешенныеГруппыПользователей;
        
    КонецЦикла;
   RomaH
 
2 - 23.06.21 - 12:23
можно конечно очистить ТекущийОбъект.СеткаПриема
а потом добавить новые строки из объекта  .... но ?

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.