Вход | Регистрация
 

Преобразовать массив товаров в соответствие

Преобразовать массив товаров в соответствие
Я
   shavkat
 
22.06.21 - 10:36
Добрый день

Не могу придумать алгоритм, чтоб из массива номенклатур, сделать соответствие аналогов из этого массива.
в результате должен получится соответствие, т.е. пары аналогов из этого же массива
   Ёпрст
 
1 - 22.06.21 - 10:40
Это невозможно в текущей постановке вопроса
   Йохохо
 
2 - 22.06.21 - 10:46
если аналог тоже справочник.номенклатура то решения ни в какой постановке нет
   mistеr
 
3 - 22.06.21 - 11:26
(0) Где и как в базе хранятся аналоги?
   fisher
 
4 - 22.06.21 - 11:47
Тю! Дарю.
Квадратичное о большое, ну да ладно.
Аналоги = Новый Соответствие;
Для Каждого Номенклатура Из МассивНоменклатуры Цикл
   Для Каждого Аналог Из МассивНоменклатуры Цикл
      Если ЯвляетсяАналогом(Аналог, Номенклатура) Тогда
         Аналоги.Вставить(Номенклатура, Аналог);
      КонецЕсли;
   КонецЦикла;
КонецЦикла;


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.