Вход | Регистрация
 

Параметры выбора УТ 11.4.11.65

Параметры выбора УТ 11.4.11.65
Я
   Varlant1n
 
18.06.21 - 17:14
Здравствуйте, форумчане. Столкнулся с проблемой, решить которую никак не могу. В справочнике номенклатура есть дополнитлеьный реквизит "Пол". В запросе динамического списка на форме списка номенклатуры через вложенный запрос, вывел данные реквизит на форму. А так же на форме создал поле ввода "Пол" и прописал отбор динамического списка по данному полю. Теперь же задача следующая. Нужно в параметры выбора, которые открываются в поле ввода "Пол" оставить только поля, которые являются полом. Что я сделал на данный момент:

В модуле формы списка номенклатуры прописал код в процедуру "ПриОткрытии":

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    ДопРеквизитПол = ПолучитьДопРеквизиты("Пол");
    НовыйМассив = Новый Массив();
    НовыйМассив.Добавить(ДопРеквизитПол);
    НовыеЗначения = Новый ФиксированныйМассив(НовыйМассив);
    НовыйПараметр = Новый ПараметрВыбора("Отбор.Владелец", НовыеЗначения);
    НовыйМассив = Новый Массив();
    НовыйМассив.Добавить(НовыйПараметр);
    НовыеПараметры = Новый ФиксированныйМассив(НовыйМассив);
    Элементы.Пол.ПараметрыВыбора = НовыеПараметры;
    //
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьДопРеквизиты(Имя)
    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ РАЗЛИЧНЫЕ
        |    ЗначенияСвойствОбъектов.Владелец КАК Владелец
        |ИЗ
        |    Справочник.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
        |ГДЕ
        |    ЗначенияСвойствОбъектов.Владелец.Имя = &Имя";
    Запрос.УстановитьПараметр("Имя", Имя);
    РезульатЗапроса = Запрос.Выполнить();
    Выборка = РезульатЗапроса.Выбрать();
    
    Пока Выборка.Следующий() Цикл
         Возврат Выборка.Владелец;
    КонецЦикла;
    
КонецФункции


Но ничего не срабатывает. СИжу уже целый день. и так и сяк через отладчик пробежал, вроде бы все нормально. Но при открытии выбора в поле воода, открывается весь список, где есть и другие доп реквизиты. В чем может быть проблема?

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.