Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Не отображается валюта в договоре на форме

v7: Не отображается валюта в договоре на форме
Я
   maksimiich
 
17.06.21 - 08:59
Ребят нужна помощь, не отображается валюта в договоре на форме, хотя в конфиге все есть, в чем беда может быть? только не пишите вот это свое: позови программиста)

https://prnt.sc/15oeltq

https://prnt.sc/15of62c
   ДенисЧ
 
1 - 17.06.21 - 09:02
Нужно позвать программиста, который скажет, на каком условии отключается эта видимость.
Это не 8ка, где рулят всякие условные и прочие оформления и пользовательские видимости.
Это явно или в коде прописано, или в свойствах элементов формы.
   РусскийВедун
 
2 - 17.06.21 - 09:03
(1) Может слой невидим на котором реквизиты.
   ДенисЧ
 
3 - 17.06.21 - 09:04
(2) Это входит в "свойства элементов формы"
   serpentt
 
4 - 17.06.21 - 09:04
(2) +
   evorle145
 
5 - 17.06.21 - 09:06
(2) да, сто пудово. Лет 17 назад кажется сталкивался с такой же проблемой.
   Хряк
 
6 - 17.06.21 - 09:08
Если (Константа.ВалютныйУчет = Да) или (ПустоеЗначение(ВалютаДоговора) = 0) Тогда
        Если Наименование <> глИмяДоговораДляПлатежейБезДоговора Тогда
            Форма.ИспользоватьСлой("ВалютныйУчет", 1);
        КонецЕсли;
        Если ПустоеЗначение(ВалютаДоговора) = 0 Тогда
            ЦеныВДоговоре = 2;
        Иначе
            ЦеныВДоговоре = 1
        КонецЕсли;
        
        УправлениеДиалогом();
    КонецЕсли;
   maksimiich
 
7 - 17.06.21 - 09:23
(6)////////////////////////////////////////////////////////////////////////////////

// ПЕРЕМЕННЫЕ МОДУЛЯ
//

Перем СписокВременныхЕдиницРасчета;

//******************************************************************************

// ПриВыбореТипаЦенВДоговоре()
//

// Параметры:
//  Нет.

//
// Вызывается из формул элементов диалога:

//    Переключатель "Цены в договоре...".
// 

// Описание:
//  Если цены в договоре в рублях, то становится невозможным указать оплату 

// договора в валюте.
//       



Процедура ПриВыбореТипаЦенВДоговоре()
    
    Если ЦеныВДоговоре = 1  Тогда
        Если ПустоеЗначение(ВалютаДоговора) = 0 Тогда
            ВалютаДоговора = "";
        КонецЕсли;
        Форма.ВалютаДоговора.Доступность(0);
        Если ОплатаДоговора <> 1 Тогда
            ОплатаДоговора = 1;
        КонецЕсли;
        Форма.ОплатаДоговораВал.Доступность(0);
        
    Иначе
        Если ПустоеЗначение(ВалютаДоговора) = 1 Тогда
            ВалютаДоговора = Константа.ОсновнаяВалюта;
        КонецЕсли;
        Форма.ВалютаДоговора.Доступность(1);
        Форма.ОплатаДоговораВал.Доступность(1)
    КонецЕсли;
    
КонецПроцедуры// ПриВыбореТипаЦенВДоговоре() 



//******************************************************************************

// Предопределенная процедура
//

Процедура ПриОткрытии()
    
    Форма.ИспользоватьСлой("Основной", 2);
    Если Наименование = глИмяДоговораДляПлатежейБезДоговора Тогда
        Форма.ДатаВозникновенияОбязательства.Видимость(0);
        Форма.ПодписьДатаВозникновенияОбязательства.Видимость(0);
        Форма.ДатаПогашенияОбязательства.Видимость(0);
        Форма.ПодписьДатаПогашенияОбязательства.Видимость(0);
        
    Иначе
        Форма.ИспользоватьСлой("ШтрафныеСанкции", 1);
    КонецЕсли;
        
    Если (Константа.ВалютныйУчет = Да) или (ПустоеЗначение(ВалютаДоговора) = 0) Тогда
        Если Наименование <> глИмяДоговораДляПлатежейБезДоговора Тогда
            Форма.ИспользоватьСлой("ВалютныйУчет", 1);
        КонецЕсли;
        Если ПустоеЗначение(ВалютаДоговора) = 0 Тогда
            ЦеныВДоговоре = 2;
        Иначе
            ЦеныВДоговоре = 1
        КонецЕсли;
        ПриВыбореТипаЦенВДоговоре();
    КонецЕсли;    

    СписокВременныхЕдиницРасчета = СоздатьОбъект("СписокЗначений");
    СписокВременныхЕдиницРасчета.ДобавитьЗначение("День");
    СписокВременныхЕдиницРасчета.ДобавитьЗначение("Рабочий день");
    СписокВременныхЕдиницРасчета.ДобавитьЗначение("Неделя");
    СписокВременныхЕдиницРасчета.ДобавитьЗначение("Месяц");
    
КонецПроцедуры// ПриОткрытии()


//*****************************************************************************

// Предопределенная процедура
//

Процедура ВводНового()
    
    АвтоОбработкаНДС=1;
    ОплатаДоговора = 1;
    
КонецПроцедуры

//*****************************************************************************

// Предопределенная процедура
//


Процедура ПриНачалеВыбораЗначения(ЭлементДиалога, Флаг)
    
    Если ЭлементДиалога = "ВременнаяЕдиницаРасчетаШтрафныхСанкций" Тогда
        Флаг = 0;
        ВыбраннаяВременнаяЕдиницаРасчета = СокрП(ВременнаяЕдиницаРасчетаШтрафныхСанкций);
        Если СписокВременныхЕдиницРасчета.ВыбратьЗначение(ВыбраннаяВременнаяЕдиницаРасчета,,,, 2) = 1 Тогда
            ВременнаяЕдиницаРасчетаШтрафныхСанкций = ВыбраннаяВременнаяЕдиницаРасчета;
        КонецЕсли;
    КонецЕсли;

КонецПроцедуры//ПриНачалеВыбораЗначения()


//******************************************************************************

// Предопределенная процедура
//

Процедура ПриЗаписи()
    
    Если (ЦеныВДоговоре = 2) и (ПустоеЗначение(ВалютаДоговора) = 1) Тогда
        Предупреждение("Введите валюту договора или поставьте переключатель 
                        |""Цены в договоре"" в положение ""в рублях""");
        СтатусВозврата(0);
        Возврат;
    КонецЕсли;
    Если (ЦеныВДоговоре = 2) и (ОплатаДоговора = 2) Тогда
        Предупреждение("Книга покупок по валютным договорам автоматически не формируется.");   
        АвтоОбработкаНДС=0;
    КонецЕсли;  
КонецПроцедуры// ПриЗаписи()
   maksimiich
 
8 - 17.06.21 - 09:40
есть идентичная бд с идентичным кодом и формой и в ней все открывается, а в этой не показывает валюты, парадокс
   Масянька
 
9 - 17.06.21 - 10:19
(8) Парадокс - это когда смотришь в книгу (код), а видишь (ну, сам понимаешь).
В (2) написали про слои. Сто пудово то, что обведено на первом скрине, входит в слой "ВалютныйУчет".
   Масянька
 
10 - 17.06.21 - 10:40
(8) Ты к программированию (вообще) отношение имеешь?
   Bigbro
 
11 - 17.06.21 - 10:42
Если (Константа.ВалютныйУчет = Да) или (ПустоеЗначение(ВалютаДоговора) = 0) Тогда
        Если Наименование <> глИмяДоговораДляПлатежейБезДоговора Тогда
            Форма.ИспользоватьСлой("ВалютныйУчет", 1);
        КонецЕсли;


тут же все написано.
проверяйте константу, проверяйте валюту, наименование.
запишите договор для начала он у вас кажется не записан еще.
   Злопчинский
 
12 - 17.06.21 - 11:55
Если проблема не решена - стучись оперативно в скайп Zlopun, подключусь, порешаем.
   maksimiich
 
13 - 17.06.21 - 12:35
все решено, всем спасибо
   Bigbro
 
14 - 17.06.21 - 12:51
что было то в итоге?

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.