Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Вопрос касательно движения в КА-2

↓ [Фрэнки, 17.06.21 - 07:42]
Вопрос касательно движения в КА-2
Я
   1C_Patriot
 
17.06.21 - 06:51
Доброго времени суток!

Подскажите логику этого запроса в событии ПередЗаписью, что находиться в модуле регистра накопления ДетализацияПартийТоваровДляНДСиУСН. А то смотрю и не пойму в чем прикол, не видно чтобы результат запроса куда то возвращался?

Процедура ПередЗаписью(Отказ, Замещение)
    
    Если ОбменДанными.Загрузка
     ИЛИ УниверсальныеМеханизмыПартийИСебестоимости.ДвиженияЗаписываютсяРасчетомПартийИСебестоимости(ЭтотОбъект) Тогда
        Возврат;
    КонецЕсли;
    
    ОбновлениеИнформационнойБазы.ПроверитьОбъектОбработан(ЭтотОбъект);
    
    УниверсальныеМеханизмыПартийИСебестоимости.СохранитьДвиженияСформированныеРасчетомПартийИСебестоимости(ЭтотОбъект, Замещение);
    
    Если ПланыОбмена.ГлавныйУзел() <> Неопределено
     ИЛИ НЕ ДополнительныеСвойства.Свойство("ДляПроведения") Тогда
        Возврат;
    КонецЕсли;
    
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    *
    |ПОМЕСТИТЬ ДетализацияПартийТоваровДляНДСиУСНПередЗаписью
    |ИЗ
    |    РегистрНакопления.ДетализацияПартийТоваровДляНДСиУСН КАК ДетализацияПартийТоваровДляНДСиУСН
    |ГДЕ
    |    ДетализацияПартийТоваровДляНДСиУСН.Регистратор = &Регистратор";
    
    СтруктураВременныеТаблицы = ДополнительныеСвойства.ДляПроведения.СтруктураВременныеТаблицы;
    
    Запрос.МенеджерВременныхТаблиц = СтруктураВременныеТаблицы.МенеджерВременныхТаблиц;
    Запрос.УстановитьПараметр("Регистратор", Отбор.Регистратор.Значение);
    
    Запрос.Выполнить();

КонецПроцедуры
   1C_Patriot
 
1 - 17.06.21 - 06:55
Все понял, спасибо. Тема закрыта!

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.