Вход | Регистрация
 

Zero-строка в макете 1С

Zero-строка в макете 1С
Я
   Гений 1С
 
14.06.21 - 11:24
Есть такое в MXL, что если значение параметра не заполнено, строка не выводится?
   ДенисЧ
 
1 - 14.06.21 - 11:29
нет
   fisher
 
2 - 14.06.21 - 11:32
MXL со встроенной логикой называется СКД.
   acht
 
3 - 14.06.21 - 11:36
Ну ладно там odata. Но mxl, Геня, mxl которому 100500 лет, можно было изучить-то?
Чем дальше тем тупее.
   acanta
 
4 - 14.06.21 - 11:51
Вы еще спросите есть ли в mxl включение фильтра в заголовках колонок..
   mistеr
 
5 - 14.06.21 - 14:10
(0) Что есть "строка"?
   Aleksey
 
6 - 14.06.21 - 14:30
И группировка строк как в екселе
   Ненавижу 1С
 
7 - 14.06.21 - 15:53
(5) геня мастер постановки задач, жаль вокруг одни буквоеды
   Chameleon1980
 
8 - 14.06.21 - 15:57
(7) точно - мастер
о чем спросил?
   Ненавижу 1С
 
9 - 14.06.21 - 15:58
(8) это знает только автор вопроса, но и это не точно
   Chameleon1980
 
10 - 14.06.21 - 16:06
в строке может быть много параметров
в области
   Chameleon1980
 
11 - 14.06.21 - 16:06
или что?
   Гений 1С
 
12 - 14.06.21 - 19:07
(8) (9) что в вопросе не понятно?
   acht
 
13 - 14.06.21 - 19:10
(12) Ноль бит, буквоеды, ггг. Правильно я говорю, Геня?
   Гений 1С
 
14 - 14.06.21 - 19:13
(13) 0 бит
   acht
 
15 - 14.06.21 - 19:13
(14) Ой, прости. А остальное правильно, да? Может быть там регистр у букв "Г" поправить?
   Гений 1С
 
16 - 14.06.21 - 19:18
(15) не засоряй эфир
   acht
 
17 - 14.06.21 - 19:27
(16) "не засоряй эфир", записал, спасибо, буду использовать.
Что-то еще?
   ДенисЧ
 
18 - 14.06.21 - 19:52
(13) (14) ноль или нуль? ))
   lodger
 
19 - 14.06.21 - 22:59
(18) сказано 0, значит 0!
   Ёпрст
 
20 - 15.06.21 - 00:01
(19) ноль, или ноль факториал ? Уточните
   acht
 
21 - 15.06.21 - 00:22
(20) > ноль факториал
буквоеды!
0 бит, ггг, не засоряй эфир! Что в вопросе не понятно?

Гм. А быть гением так просто, оказывается.
   Chameleon1980
 
22 - 15.06.21 - 05:12
нее. не просто.
чтобы задавать такие вопросы нужны:
талант,
смелость

как минимум
   BeerHelpsMeWin
 
23 - 15.06.21 - 06:24
(21) >А быть гением так просто, оказывается.
Статью написал? Обработку на инфостарт выложил? То-то же, до настоящего Гени ещё работать и работать!
   RomaH
 
24 - 15.06.21 - 07:19
Если Найти(ОбластьМакета.Представление,"Обязательно") > 0 Тогда
            ТабличныйДокумент.Вывести(СоответствиеОбластейМакета[ОбластьМакета.Представление]);
        Иначе 
            
            ВыводитьОбласть = Ложь;
            
            Для Каждого ПараметрОбласти Из СоответствиеОбластейМакета[ОбластьМакета.Представление].Параметры Цикл
                Если ЗначениеЗаполнено(ПараметрОбласти) Тогда
                    ВыводитьОбласть = Истина;
                    Прервать;
                КонецЕсли;
            КонецЦикла;
                
            Если ВыводитьОбласть Тогда
                
                Если Найти(ОбластьМакета.Представление,"_ВСтроку") > 0 Тогда
                    
                    Если Не НачатВыводВСтроку Тогда
                        ОбластьПриемникВСтроку = СоответствиеОбластейМакета[ОбластьМакета.Представление];    
                    КонецЕсли;
                    
                    ТабличныйДокументПриемникВСтроку.Вывести(СоответствиеОбластейМакета[ОбластьМакета.Представление]);
                    НачатВыводВСтроку = Истина;
                    
                ИначеЕсли НачатВыводВСтроку Тогда
                    
                    МассивСтрок = Новый Массив;
                    
                    Для Ш = 1 По ТабличныйДокументПриемникВСтроку.ВысотаТаблицы Цикл
                        МассивСтрок.Добавить(ТабличныйДокументПриемникВСтроку.Область(Ш,1,Ш,1).Текст);    
                    КонецЦикла;
                    
                    ОбластьПриемникВСтроку.Область(1,1,1,1).Текст = СтрСоединить(МассивСтрок,"; ");
                    
                    ТабличныйДокумент.Вывести(ОбластьПриемникВСтроку);

                    НачатВыводВСтроку = Ложь;
                    ТабличныйДокументПриемникВСтроку = Новый ТабличныйДокумент;
                    
                    ТабличныйДокумент.Вывести(СоответствиеОбластейМакета[ОбластьМакета.Представление]);
                    
                Иначе
                    ТабличныйДокумент.Вывести(СоответствиеОбластейМакета[ОбластьМакета.Представление]);
                    НачатВыводВСтроку = Ложь;
                КонецЕсли;
                
            КонецЕсли;
            
        КонецЕсли;
        
    КонецЦикла;
   acht
 
25 - 15.06.21 - 08:10
(23) Да, тут недоработка, ты прав. Я пока там просто забаненный. Надо исправляться.
   fisher
 
26 - 15.06.21 - 09:11
(25) > Я пока там просто забаненный
Как достиг?


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.