Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Установка сервера 1С под Linux - не удается установить libwebkitgtk-3.0-0 на Ubuntu 20.4

Установка сервера 1С под Linux - не удается установить libwebkitgtk-3.0-0 на Ubuntu 20.4
Я
   СЕсин
 
12.06.21 - 16:52
Уважаемые линуксоиды, просьба помочь. Пытаюсь установить сервер 1С:Предприятие 8.3.18.1334 на виртуальной машине KVM. И хост и гость - Ubuntu Server 20.04, но до установки дистрибутива 1С не дошел, застрял на установке пакета: libwebkitgtk-3.0-0, пишет:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package libwebkitgtk-3.0-0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libwebkitgtk-3.0-0' has no installation candidate

Делаю все по инструкции:
https://losst.ru/ustanovka-servera-1s-na-ubuntu-20-04
http://renbuar.blogspot.com/2020/04/ubuntu-2004-libwebkitgtk-30.html

Пробовал устанавливать пакеты вручную, но вручную тоже не получилось, застрял на установке другого пакета libenchant1c2a

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package libenchant1c2a

При этом когда я пробовал неделю назад то же самое на Ubuntu Desktop 20.04, все получилось четко по инструкции. Сейчас все делаю через консоль на Ubuntu Server 20.04 и к моему удивлению тот же порядок действий не срабатывает.
Подскажите пожалуйста, если кто сталкивался.
   arsik
 
1 - 12.06.21 - 16:56
(0) Может версия 3.0-0 уже неактуальна?
Посмотри что есть?
>apt search libwebkitgtk
Ну или как там у вас у дебианщиков.
   arsik
 
2 - 12.06.21 - 17:06
   Бишбармак
 
3 - 12.06.21 - 17:29
   СЕсин
 
4 - 13.06.21 - 12:51
Извиняюсь за долгий ответ.
(2) к сожалению ничего из перечисленного не сработало.
(3) это видел, но не понял. Т.к. там чувак пишет, что не мог установить libwebkitgtk-3.0-0, но потом "По описанию в уроке решил вышеуказанную проблему, но после этого...". Т.е. вопрос про другое, а установку libwebkitgtk он как-то решил, но не пишет как.
Я вот что думаю, может libwebkitgtk-3.0-0 нужен только для клиентской части? И мне нет смысла её устанавливать на сервер, где будет только серверная часть 1С?
Возможно с этим как-то связано, что на Ubuntu Desktop все получилось. Буду пробовать установить сервер без этого пакета, посмотрим что получится.
   Turku
 
5 - 13.06.21 - 14:37
(0) Для начала я бы отказался от бубунты, ибо спайварь.
https://blog.desdelinux.net/en/richard-stallman-tilda-from-spyware-to-ubuntu/
Лучше использовать Debian, ИМХО.
Также отказался бы от KVM, ибо потери производительности для 1С.
   arsik
 
6 - 13.06.21 - 17:11
(5) Debian - слишком консервативен. Старая пакетная база. Центось наше все.
   ansh15
 
7 - 13.06.21 - 19:00
>> Центось наше все
Ну да...
До 24-года платформа(1С), наверное, досидит на 7-й редакции, а что дальше - фиг знает.
   arsik
 
8 - 13.06.21 - 21:50
(7) Не понимаю в чем проблема. Что там в 25?
   Turku
 
9 - 13.06.21 - 22:28
(8) Кентось рулит, это да. Вернее, рулила. Пока они не похерили 8-ю версию. Был слух, что много разработчиков покинули проект (то бишь поддержка может быть так себе), поэтому вопрос, насколько целесообразно для новых инсталляций использовать Centos 7. Да, она на поддержке до 2024. Конечно, в 2025 работать оно не перестанет.
   arsik
 
10 - 13.06.21 - 22:35
(9) Ну какие там разработчики, в основном они же занимаются вырезанием красношляпочного проприетарного софта. На крайняк можно использовать ту же оракловскую сборку. Да и не думаю, что с 8й версией что то изменится.
   ansh15
 
11 - 09.07.21 - 11:00
Осталось дождаться платформы 8.3.20, там снята зависимость от libwebkitgtk-3.0-0.
   shotsdv2008
 
12 - 09.07.21 - 20:34
(6) Зато всё работает.
   arsik
 
13 - 09.07.21 - 22:32
(12) Ну так в центоси тоже все работает. И без бубнов.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.