Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Поле объекта не доступно для записи в табличной части

Поле объекта не доступно для записи в табличной части
Я
   anshnine
 
11.06.21 - 08:06
Тема банальная, но с табличной частью найти не смог. Есть форма списка. Есть событие ДокументСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

На форму списка добавил новую колонку , ссылающуюся на реквизит документа . Хочу при открытии формы , чтобы заполнялась для чтения данная колонка.
Делаю запрос на получение требуемых данных
Запрос = Новый Запрос;
    Запрос.Текст= "ВЫБРАТЬ
    |    УстановкаЦенНоменклатуры.Ссылка
    |ИЗ
    |    Документ.УстановкаЦенНоменклатуры КАК УстановкаЦенНоменклатуры
    |ГДЕ
    |    УстановкаЦенНоменклатуры.Товары.ДокументПоступления = &ДокументПоступления";
    Запрос.УстановитьПараметр("ДокументПоступления", ДанныеСтроки.Ссылка)  ;
    Результат = Запрос.Выполнить().Выгрузить();
После этого пытаюсь изменить колонку
Для Каждого Строка Из Результат Цикл
        Элемент.ТекущиеДанные.ДокументУстановкиЦен  =Строка.ссылка;
КонецЦикла;
И выходит ошибка.Собственного перепробовал многие вариации с ПолучитьОбъект() , но видимо нужную так и не смог найти.Подскажите пожалуйста как правильно сделать. У самой табличной части тип ДокументСсылка.УстановкаЦенНоменклатуры
   ДенисЧ
 
1 - 11.06.21 - 08:09
Делаешь неправильно практически всё.
1. Нужно в ПРиПолученииДанных
2. Запрос нужно делать по тем элементам, что есть в ОформленияСтрок
3. Текст нужно писать в соответсвующее оформление из ОформленияСтрок
   anshnine
 
2 - 11.06.21 - 08:16
(1) если честно , не совсем понимаю как работать через оформлениестрок. Если через данные строки можно обратиться к нужным данным , то тут я не уже не въезжаю в идею http://i.prntscr.com/tZc-qvt-QuCJkgwwOD8STA.png
   ДенисЧ
 
3 - 11.06.21 - 08:22
(2) ОформленияСтрок[0].ДанныеСтроки - чем плох вариант? По мне - так очень даже...
   anshnine
 
4 - 11.06.21 - 08:38
(3) Чтобы дед не варил,все равно самогон получается ) Передал под оформление строк ,  но получилось все тоже самое.Я видимо уперся в то, что уже написал до этого , и не хочу смотреть в другую сторону

Процедура ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок)
    
    Для Каждого ОформлениеСтрок из ОформленияСтрок Цикл
    Запрос = Новый Запрос;
    Запрос.Текст= "ВЫБРАТЬ ПЕРВЫЕ 1
    |    УстановкаЦенНоменклатуры.Ссылка
    |ИЗ
    |    Документ.УстановкаЦенНоменклатуры КАК УстановкаЦенНоменклатуры
    |ГДЕ
    |    УстановкаЦенНоменклатуры.Товары.ДокументПоступления = &ДокументПоступления";
    Запрос.УстановитьПараметр("ДокументПоступления", ОформлениеСтрок.ДанныеСтроки.Ссылка)  ;
    Результат = Запрос.Выполнить().Выгрузить();
    Для Каждого Строка Из Результат Цикл
        ОформлениеСтрок.ДанныеСтроки.ДокументУстановкиЦен  =Строка.ссылка;
    КонецЦикла;
    КонецЦикла;
КонецПроцедуры
   ДенисЧ
 
5 - 11.06.21 - 08:42
(4) А если закладывать не дрожжи и сахар, а курицу и морковку - может получиться бульон...

Процедура ПриПолученииДанных(Элемент, ОформленияСтрок)
  Для каждого оф из ОформленияСтрок Цикл
   оф.Колонки.ДокументУстановкицен.УстановитьТекст("А вот я, документ цен!");
  КонецЦикла;
КонецПроцедуры
   anshnine
 
6 - 11.06.21 - 08:57
(5) Все бы ничего ,но к колонкам через оф не выходит  обращаться , да и в принципе желательно , чтобы именно ссылки были , для возможности провалиться в документ , а не просто текст http://i.prntscr.com/wQPHURDpQNyMHW2t1CbpjQ.png . В любом случае спасибо за помощь.
   ДенисЧ
 
7 - 11.06.21 - 09:00
(6) Какая, к Морготу, ссылка в колонке в форме списка? Ты ещё не проснулся?
   anshnine
 
8 - 11.06.21 - 09:07
(7) Враг одурманил меня , никогда об этом и не думал , что их там нельзя размещать , к своему невежеству
   anshnine
 
9 - 11.06.21 - 09:20
Так или иначе метод установитьтекст не могу использовать
   ДенисЧ
 
10 - 11.06.21 - 09:23
(9) Надо как-то себя заставлять... сотни тысяч 1сником делают это и ты сможешь!
   anshnine
 
11 - 11.06.21 - 09:40
(10)Да уж , надо было чуть шире глянуть. В моем случае не колонки , а ячейки , и через них уже можно устанавливать текст.Спасибо большое за помощь

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.