Вход | Регистрация
 

Клиент-банк:неверный ИДПервичногоДокумента в загружаемом файле-ожидается не пустой GUID

Клиент-банк:неверный ИДПервичногоДокумента в загружаемом файле-ожидается не пустой GUID
Я
   РБ
 
10.06.21 - 11:55
Пришло подтверждение на открытие лицевых счетов, загрузить не могу
ошибка в сабже
С виду XML выглядит, как надо, ИДПервичногоДокумента не пустой.
Какой вид должен быть этого значения?

У меня вот такой:
12345678-9055-541714978
Этот номер из инструкции СБ для заполнения реестра через их екселевский файл

а во всех инструкциях 1С это значение выглядит иначе:
ИдПервичногоДокумента="7ac2aa03-a863-4847-83a9-adb6b6bd4d24">

Звонила девчуля из СБ-уверяет, что это у меня в 1С настройки неверные..
   РБ
 
1 - 10.06.21 - 12:02
кажется разобралась...
1С ищет вот такой формат
Проверяет, является ли строка уникальным идентификатором.
// В качестве уникального идентификатора предполагается строка вида

// "XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX", где X = [0..9,a..f].
//

// Параметры:
//  Значение - Строка - проверяемая строка.

//
// Возвращаемое значение:

//  Булево - Истина, если переданная строка является уникальным идентификатором.
//

Функция ЭтоУникальныйИдентификатор(Знач Значение) Экспорт
    
    Шаблон = "XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX";
    
    Если СтрДлина(Шаблон) <> СтрДлина(Значение) Тогда
        Возврат Ложь;
    КонецЕсли;
    Для Позиция = 1 По СтрДлина(Значение) Цикл
        Если КодСимвола(Шаблон, Позиция) = 88// X

            И ((КодСимвола(Значение, Позиция) < 48 Или КодСимвола(Значение, Позиция) > 57)// 0..9

            И (КодСимвола(Значение, Позиция) < 97 Или КодСимвола(Значение, Позиция) > 102)// a..f

            И (КодСимвола(Значение, Позиция) < 65 Или КодСимвола(Значение, Позиция) > 70))// A..F

            Или КодСимвола(Шаблон, Позиция) = 45 И КодСимвола(Значение, Позиция) <> 45 Тогда// -

                Возврат Ложь;
        КонецЕсли;
    КонецЦикла;

а клиент отправлял список сотрудников не из 1С, а из екселя сберовского, вот ИД и причепился не 1С-овский

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.