Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

БСП 3.1.4.252 - Ошибка печати "Внешние обработки"

БСП 3.1.4.252 - Ошибка печати "Внешние обработки"
Я
   serg999
 
04.06.21 - 11:17
Добрый день.

До последнего обновления БСП, внешние печатные формы нормально работали, не могу понять, что не так

Получатся из ОбщаяФорма.ПечатьДокументов.Форма.СоздатьРеквизитыИЭлементыФормыДляПечатныхФорм(КоллекцияПечатныхФорм = ТаблицаЗначений) вываливается в ОбщийМодуль.УправлениеПечатьюМультиязычность.Модуль.ЯзыкиМакета(ПутьКМакету = "ПФ_MXL_Макет"), и ругается на количество "." , далее в исключение
=====
Функция ЯзыкиМакета(ПутьКМакету) Экспорт
    
    ТекстОшибки = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
        НСтр("ru = 'Макет ""%1"" не существует. Операция прервана.'"), ПутьКМакету);
    ЧастиПути = СтрРазделить(ПутьКМакету, ".", Истина);
    Если ЧастиПути.Количество() <> 2 И ЧастиПути.Количество() <> 3 Тогда
        ВызватьИсключение ТекстОшибки;
    КонецЕсли;
=====

Тут все стандартно ..
========
Функция СведенияОВнешнейОбработке() Экспорт
    
    //Данные для заполнения сведений об обработке:
    НаименованиеОбработки = ЭтотОбъект.Метаданные().Синоним;                     // Возьмем из синонима
    ВерсияОбработки = СтрЗаменить(ЭтотОбъект.Метаданные().Комментарий,"v","");    // Возьмем из комментария
    ИнформацияПоОбрабтке = "Внешния печатная форма";                            // Произвольное описание
    
    //Массив назначений
    МассивНазначений = Новый Массив;
    УказанныеТипы = ЭтотОбъект.Метаданные().Реквизиты.Документ.Тип.Типы();      // Возьмем типы из реквизита "Документ"
    Для Каждого УказанныйТип ИЗ УказанныеТипы Цикл
        ОбъектМетаданных = Метаданные.НайтиПотипу(УказанныйТип);
        Если ОбъектМетаданных <> Неопределено Тогда
            МассивНазначений.Добавить("Документ." + ОбъектМетаданных.Имя);
        КонецЕсли;    
    КонецЦикла;    
    
    //Добавляемые команды на формы документов
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    ДобавитьКоманду (ТаблицаКоманд, НаименованиеОбработки, "ПФ_MXL_Макет", "ВызовСерверногоМетода", Истина, "ПечатьMXL");
    
    //Заполняем структуру сведений
    ПараметрыРегистрации = Новый Структура;
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма");                     // Варинаты: ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов...
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);          // Массив документов, обрабатываемых обработкой
    ПараметрыРегистрации.Вставить("Наименование", НаименованиеОбработки);     // Имя под которым обработка будет зарегестрирована в справочнике внешних обработок
    ПараметрыРегистрации.Вставить("Версия", ВерсияОбработки);               // Версия обработки, которая будет отображаться в справочнике внешних обработок
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);                   // Включение безопасного режима
    ПараметрыРегистрации.Вставить("Информация", ИнформацияПоОбрабтке);        // Описание обработки для пользователя
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);                // Таблица команд, добавляемых в систему
    Возврат ПараметрыРегистрации;
    
КонецФункции
========
   serg999
 
1 - 04.06.21 - 14:26
Вопрос закрыт .. добавил в УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию параметр ПолныйПутьКМеакету
   Target1025
 
2 - 05.06.21 - 12:30
(1) и как у вас выглядит полный путь к макету?

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.