Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Поймать момент записи документа

Поймать момент записи документа
Я
   Масянька
 
04.06.21 - 11:02
День добрый!
УПП 8.1.0.17.
На основании корректировки реализации вводится СФ (гиперссылка в док-те).
По алгоритму - новый док-т СФ + заполнение (не сохраняется).
Вылезла ошибка (у себя вижу): несколько док-т отрабатывает алгоритм правильно (СФ создается, но не сохраняется), и тут, бац, док-т, СФ и СФ сохраняется (алгоритм тот же самый).
Как поймать?
Спасибо.
 
 Партнерская программа EFSOL Oblako
   Масянька
 
1 - 04.06.21 - 11:03
Парни, отбой - нашла...
   ДенисЧ
 
2 - 04.06.21 - 11:04
А кто-то вчера утверждал(-а), что читает документацию...
   Масянька
 
3 - 04.06.21 - 11:07
(2) В данном случае документация не поможет.
УПП переписана в хлам. Причем, такой, что ... (непереводимая игра слов с использованием местных идиоматических выражений).
Вот кусок кода:
    Если ВерсияПостановления = 2 Тогда
        Если СчетФактураБезНДС <> ПараметрыСФ.СчетФактураБезНДС Тогда
            СчетФактураБезНДС = ПараметрыСФ.СчетФактураБезНДС;
            РеквизитыОбновлены  = Истина;
        КонецЕсли;
        
        Если РеквизитыОбновлены Тогда
            Записать(РежимЗаписиДокумента.Запись);
        КонецЕсли;
                
        Если ЭтоНовый() Тогда
            УстановитьКодВидаОперации();
        КонецЕсли;
    КонецЕсли;
Чем поможет документация?

Список тем форума
 
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.