Вход | Регистрация
 

Обновление на ЗУП 3.1.18.46 - ошибка. Есть кто уже обновлял на эту версию?

Ø [Фрэнки, 03.06.21 - 18:30]
Обновление на ЗУП 3.1.18.46 - ошибка. Есть кто уже обновлял на эту версию?
Я
   Volga_Volga
 
03.06.21 - 18:27
https://c.radikal.ru/c41/2106/33/bc87f32d8e3c.png

Ошибка в модуле ОбновлениеИнформационнойБазыСлужебный

// Проверить корректность заполнения параметров выборки данных обработчика обновления.
//
// Параметры:
//   ПараметрыВыборки - см. ОбновлениеИнформационнойБазы.ДополнительныеПараметрыВыборкиДанныхДляМногопоточнойОбработки
//
Процедура ПроверитьПараметрыВыборки(ПараметрыВыборки)
    
    СпособВыборки = ПараметрыВыборки.СпособВыборки;
    ИзвестныйСпособ = (СпособВыборки = ОбновлениеИнформационнойБазы.СпособВыборкиИзмеренияНезависимогоРегистраСведений())
                  Или (СпособВыборки = ОбновлениеИнформационнойБазы.СпособВыборкиРегистраторыРегистра())
                  Или (СпособВыборки = ОбновлениеИнформационнойБазы.СпособВыборкиСсылки());
    Если Не ИзвестныйСпособ Тогда
        ШаблонСообщения = НСтр(
            "ru = 'Укажите способ выборки в процедуре регистрации данных к обновлению.
            |Указывается в ""Параметры.ПараметрыВыборки.СпособВыборки"".
            |Сейчас указан неизвестный способ выборки ""%1"".'");
        ВызватьИсключение СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ШаблонСообщения, СпособВыборки);
    КонецЕсли;
    
    ТаблицыУказаны = Не ПустаяСтрока(ПараметрыВыборки.ПолныеИменаОбъектов)
                 Или Не ПустаяСтрока(ПараметрыВыборки.ПолныеИменаРегистров);
    Если Не ТаблицыУказаны Тогда
        ВызватьИсключение НСтр(
            "ru = 'Укажите обрабатываемые таблицы в процедуре регистрации данных к обновлению.
            |Указывается в ""Параметры.ПараметрыВыборки.ПолныеИменаОбъектов"" и/или
            |""Параметры.ПараметрыВыборки.ПолныеИменаРегистров"".'");
    КонецЕсли;
    
КонецПроцедуры


Поиск данных для обработчика обновления "РегистрыСведений.ПодписываемыеВидыЭД.ОбработатьДанныеДляПереходаНаНовуюВерсию"

Что это за нафик? В этой части никаких изменений в базе не было.
Подскажите, как решить?
 
 Партнерская программа EFSOL Oblako
   Фрэнки
 
1 - 03.06.21 - 18:30
Вы хоть немного темы на первой странице хотя бы просматриваете прежде чем новую шлепать?!
   Фрэнки
 
2 - 03.06.21 - 18:30

Список тем форума
 
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.