Вход | Регистрация
 

Заполнение реквизита из ресурса регистра накопления

Заполнение реквизита из ресурса регистра накопления
Я
   Dmitriy1C_Rookie
 
02.06.21 - 16:33
&НаКлиенте
Процедура ТранспортПриИзменении(Элемент)
    Проверка = ПроверкаБригады(НачалоДня(Объект.Дата), Объект.Транспорт);
    Если проверка = Ложь Тогда
        Сообщить("На машину не определена бригада");
        Объект.Транспорт = "";
    Иначе Объект.Водитель=Водитель(Объект.Дата,Объект.Транспорт)
            //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
        // Данный фрагмент построен конструктором.
        // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
        
            
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

        
    КонецЕсли
    
КонецПроцедуры
&НаСервере
Функция Водитель (АктуальнаяДата, Машина) Экспорт
    
         //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    СостояниеМашины.Бригада.Водитель КАК БригадаВодитель
        |ИЗ
        |    РегистрСведений.СостояниеМашины КАК СостояниеМашины
        |ГДЕ
        |    СостояниеМашины.Машина = &Машина
        |    И СостояниеМашины.Период = &АктуальнаяДата";
    
    Запрос.УстановитьПараметр("АктуальнаяДата", АктуальнаяДата);
    Запрос.УстановитьПараметр("Машина", Машина);
    
    РезультатЗапроса = Запрос.Выполнить();
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        // Вставить обработку выборки ВыборкаДетальныеЗаписи
    КонецЦикла;
    
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

    
    Возврат ВыборкаДетальныеЗаписи;
КонецФункции
 
 Партнерская программа EFSOL Oblako
   Dmitriy1C_Rookie
 
1 - 02.06.21 - 16:34
&НаКлиенте
Процедура ТранспортПриИзменении(Элемент)
    Проверка = ПроверкаБригады(НачалоДня(Объект.Дата), Объект.Транспорт);
    Если проверка = Ложь Тогда 
        Сообщить("На машину не определена бригада");
        Объект.Транспорт = "";
    Иначе Объект.Водитель=Водитель(Объект.Дата,Объект.Транспорт)
            
        
    КонецЕсли
    
КонецПроцедуры

&НаСервере
Функция Водитель (АктуальнаяДата, Машина) Экспорт
    
         
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    СостояниеМашины.Бригада.Водитель КАК БригадаВодитель
        |ИЗ
        |    РегистрСведений.СостояниеМашины КАК СостояниеМашины
        |ГДЕ
        |    СостояниеМашины.Машина = &Машина
        |    И СостояниеМашины.Период = &АктуальнаяДата";
    
    Запрос.УстановитьПараметр("АктуальнаяДата", АктуальнаяДата);
    Запрос.УстановитьПараметр("Машина", Машина);
    
    РезультатЗапроса = Запрос.Выполнить();
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        // Вставить обработку выборки ВыборкаДетальныеЗаписи

    КонецЦикла;

    
    Возврат ВыборкаДетальныеЗаписи;
КонецФункции
   Dmitriy1C_Rookie
 
2 - 02.06.21 - 16:35
как из запроса выбрать нужное, чтобы поместить в реквезит документа?
   Dmitriy1C_Rookie
 
3 - 02.06.21 - 16:39
Ресурс бригада ссылается на документ "Состав бригады" хочу из него вытащить Работника1,2 и водителя
   Greeen
 
4 - 02.06.21 - 17:29
Вот это:
 Возврат ВыборкаДетальныеЗаписи;

заменить на 
 Возврат ВыборкаДетальныеЗаписи.БригадаВодитель;

Что то, скорее всего, подставится
   acht
 
5 - 02.06.21 - 18:06
(4) И поместить внутрь цикла  Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.