Вход | Регистрация
 

Проверка в регистре сведений

Проверка в регистре сведений
Я
   Dmitriy1C_Rookie
 
02.06.21 - 13:07
Хочу в событии "при изменении" проверить есть ли в Регистре Накопления запись, что бригада на машину собрана (каждый день в начале дня проводится документ "СоставБригады". В другом документе хочу проверить собрана ли бригада на N-машину. Если нет, то выводится нет, если есть то "Есть"
&НаКлиенте
Процедура ВремяДоставкиПриИзменении(Элемент)
    

    Если НачалоДня(Объект.ВремяДоставки) < НачалоДня(Объект.Дата)+60*60*24-1
        Тогда Объект.ВремяДоставки= " ";
        Сообщить("Доставка не может быть раньше текущей даты");
    КонецЕсли;
          
КонецПроцедуры

&НаКлиенте
Процедура ТранспортПриИзменении(Элемент)
    Проверка = Проверка(Объект.Дата);
    Если проверка = Ложь Тогда Сообщить("Есть");
    Иначе Сообщить("Нет");
    КонецЕсли
    
КонецПроцедуры

&НаСервере
Функция Проверка(ТекущаяДата)
    
         //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    СостояниеМашиныСрезПоследних.Машина КАК Машина,
        |    СостояниеМашиныСрезПоследних.Бригада КАК Бригада
        |ИЗ
        |    РегистрСведений.СостояниеМашины.СрезПоследних КАК СостояниеМашиныСрезПоследних
        |ГДЕ
        |    СостояниеМашиныСрезПоследних.Период = &ТекущаяДата";
    
    Запрос.УстановитьПараметр("ТекущаяДата", ТекущаяДата);
    
    РезультатЗапроса = Запрос.Выполнить();
    

    еСЛИ РезультатЗапроса.Пустой() Тогда Результат = Ложь; Возврат Результат;
    Иначе Результат = Истина; Возврат Результат;
    КонецЕсли


            
КонецФункции
 
 Партнерская программа EFSOL Oblako
   Dmitriy1C_Rookie
 
1 - 02.06.21 - 13:07
первая часть кода не нужна
   Dmitriy1C_Rookie
 
2 - 02.06.21 - 13:08
неправильно набран запрос, а что не так
   ДенисЧ
 
3 - 02.06.21 - 13:08
1. Сначала говоришь о РН, потом в запросе РС...
2. Вопрос-то где?
   Dmitriy1C_Rookie
 
4 - 02.06.21 - 13:10
Регистр сведений. уже третий раз почему то за день путаю
   Dmitriy1C_Rookie
 
5 - 02.06.21 - 13:10
хочу сказать одно, пишу другое
   ДенисЧ
 
6 - 02.06.21 - 13:11
(5) Это своночек... Сходи к психопаталогоанатому, не запускай...
А по запросу - кто так тебя учил писать обращение к СрезПоследних()?
   Dmitriy1C_Rookie
 
7 - 02.06.21 - 13:14
Никто..
А как правильно нужно?
   Галахад
 
8 - 02.06.21 - 13:16
У объекта дата-то есть?
   Dmitriy1C_Rookie
 
9 - 02.06.21 - 13:18
Дата стандартный же реквизит
   Mankubus
 
10 - 02.06.21 - 13:20
Запрос.УстановитьПараметр("ТекущаяДата", НачалоДня(ТекущаяДата));
и тут не нужен срез последних
   Dmitriy1C_Rookie
 
11 - 02.06.21 - 13:22
Использовать просто регистр накопления?
   Mankubus
 
12 - 02.06.21 - 14:00
(11) регистр сведений. но для него не нужна периодичность. просто поле Период.
а можно вообще без регистров просто запрос к документу делать
   Mankubus
 
13 - 02.06.21 - 14:00
много вариантов. без подробного анализа нельзя однозначно советовать

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.